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1. Purpose of the document

This document contains detailed information about vectorization in the PHOTOMOD
system. It describes work with vector layers, including classifier, as well as features
used for vector objects creation and editing, and topology check of created objects.
The document also contains a description of all types of import and export in the
PHOTOMOD system.

2. About vectorization

The system provides for working with vector objects both in 2D and in 3D windows (see
the “General information” User Manual).

2.1. Main conventions and terms
This documentation uses the following concepts:

» Vector graphics — way of image objects presentation, based on using elementary
geometric objects, such as points, lines, broken lines, splines, polygons, described
by mathematical functions in contrast to raster graphics, where each object is a set
of points (pixels);

» Vector object— 2D or 3D-object of vector graphics, described by mathematical function
and belongs to one of the following objects types in the system: point, polyline, poly-
gon;

* Point — a point object, which is determined by XY coordinates in the plane and by
XYZ coordinates in space;

* Polyline — a broken line or a curve, containing a set of vertices, joined by straight or
curve line pieces called segments;

» Polygon — an areal object, which boundaries are closed polyline;

» CAD-objects - standard geometric figures, for example, ellipse, circle, rectangle, arc,
that are polylines or polygons (see Section 5.3.5);

* Vertex — a point, connecting polyline or polygon segments;
+ Segment — a straight line, connecting two vertices;

» Fragment — a part of polyline/polygon, a set of adjacent vertices/segments of poly-
line/polygon;

» Vectorization — an operation of vector objects creation on a vector layer, for example,
for generation of digital maps.
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2.2. Stereovectorization

Stereovectorization — an operation of terrain objects vectorization in stereo mode using
stereo model, that allows to create digital elevation models and 3D topographic maps.

Stereomodel builds by stereopairs during block adjustment (see the “Block adjustment”
User Manual).

Stereopair — two images for the same terrain acquired from different points of view that
have overlap area.

When viewing a stereopair in such a way that each eye can see only one of the images,
user can imagine three-dimensional (stereoscopic) picture, reproducing depth of the
real object. Stereopairs formed by airborne and space borne images are used to create
digital maps and DEM.

During survey images can have in-strip (inside a strip) and inter-strip (between strips)
overlap. For stereo effect of optimal quality images have to have the following overlap
size: in-strip overlap — at least 60% of image width, inter-strip — at least 20% of image
height.

Stereo mode — a mode when each eye can see only one of two images, with stereo-
scopic effect as a result. It is used for stereo viewing of stereo model, and it is provided
by hardware devices and monitor technical features.

ﬁ Prior to start vectorization operation it is necessary to perform block adjustment in free or non-
free model (see the “Block adjustment” User Manual).

3. Preparing to stereovectorization

3.1. Stereo image settings

When working in stereo mode to obtain the best stereo effect in created vector object
area it is recommended to tune stereo image depth. This is important when working
with “deep” images, i.e. images with a large Y-parallaxes difference in stereoscopic
viewing area.

To tune stereo place marker to necessary area and project it on object or relief surface
(see Section 3.4). Click the -~ button or press the F2 key. Images are moved in such
a way that parallax gets zero value in marker position, and the best stereo is obtained
in this point vicinity or in its “depth”.

% In order to activate Automatic adjusting parallax in stereo mode choose Service > Settings or
click &% button of the main toolbar. In Settings window select Control tab and in the section
Automatically adjust parallax in stereo mode set the Activate, with threshold checkbox.
Threshold of changing marker height is a value with which automatic adjusting parallax in stereo

mode is performed. Threshold value is specified in pixels in corresponding field.
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To restore basic stereoscopic effect “depth” click the ++ button of 2D window toolbar
or use the F3 hotkey.

To change stereo mode phase (i.e. to switch between left and right images) click the
button of 2D window toolbar or use the F11 hotkey.

To change stereo image depth use the Shift+Page Up/Page Down or Shift+mouse
wheel hotkeys.

3.2. Stereo modes

3.2.1. Anaglyph mode

In anaglyph mode a stereo image is formed using digital coding of stereopair images,
that are intended for the right and left eyes, by the “red” and “blue” colour filters corres-
pondingly. To view and measure in anaglyph stereo mode it is necessary to use dedic-
ated spectral anaglyph glasses with the same filters.

Anaglyph mode for stereo measurements does not depend on monitor and graphics
card parameters. The main disadvantage of anaglyph mode is inability to work with full
color images.

@ Anaglyph mode of stereoscopic visualization is used in HighColor or TrueColor monitor graphic
mode only.

3.2.2. Page-flipping mode

Page-flipping stereo mode provides quality stereo image using full frames. The left and
right images are shown on the screen synchronously with frames changing. Synchron-
ization of shutter glasses with vertical interlace of monitor allows to view two images at
the same time and to perform stereo measurements on them. A prerequisite of the
page-flipping mode is the presence of an appropriate video adapter, and monitor with
stereo mode support.

To work in page-flipping mode it is necessary to use shutter stereo glasses. Shutter
glasses are glasses with liquid crystals, which are synchronized with vertical interlace
of monitor. The system supports page-flipping stereo measurements mode using
shutter glasses. To learn more about using the stereo glasses and other special
equipment for stereo measurements.

3.2.3. Polarization mode

To view stereo image on stereo monitor screen, which use polarization effect to divide
the right and left images of stereopair superimposed on the screen or on a special
translucent mirror, there are special polarized glasses. Polarized 3D-glasses (in contrast
to shutter 3D-glasses) not fitted with wires and looks very similar to normal vision
glasses.
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@ Polarized 3D-glasses are included to stereo monitor delivery set, that supports this mode.

Polarized stereo glasses contain special polarized lenses with transparent polarizing
film (polarization filter) inside. This film has the ability not to pass the light rays having
a certain direction of transverse vibrations (certain direction of polarization), and does
not prevent the passage of the rays with the other polarization directions. Polarized 3D-
stereo glasses polarizing filters in the left and right lenses are orthogonally rotated rel-
ative to each other. That is why combination on the screen or on a special mirror of or-
thogonally polarized left and right stereo pair images are divided in the polarizing filter
glasses to separate images for the left and right eyes.

3.2.4. Pseudo-stereo mode
The system allows to work in pseudo-stereo mode in the block scheme window.

Pseudo-stereo — is a stereo mode, where orthogonal projection is used for left eye, and
for right eye — parallel projection with some angle to normal line. This mode allows to
display to raster layers as one stereo image.

‘ Pseudo-stereo mode has no metric characteristics and couldn’t be used for stereo measurements.

In order to turn on the pseudo-stereo mode perform the following actions:
1. Choose Service > Settings (Ctrl+Alt+P). The Settings window opens.

2. On the Windows tab set the Allow pseudo-stereo in block scheme window
checkbox.

3. [optional] To define an angle of projection to normal line, specify the Separation
parameter.

4. Click OK. To apply the changes, close block 2D-window and then open it again.
To do this choose Window » 2D-window (block).

5. The buttons are the same as buttons in stereopair 2D-window. Buttons used to turn
on and setup stereomode are added in 2D-window toolbar.

6. Choose Raster > Load georeferenced image (files) or Raster » Load georefer-
enced image (resources) and select two images to be loaded from file system or
from projects resources. The Load georeferenced image window opens.

@ See more in the “Georeferenced external data” chapter of the “Aerial triangulation” User
Manual.

10
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’. Load georeferenced images @

|:| Convert coordinate system
Input coordinate system

WGES 84 /UTM 32M (6°8.4.-12°8.0. CEBEPHOE NONYLLAPWE) Select @!
Crientation: right, geo-referencing: global coordinate system

Output coordinate system

WES 84 /UTM 32N (6%6.4.-12%.4. CepepHoe nonywapHe) Select, @!

Orientation: right, geo-referencng: global coordinate system

[] Transparent background -

[ Ok ] [ Cancel

Fig. 1. Loading images

7. [optional] To change image coordinate system set the Convert coordinate system
checkbox on (see the Section 10.5.2).

8. [optional] When loading multiple images at once the Load window opens. Select
Create separate layer for each file. After that the images loads to two separate
raster layers.

( . Loading ﬁ‘

i@' 2 files selected to load

[ Load into ane layer

R

’ Create separate layer for each file

Close

Fig. 2. Loading more than one image

9. Right click the layer with the “left” image in the Manager. In the context menu choose
the Raster layer parameters item. The Raster layer parameters window opens.

11
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i N
’. Raster layer parameters [&J
Layer 2 files (Raster)
Z position of the layer 0.0 = m
Pseudo-sterea layer | <MNone = - |
[ 0K ] | Cancel |

Fig. 3. Raster layer parameters

10. [optional] To set the layer Z level, specify a value in the Z position of the layer
field.

ﬁ This value is used as a elevation of stereo zero-parallax (not only for stereoscopic image
formed with the other layer, but for a usual raster layer when the stereo is on in block
scheme window). If current layer contains stereoscopic image formed with the other layer,

then the layer Z position, specified in the window, is applied to both layers.

11. In the Pseudo-stereo layer list select the layer with the “right” image. Raster layer
with the “left” images becomes stereo layer.

In order to estimate a result of obtained pseudo-stereo image perform the following
actions:

1. Turn on the stereo mode in the block scheme window. To do this click the &g button.

2. Turn off visibility of layer with image, selected as the “right” one, by clicking the @
button next to the layer name in the Manager.

3.3. Stereopair selection

3.3.1. Pass to adjacent stereopair

The system provides possibility to pass to the adjacent stereopair when working in 2D-
window.

ﬁ In the navigation window displays the left image of the stereopair.

@ When vectorizing lengthy objects — for example, roads or rivers, that passes through the whole
images block — it is recommended to perform vectorization by sequential passage of stereopairs.
At that the system allows to preserve marker position, zoom, parallax value and vector objects
activity during smooth continuation of 3D vectorization (see the “General system’s parameters”
User Manual).
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To pass to another stereopair use the following menu items in 2D-window Window »
Stereopairs and buttons of the Change stereopair additional toolbar.

Table 1. Brief description of the “Stereopairs” menu

Buttons and menu items Function
=» Next stereopair (Ctrl+Alt+RIGHT) to open a stereopair with next image in the strip
#= Previous stereopair (Ctrl+Alt+LEFT) to open a stereopair with previous image in the strip
it Stereopair up (Ctrl+Alt+UP) to pass to a stereopair located on one strip up
4 Stereopair down (Ctrl+Alt+DOWN) to pass to a stereopair located on one strip down
[l Select stereopair to select an arbitrary stereopair to pass to
[ Auto change stereopair (Ctrl+J) to choose the best next stereopair related to marker
position and move to it
Open reverse stereopair to swap images of opened stereopair and to rotate
image by 180 degrees

3.3.2. Pass to chosen stereopair

To select an arbitrary stereopair to pass to, choose Window > Stereopairs » Select
stereopair or click the B, button on the Change stereopair toolbar. The Select stereo-
pair window opens.

g N
. Select sterecpair @

| Adjacent stereopairs | Allimages | Parametric search

W E: Sk o OE B S

Mame

4 2
[T 680
[ 679
[T 678
[ 677
676
675
[T 674
[T 673

4 1
[7] 664
[7] 665
[7] 666
[7] 567
[7] s&a
[7] &4
[ 870
3 s71

[ OK ] [ Cancel

Fig. 4. The Select stereopair window
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On the Adjacent stereopairs tab the system displays a list of all possible stereopairs,
including those formed by non-adjacent images or images from different strips provided
that all of them are overlapped.

On the All images tab a list of all project images displays. Images of the opened ste-
reopair are marked by checkboxes.

The toolbar on the All images tab contains the following buttons:

3@ — allows to select all images;

Bz — allows to unselect all images;

23k — allows to reverse image selection in the table;

+ Em — allows to select highlighted images;

+ Om — allows to unselect highlighted images;

- k& — allows to select images, highlighted on the block scheme;
- [ — allows to highlight selected images on a block scheme.

The Parametric search tab is used to select a stereopair using parameters displayed
in the table containing the following columns:

» Score, % — a score of stereo quality for block stereopairs;

* Intersection angle, degrees - an angle between photographing beams at the current
terrain point (in marker position);

» Distance to the boundary, pix. - the shortest distance from the current marker pos-
ition to the stereopair boundary;

* Heading, degree. - rotation angle of airframe in horizontal plane measured from the
north direction (countdown of positive angles counter-clockwise when viewed from
above);

* Roll, degree. - rotation angle (roll angle) of aircraft in relation to roll axis;

* Pitch, degree. - rotation angle of aircraft to main transverse axis of inertia or angle
between aircraft roll axis and horizontal plane;

+ Basis angle, degree. - angle between photographic image base and coordinate
system plane;

* Ray angle, degree. - angle between ray and coordinate system plane;

14



PHOTOMOD 8.1 Vectorization (Windows x64)

* Projection center height, left image, m - projection center height for left image, in

meters;

* Projection center height, right image, m - projection center height for right image,

in meters;

@ Stereopair table displays a list of all stereopairs found in marker’s position and the system

automatically selects an optimal stereopair (active stereopair) there, i.e. block stereopair with
the best quality of stereo. This stereopair is assigned the highest rating.

To select an optimal stereopair (by parameters) perform the following actions:

A

1.

For VisionMap A3 projects it is not recommended to use parametric mode of stereopair selection.

In the Selection mode section specify one of the following ways of optimal stereopair
selection:

é Mode of active stereopair selection and configuring of selection parameters leads to recal-
culating of stereo quality score of all stereopairs in the table.

+ By stereo angle - allows to select an active stereopair by optimal or specified
stereo angle;

+ By distance to the boundary - allows to select an active stereopair by distance
from current point in marker’s position to stereopair’s boundary;

+ Advanced - allows to find an active stereopair which features satisfy extended
set of specified parameters values.

[optional] Specify optimal parameters values for selected mode in the Optimal
value section. To configure parameters use calculated value from active stereopair
or specify fixed value (with indication of weight percentage for the advanced mode).

[optional] Define a range of acceptable values of specified parameters in the Limits
section. The system suggests by default to specify limits (minimal and maximal
values) for stereo angle. To define a range of acceptable values of other parameters
set the Show all limits checkbox on.
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& Select stereopair ﬁ
| Adjacent stereopairs I All images Parametric search
Selection mode
@ By stereo angle () By distance to the boundary () Advanced
el Limits
Opti
Pl valuE [ show all limits
F ti ) X )
sgll:g;;ai\:e Fixed Weight on Min Maix
Intersection angle 3211° .00 5 e 99,99 Sk [T 1500 [ = soo0 [ e
Heading -45.34° 0,00 a|f 50.00 o % | © 99,99 = =
Projection Projection
5 Intersection Distance to the Basi center center
Stereopair ‘;’E‘ angle, boundary,  Heading, ® Roll.® Pitch, ° als's,, R‘?’ . height,  height,
v pix. angle. ~ angle. left right
image, m image, m
*676-675 10000 3211 4540.3 -49.34 091 -035 -0.04 098 1730539  1729.962
675-676 9545 3211 4540.8 130.66 -091 035 0.04 093 1729962  1730.539
[ OK l [ Cancel

Fig. 5. Parametric stereopair search
To pass select a stereopair on one of the tabs and click OK.
3.3.3. Automatic stereopair selection

The system provides possibility to search for the best stereopair and to pass to it auto-
matically during stereo vectorization.

To select the best stereopair automatically perform the following actions:
1. Place marker in the vicinity of the vectorization object.

2. Click the B button (Ctrl+J). The system calculate the best stereopair to pass to,
using a value of intersection angle in relation to marker.

3.4. The marker management

3.4.1. The “Marker”’ window

The system provides possibility to display current marker coordinates both in project
coordinate system and WGS-84 geodetic coordinate system, as well as marker move
to a point with specified coordinates. The Marker window is used for this purpose.

To display current marker coordinates in the project coordinate system choose Window »
Marker window or click the fgg button of the main toolbar. The Marker window opens.
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r. Marker

===

Project coordinates

G5

G049 / Mew Zealand Map Grid
¥ 258834549
Y 6585278.57
Z 2493

WGS5-84 coordinates

Latitude

Longitude |+173.861374

Height

52.36

=

Fig. 6. The Marker window

The top toolbar contains the following buttons:

+ & - allows to change marker’s position just after input of coordinates values without

clicking the ¥ button or press Enter.

« % - allows to move marker in accordance with specified coordinates;

« ¥ — allows to cancel changes and return to initial coordinates;

« % _ allows to increase number of displayed decimal places by one;

« ® - gllows to decrease number of displayed decimal places by one;

ordinates in WGS-84;

IG5 — allows to show/hide bottom part of the window to display geodetic marker co-

« Z - allows to fix the marker value by Z coordinate (Alt+Z). Is used on vectorization
and editing of lines on a constant Z (see the Section 3.4.5).

The bottom part of the window displays geodetic marker coordinates (latitude/longit-
ude/height). The toolbox contains the following buttons:

« 2¢ _ gllows to change display format of geodetic coordinates;

« % _ allows to increase number of displayed decimal places by one;

« ® - gllows to decrease number of displayed decimal places by one;

 u - allows to turn on display format of units and hemispheres;
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+ [E allows to copy coordinates to clipboard (Ctrl+C).

@ Only plane coordinates copies by default. To copy all coordinates, click the button while holding
Alt key.

In order to change marker position in project coordinate system perform the following
actions:

1. Choose the Window > Marker window or click the g button of the main toolbar.
The Marker window opens.

-'. Marker &Jﬁ

a8 v v 2o | =

Project coordinates

G049 / Mew Zealand Map Grid
¥ 258834549
Y 6585278.57
Z 2493
WGE5-84 coordinates

Latitude (-35.930853

Longitude |+173.861374

Height 52,36

Fig. 7. The Marker window

2. Input coordinates of a point to move marker to in the Project coordinates section.

@ [optional] To change marker’s position automatically just after input of coordinates values
click the & button.

3. Click the ¥ button or press the Enter key. After that marker is moved to the point
with specified coordinates.

3.4.2. Marker modes

Depending on the object of vectorization for different stereo vectorization methods the
system provides the following modes of marker work:

* moving marker mode — the marker moves arbitrarily by image “fixed” in XY plane.

Use arrow keys to move marker in XY plane. Use the Page Up and Page Down
hotkeys or rotate mouse wheel to set marker by Z.
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@ Moving marker mode is used in the system by default.

- & fixed marker mode (F6) — marker is always in the center of the screen, horizontal
parallax on it is zero.

@ In fixed marker mode a step of model move by Z is defined arbitrarily.

Fixed marker mode is intended for users who have work experience on stereo devices. The
advantage of the mode is the ability to vectorize extended objects continuously with a constant
automatic moving of image.

To place the marker on the surface of relief model in stereomode use the Page Up
and Page Down hotkeys (in XY plane) or mouse wheel rotation to move marker by
Z. To move image in XY plane use mouse or arrow keys.

« T marker=mouse mode (F4) — mouse cursor is invisible, all mouse moves lead to
marker moving without additional clicks of mouse buttons.

% This mode is used for vectorization of extended objects breaklines.

é The marker=mouse mode is not available if the alignment mode is enabled.

» orthogonal mode — allows to create orthogonal objects; in this mode marker moves
at a right angle;

* snap-to-ground mode — marker is automatically positioned on the relief;

» streamline mode — points are added continuously by set distance while mouse button
is pressed;

+ fixing by Z — marker has fixed elevation value.
é Step of marker moving along Z axis is discrete and inversely proportional to the currentimage

increase when scaling. For fast marker moving along Z use mouse wheel rotation while
holding pressed Alt key.

The system also allows to place marker on a model surface automatically using correl-
ator. The Space key is used to do this.

* [optional] If the correlator failed to work the Status panel displays the Bad point
message and the system produces warning audio signal;

* [optional] In case of successful correlator operation, correlation coefficient (Corr) and
autocorrelation coefficient (AQ) values are displayed in the Status panel.
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@ High autocorrelation coefficients may indicate that the marker is located in an area containing
contrasting, but similar and adjacent objects, mainly of anthropogenic origin, for example sections
of a railway track or road markings.

@ To configure threshold values of the correlation coefficient and autocorrelation coefficient, choose
Service ) Settings. The Settings window opens. Set the required values in the Block scheme
section of the Correlator tab (see the “Correlator settings” in the “General system’s parameters”

User Manual).

To set up marker parameters choose the Service » Settings. The Settings window
opens. It is possible to configure shape, color and size of marker in the Windows section
on the Marker (stereopair) tab (see the “General system’s parameters” User Manual).

To change horizontal parallax in stereo mode the system provides the Shift+PgUp/PhDn
hotkeys, and Shift+mouse wheel rotation.

@ For fast parallax change for high values, move the mouse while holding Alt+Shift+mouse
middle button.

To change horizontal parallax in fixed marker mode it is possible to use Shift+mouse
wheel rotation and Ctrl+Shift+mouse wheel rotation hotkeys by X and Y accordingly.
To set parallax to zero in marker position the F3 hotkey is used.

3.4.3. Snap-to-ground mode

For automatic place marker on terrain relief during stereo vectorization the system
provides the snap-to-ground mode — a mode of automatic marker following the relief.
To enable the snap-to-ground mode choose Edit > Snap-to-ground mode (T) or click
the [ button of the Vectors toolbar.

In this mode marker moves on XY plane and automatically set by Z (with correlator).

@ If the correlator failed to work the Status panel displays the Bad point message and the system
produces warning audio signal. In this case it is possible to place marker on the relief manually
using mouse wheel or the Page Up, Page Down keys.

3.4.4. Streamline mode

The system provides possibility to vectorization in streamline mode. In this mode points
add automatically by set distance.

To enable the streamline mode choose Edit » Streamline mode (Y) or click the ™,
button of the Vectors toolbar. Press Insert to create first node. Next nodes add auto-
matically when moving mouse with pressing left button. Nodes add through the distance
set in the general system’s parameters (see the “General system’s parameters” User
Manual).

% To add a node in a distance closer than specified, use the Insert key.
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@ In classifier layer the streamline mode is used with linear (L) or polygonal (P) code type.

3.4.5. Fixation of Z

To perform vectorization on a constant elevation (for example, during contour lines
creation) the system provides fixation of marker by Z mode.

To fix vectorization elevation place marker to necessary position and click the Z button
in the Marker window (Alt+Z).

3.4.6. Snapping mode

Snapping called marker movement mode, when it “sticks” to the different elements of
the vector objects on the screen (to points, midpoints, lines, etc). The mode is used for
precise spatial matching of created objects elements with elements of existing ones.

It is possible to snap created objects not only to objects located in active layer, but to
all objects on opened vector layers, as well as to elements of the object being created.

For the work in snapping and multi-snapping modes (see below) the system provides
the Edit » Snapping menu items, hotkeys and Vectors toolbar buttons (partially).

Snapping types and modes
The system supports two types of snapping:

» 2D — XY-plane marker coordinates match to coordinates of object elements, Z-height
of marker is not changed;

§ 2D snapping is used while creation an object coinciding with existing one only in XY plane.
If, for example, it is necessary to add an extension to building with different height.

» 3D - XYZ marker coordinates match to coordinates of object elements;

Both snapping types provide several modes, defining an interaction of marker with
particular elements of vector objects (see below).

The system also provides multi-snapping functionality, which allows for using several
snapping modes at once, to generate unique combinations of active snapping options.

Work in snapping mode

. For work in snapping mode only the hotkeys are used (see the “Hotkeys” User Manual).
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Table 2. Work in snapping mode

Hotkeys and “Snapping” menu items Function
¥ 3D snapping to vertices (V) when the mode was enabled with hotkey, marker
moves to the vertex nearest to the marker position
% 2D snapping to vertices (B) when the mode was enabled with hotkey, marker

moves to the vertex nearest to the marker position
without changing marker’s height value

#p 3D snapping to lines (N) when the mode was enabled with hotkey, marker
moves to the point on vector object segment, closest
to the marker position, with exact match with XYZ
coordinates

#5 2D snapping to lines (M) when the mode was enabled with hotkey, marker
moves to the point on vector object segment, closest
to the marker position, without changing marker’s
height value

Work in multi-snapping mode

The multi-snapping mode allows for using several snapping modes at once, to generate
unique combinations of active snapping options.

It is recommended to set snapping parameters before work with vector objects in multi-
snapping mode.

To specify snapping settings, select Service » Settings. Set snapping parameters at
the Snapping section of Vectors tab (see the “Settings of work with vector objects”
chapter of the “General system’s parameters” User Manual).

Set the following parameters:

» Detect radius (in pixels) — if marker is placed from the object element at the distance
of less than Detect radius, this element is highlighted by grey colour with no snapping
(moving marker);

? An element is highlighted in gray, if the default Show tips checkbox is not cleared in the
Settings (Service > Settings » Vectors) window.

» Snap radius (in pixels) — if marker is placed from the object element at the distance
of less than Snap radius, a marker snapped to this element. A label of snapping
mode used appears near it;

? A snapping label appears if the default Show labels checkbox is not cleared in the Settings
(Service > Settings » Vectors) window.

» Cache for snapping to coordinates — is used during Snapping to coordinates and
Manual snapping to coordinates;
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The Separate 2D and 3D modes checkbox allows to generate unique combinations
of active snapping options (to points, midpoints, lines, coordinates, as well as perpen-
dicular mode) separately for 2D and 3D snapping modes. The Create common vertices
on snap to lines mode checkbox allows to add vertices in snapping mode both on
marker and source line height.

@ In the 3D-snapping mode vertices are also becomes topological connected. When editing vector
objects (e.g. when cutting with a polyline), the topological connectivity of objects is not disrupted.

Q For the work in multi-snapping mode the system provides the Edit » Snapping menu items,
hotkeys and Vectors toolbar buttons.

To start working in multi-snapping mode make active one of two multi-snapping types:

Table 3. Brief description of the multi-snapping types and modes

Hotkeys and “Snapping” menu items Function

4 2D multi-snapping (2) Marker moves to vector object elements (vertices,
medians etc.), XY-plane marker coordinates match
to coordinates of object elements, Z-height of
marker is not changed,;

+4 3D multi-snapping (3) Marker moves to vector object elements (vertices,
medians etc.), XYZ marker coordinates match to
coordinates of object elements;

Make active at least one of following snapping modes:

* Snap to points (4) marker snaps to vertices of vector objects. Label
End appears near that nodes

# Snap to midpoints (5) marker snaps to medians of vector objects. In case
of detecting object segment at the distance of lower
than Detect radius, its median is highlighted by
small grey circle symbol. Label Midpoint appears
near that medians

=" Snap to lines (6) marker snaps to segments of vector objects. Label
Nearest appears near segment point closest to the
marker position

I* Perpendicular snap (7) allows to edit vector objects by moving their vertices
in directions parallel or perpendicular to adjacent
segments, as well as to move these vertices to the
segments of the edited object (or the segments of
neighboring objects) towards the perpendicular to
these segments

T} Snap to coordinates (8) allows to create polylines/polygons orthogonal to
the basic or additional coordinate system, as well
as accurately orient drawing objects regarding ver-
tices of existed vector objects

? Menu item Select a segment for a snapping (Ctrl+Space) is used during snapping to the se-
lected segment’s prolongation or parallel.
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? While activating a snapping mode with a hotkey, a highlighting of corresponding object element
or marker move to element position take place automatically if the element is at the distance
less than Detect radius or Snap radius respectively.

? In snapping mode there is a possibility to draw a part of the created object over existing one
(see Section 11.7).

Perpendicular snapping

é The perpendicular snapping mode is used only for editing already created vector objects. To
create orthogonal vector objects, use shap to coordinates or orthogonal mode.

When the perpendicular snapping mode is activated, the system allows to edit vector
objects by moving their vertices in directions parallel or perpendicular to adjacent seg-
ments:

1. Activate Select vertices when marker moves over them and Move marker to
selected vertex modes by setting the appropriate checkboxes in the Settings
(Service > Settings > Vectors) window, or click ‘4 and . buttons in the Vectors
additional toolbar.

2. Make active one of two multi-snapping types — %, 2D multi-snapping or %, 3D
multi-snapping;

3. Make active 1" Perpendicular snap mode;
4. Press and hold the Ctrl key;

5. Holding the Ctrl key move the mouse cursor to the needed vertice and press and
hold the left mouse button. The vertice and the adjacent segments would be
highlighted by white colour;

EzlvEs bk m 22 EEERREY s s @2 C EQREE|

Fig. 8. The vertice and the adjacent segments are highlighted by white colour
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6. Holding the Ctrl key and left mouse button move the marker to the different direc-
tions. Creation of guides is indicated by Perpendicular and Parallel labels in the
vicinity of a vertex, respectively.

LAY N A EWEERRA s RO L 2 S EAN R E|

Fig. 9. Moving the vector object vertex to the arbitrary direction
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Fig. 10. Moving the vector object vertex parallel to the adjacent segment
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Fig. 11. Moving the vector object vertex perpendicular to the adjacent segment
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When the perpendicular snapping mode is activated, the system also allows to move
vertices of the edited object to the segments of this object (or the segments of neighbor-
ing objects) towards the perpendicular to these segments.

When moving an object’s vertex to neighboring vector objects (or the edited object
segments), “snap points” are created (indicated by a small gray square and a Perpen-
dicular label) located at the intersection of segments and the perpendicular (gray
dashed line) originating from the location of the moved vertex:

Perform the following:

1.

Activate Select vertices when marker moves over them and Move marker to
selected vertex modes by setting the appropriate checkboxes in the Settings
(Service > Settings > Vectors) window, or click ‘4 and . buttons in the Vectors
additional toolbar.

Make active one of two multi-snapping types — «4; 2D multi-snapping or «%; 3D
multi-snapping;

Make active 1" Perpendicular snap mode;
Press and hold the Ctrl key;

Holding the Ctrl key move the mouse cursor to the needed vertice and press and
hold the left mouse button.

The vertice and the adjacent segments would be highlighted by white colour.

EnYES LWL A D FIESEEEEREY s DL 2 EAE E

Fig. 12. The vertice and the adjacent segments are highlighted by white colour

Perform one of the following:
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+ [optional] Holding the Ctrl key and left mouse button move the marker to the
direction of the edited object segments;

SoEves LNk A Y EWEERREY B2 O EANEE|

Fig. 13. Moving the vector object vertex to the arbitrary direction
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Fig. 14. Moving the vector object vertex to the arbitrary direction (the “snap point” is created —
the marker is in Detect radius)
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erpendicular”

Fig. 15. The object’s vertex snapping to the same object segment in the direction perpendicular
to the segment
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+ [optional] Holding the Ctrl key and left mouse button move the marker to the
direction of the neighboring vector objects segments;

L Eny e bk A EWEERESY s 2 L2 | EAN 8

Fig. 16. Moving the vector object vertex to the arbitrary direction
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Fig. 17. Moving the vector object vertex to the arbitrary direction (the “snap point” is created —
the marker is in Detect radius)
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Fig. 18. The object’s vertex snapping to the neighboring object segment in the direction
perpendicular to the segment
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Snap to coordinates

If Snap to coordinates mode is enabled, the system allows to build and edit poly-
lines/polygons orthogonal to the basic or additional coordinate system as well as accur-
ately orient drawing objects regarding vertices of existed vector objects.

» While creating polylines/polygons starting from the first vertice, a marker snaps to
red and green dash line guides, outgoing from the vertices of the created object and
co-directed with axes of basic or additional coordinate systems. Red guide is co-dir-
ected with X axis, green guide is co-directed with Y axis.

Guide is shown as a solid line if the marker was placed near the guide (at the distance
shorter than Snap radius), was snapped to the guide, and drawing segment of
polyline/polygon should be co-directed with corresponding axis of coordinate system.
In neighbourhood of vertices from which guides outgo labels End appear.

ﬁ Dashed guides are displayed only if default Show tips checkbox is not cleared in the Settings
(Service » Settings » Vectors) window and if the distance between the previously created
object’s vertices and the marker position does not exceed the Detect radius.

Y ESEENA R IXESE +FAY S B L2 S EAN EE]

Fig. 19. The beginning of the vector object creation in Snap to coordinates mode.
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Fig. 20. Creation of the segment, co-directed with Y axis.
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Fig. 21. Guides, outgoing from 2 previous created vertices
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Fig. 22. Guides, outgoing from 2 previous created vertices
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» If Snap to points / Snap to midpoints mode is enabled as well, while drawing
polyline/polygon in the neighborhood of existed vector objects, the guides outgoing
from the vertices (medians) of existed vector objects are also built.

To have guides from the vertices (medians) of an existing object (in the process of
a new object creation), it is needed first snap to every needed vertice (median) of
this object (see Cache for snapping to coordinates parameter above).

While snapping marker to intersection of guides, guides are shown like solid lines.
In neighbourhood of vertices from which guides outgo labels End appear.

7

7
7

The system provides for memorizing the fixed number of selected vertices of existing objects
to snap to coordinates which is determined by the Cache for snapping to coordinates option
that can be set in the Settings (Service » Settings » Vectors) window.

Maximum value for Cache for snapping to coordinates is 100. If the value of Cache for
snapping to coordinates is equal to 0, the selection of vector object’s vertices (by snapping
to them) will not result in appeared guides, and it will not be possible to set the marker on
their intersection.

Snapping functions are active not only when creating new objects but when editing positions
of the existing object’s vertices.

In default while Snap to coordinates mode is enabled guides outgo just from the vertices
of existed objects. If Snap to medians mode is enabled as well, additional guides outgoing
from segment medians are built.

BV EENKIRI I ENE - EBAM B 22 S ERN M B

Fig. 23. Guides originating both from the vertex of the created object and the neighboring object’s

vertex (snapping to the vertex of the left object was performed previously)
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“Manual” snapping to coordinates

With enabled snapping to coordinates mode, the system allows to create vertices of
vector objects in so called “manual snapping to coordinates” mode at the points of in-
tersection of the preset direction and the perpendicular from it to guides originating from
the vertices of the created object, as well as from the vertices of the existing objects (if
Snap to points is additionally activated) and the medians of object’s segments (if Snap
to midpoints is additionally activated).

For manual snapping, perform the following:
1. Create at least one polygon/polyline vertex;

2. Press and hold the left mouse button and move the marker, thus setting the direc-
tion;

P EaY @S LENAAIIYIESE +BEY s L2 ERY EE]

Fig. 24. Start of an object creation in the manual snapping to coordinates mode (when moving the
marker, press the left mouse button)

3. Holding the left mouse button, press Shift;

4. Holding the left mouse button and the Shift key, keep moving the marker. The
following will be created:
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* A solid grey guide that prolongs the direction set in paragraph 2;

» A dashed grey perpendicular from this guide to the dashed red and green guides
co-directed with the axes of main or additional coordinate systems which originate
from the vertices of the created object (and from the vertices of the existing ob-
jects, their segments, and medians of their segments, depending on the snapping
modes that are active)

» The point of intersection marking the place of the next vertex creation denoted
with a small grey x-type cross.

SNEY R AWM AIIYIESE +RBEY s B L2 ERAY R E

Fig. 25. Moving the point of the next vertex creation strictly in the direction set in paragraph 2 (both
the left mouse button and Shift button are pressed)

5. Move the marker to the desired position, release the left mouse button and the
Shift button, press the Insert button to create a new vertex at the intersection point
denoted with a small grey x-type cross.

If Snap to points / Snap to midpoints mode is enabled as well, while drawing poly-
line/polygon in the neighborhood of existed vector objects, the guides outgoing from
the vertices (medians) of existed vector objects are also built.

To have guides from the vertices (medians) of an existing object (in the process of a
new object creation), you should first snap to every needed vertice (median) of this
object (see Cache for snapping to coordinates parameter above).

ﬁ, The system provides for memorizing the fixed number of selected vertices of existing objects
to snap to coordinates which is determined by the Cache for snapping to coordinates option
that can be set in the Settings (Service » Settings » Vectors) window.

Maximum value for Cache for snapping to coordinates is 100. If the value of Cache for
snapping to coordinates is equal to 0, the selection of vector object’s vertices (by snapping
to them) will not result in appeared guides, and it will not be possible to set the marker on their
intersection.
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Fig. 26. Working in the manual snapping to coordinates mode (Snap to points is added)

AV EENA A ESE - EAFD B L 2 | EAYEE]

Fig. 27. Working in the manual snapping to coordinates mode (Snap to points and Snap to midpoints
are added)

ANV BN R PIESE - BAFA B L2 S EAN |
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Fig. 28. Working in the manual snapping to coordinates mode (Snap to points and Snap to midpoints
are added)
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Snapping to the selected segment’s prolongation or parallel

The system allows to snap to guides which are prolongations (or parallels) of the selected
segments of existing vector objects.

To do this, perform the following:
1. Load or create a vector layer with polygons and/or polylines;
2. Activate the following modes of 2D or 3D multisnapping:
* Perpendicular snap;
* Snap to lines.
3. Start the creation of a new vector object entering the first vertex;

4. Move the marker to the vicinity of the desired segment of an existing object (the
segment will be highlighted by grey colour).

Y ESEENARIIYIESE - BAEY /AR L2 S| EAN R E]

Fig. 29. The marker moved to the vicinity of the segment of an existing object, the segment is
highlighted

5. Choose Edit > Snapping > Select a segment for a shapping (or use Ctrl+Space
hotkeys) to select this segment;

% Press Esc to disable this selection.

6. Perform one of the following actions:
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* [optional] move the marker to the vicinity of the new vector object first vertex. A
guide is created which is the parallel of the selected segment of the existing object.
Use this guide to create a segment which is the parallel of the selected segment
of the existing object;

VS LEWRI A IYIESE B AEY AR L 2 S EAY |

Fig. 30. A guide which is the parallel of the selected segment of the existing object

* [optional] move the marker to the vicinity of the desired segment of an existing
object once more. A guide is created which is the prolongation of the selected
segment of the existing object. The point where the guide and the created segment
of the new object are decussate is indicated by a small gray square;

P EEYESEENA R ESE | BEAY,EARB L2 S EAN B E]

Fig. 31. The guide that is the prolongation of the selected segment of the existing object
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Perform one of the following:

o [optional] To create a vertex of a new object at an arbitrary point of a guide,
move the marker to the guide of interest (in the vicinity of the marker a label
Nearest appears). Enter a new vertex.

L ExY s Nkl ADYENE - BeY/ ERD L2 S EAY D

Fig. 32. Creating a new object vertex at an arbitrary point of the guide

o [optional] To create a new object segment perpendicular to a guide, move the
marker in the final point of the guide (in the vicinity of the marker, the label
Perpendicular appears). Enter a new vertex.

L EAn¢Yes b kAP ESE - BEY s Fn) L2 - ZAY 8

Fig. 33. Creating a segment perpendicular to the guide
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3.5. Creation of “stereo quality” map

The system allows to estimate stereo quality for images block that contains stereopairs.
The principle of building a stereo “quality maps” is as follows. Stereopair with the best
stereo quality is automatically formed from images. This stereopair is then used by the
system for evaluation of other characteristics of other stereopair, as well as their quality
score.

Stereo “quality map” is a grid which nodes are colored in images overlap areas according
to assigned score.

c To create stereo “quality map” it is necessary to complete block adjustment step (see the “Block
adjustment” User Manual).

To create stereo “quality map” perform the following actions:

1. Select Grid » Properties to create a grid. After that the Grid layer creates in the
Manager and the Grid properties window opens.

r. Grid properties [ﬁr

X step 100.000

L3

m

Y step 100,000 | m

Al
=]

Rotation  0.000

Z level 50.000 = m
Mean GSD 0. 130 m
Ok ] | Cancel | | Apply

Fig. 34. Regular grid parameters

2. Setagrid step by Xand Y in the X step and Y step fields.

@ The less the grid step, the more time is needed for creating the map of stereo quality.

3. Click OK. The grid is displayed in 2D-window on the images block as a set of nodes
of the same colour according to specified step by X and Y.

4. Place marker to overlap area on any stereopair of images block in 2D-window.

5. Choose Vectors » Create stereo quality map. The Select stereopair window
opens.

38


solver.pdf
solver.pdf

PHOTOMOD 8.1

Vectorization (Windows x64)

. Select stereopair &]
Parametric search
Selection mode
@ By stereo angle () By distance to the boundary () Advanced
L val Limits
Opti
pimal vale [ Show all limits
F ti X . .
sgzl'n;:;ai\:e Fixed Weight on Min Maix
Intersection angle 32.11° 2000 |2 e 99,99 % O 1500 - s0.00 2] e
Heading -49.34°  0.00 = 50.00 Yo 0.00 ol 99,99 =
Projection Projection
Score Intersection Distance to the Basic center center
Stereopair o, ang;le, bour_ldarjr, Heading, ® Roll, * Pitch, angle,® angle, ® height, he_lght.
pix. left right
image, m image, m
*676-675  100.00 3211 4540.8 -49.34 09 035  -0.04 0.98 1730.538  1729.962
675-676 9545 3211 4540.8 130.66 -0.91 035 0.04 0.98 1729962  1730.539
[ OK ] I Cancel

Fig. 35. Parametric method of stereopair selection

Stereopair table displays a list of all stereopairs found in marker position. The system
selects automatically an optimal stereopair — block stereopair with the best stereo-
scopic effect. This stereopair is assigned the highest rating.

For each stereopair in the table the following parameters values are shown:

Score, % — a score of stereo quality for block stereopairs;

Intersection angle, degrees - an angle between photographing beams at the
current terrain point (in marker position);

Distance to the boundary, pix. - the shortest distance from the current marker
position to the stereopair boundary;

Heading, degree. - rotation angle of airframe in horizontal plane measured from
the north direction (countdown of positive angles counter-clockwise when viewed
from above);

Roll, degree. - rotation angle (roll angle) of aircraft in relation to roll axis;

Pitch, degree. - rotation angle of aircraft to main transverse axis of inertia or
angle between aircraft roll axis and horizontal plane;

Basis angle, degree. - angle between photographic image base and coordinate
system plane;

Ray angle, degree. - angle between ray and coordinate system plane;
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* Projection center height, left image, m - projection center height for left image,

in meters;

* Projection center height, right image, m - projection center height for right

image, in meters;

6. [optional] To select an optimal stereopair manually perform the following actions:

7

1.

It is not recommended to select parameters manually for VisionMap A3 projects.

In the Selection mode section specify one of the following ways of optimal
stereopair selection:

% Mode of active stereopair selection and configuring of selection parameters leads to
recalculating of stereo quality score of all stereopairs in the table.

» By stereo angle - allows to select an active stereopair by optimal or specified
stereo angle;

* By distance to the boundary - allows to select an active stereopair by dis-
tance from current point in marker’s position to stereopair’s boundary;

» Advanced - allows to find an active stereopair which features satisfy extended
set of specified parameters.

[optional] Specify optimal parameters values for selected mode in the Optimal
value section. To configure parameters use calculated value from active ste-
reopair or specify fixed value (with indication of weight percentage for the ad-
vanced mode).

[optional] Define a range of acceptable values of specified parameters in the
Limits section. The system suggests by default to specify limits (minimal and
maximal values) for stereo angle. To define a range of acceptable values of
other parameters set the Show all limits checkbox on.

7. Click OK. After that the system generates stereo quality map in 2D-window and the
new Stereo quality map layer appears in the Manager.

The layer is a grid, which each node is assigned the following attributes values,
corresponding to selected parameters of the table:

» quality — quality score assigned to the stereo, depending on which a node in

images overlap areas is colored;

* st ang — angle of stereo between photographing beams at the current terrain

point (in marker position), corresponds to the table parameter;
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* heading — heading, rotation angle of airframe in horizontal plane measured from
the north direction (countdown of positive angles counter-clockwise when viewed
from above);

* roll — Roll, degrees;

* pitch - Pitch, degrees;

* basis roll — Basis roll, degrees;

* nadir_ang — Ray angle, degrees;

* bounds dist pix — Distance to boundary, pix;
+ overlap pix — overlap value, pix;

* [for central projection images only] z 1, z r — projection center elevation for
the left and right image, in meters;

» code im 1, code im r—codes of left and right images, that compose a stereopair,
according to assigned code in the Catalogue of exterior orientation parameters
(see the “Aerial triangulation” User Guide).

1:1:3 Block scheme 5 x

U+ e ([@EDQ EEE e AP MA

Y+ 2WEHSS
-1 Marker
B & . I+ * Stereo quality map (Vectors)
® > . I * Grid
® > QuickTies
s > D 4 Block scheme
Strip narnes
Image names
Strip outlines
Image outlines
> Raster

CECRCRCRC

4 m 3

3 i [o 1] % i [w[=)=] @@ (a

530769.134773 m; 5410279,129072 m; 0.000000 m (R.=22| Cartesian Right

Fig. 36. Stereo quality map
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To evaluate intersection angles in the images of the project, perform the following:
1. Create a “stereo quality” map for the block of images;

2. Change “stereo quality” map coloring according to the st ang attribute values
(Vectors » Attributes > Color by attribute value, see Section 7.5.4);

3. To obtain information on the st ang attribute value for the selected stereo quality
map node, select the appropriate stereo quality map node and choose Window »
Objects attributes.

3.6. Measurements on images
The system provides possibility to perform measurements on images.

To go to measurements mode use the Measurements window.

( . Measurement £

Save measurements to layer
X 579912.577 = ¥ 5410547.801 = Z 0,000 =
X¥p 530002.577 Yp  5409375.801 Zp  0.000

dx -90.000 = dY &72.000 | dZ 0.000 =
5 578.000 $ D &78.000 +1 dZ/D 0.000

Se

sy 973741 [P |— = 00000

Fig. 37. The Measurements window
The window contains fields with marker coordinates values:
« X — marker X geodetic coordinate;
* Y- marker Y geodetic coordinate;
* Z— marker Z geodetic coordinate;
* Xp — marker Xp geodetic coordinate;
* Yp — marker Yp geodetic coordinate;
» Zp — marker Zp geodetic coordinate;
* dX - current segment incrementation by X;

» dY - current segment incrementation by Y;
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* dZ - current segment incrementation by Z;

Besides, the Measurements window contains fields with values of the following para-
meters of segment:

+ S - alength of segment (on the flat surface);

+ Se — a length of geodesic curve on the surface of the ellipsoid (from the current co-
ordinate system);

é If the project coordinate system is Cartesian or Local Curved, this field remains empty.

* D - alength of horizontal distance (projection on a plane) of segment by Z;

* dZ/D - a value of segment slope (Z increment ratio to the horizontal distance);
» & — direction of current segment relative to X axis;

= — direction of current segment relative to previous one;

» =% — vertical angle of current segment.

Do the following actions to perform measurements:

1. Choose Window » Measurements window (Ctrl+Alt+D) or click the % button of
the main toolbar to turn on the measurements mode. The Marker layer becomes
active and the Measurements window opens.

( . Measurement £

Save measurements to layer
X 579912.577 = ¥ 5410547.801 = Z 0,000 =
Xp 580002.577 Yp  5409375.801 Zp  0.000

dx -90.000 = dY &72.000 + dZ 0.000 =
5 £78.000 1 D 678.000 + dZ/D 0.000

Se

sy 973741 [P |— = 00000

Fig. 38. The Measurements window

2. [optional] To save measurements to separate layer as vectors set the Save
measurements to layer checkbox.

@ The layer with measurements is used for example as error vectors to convert vector objects
(see Section 10.1.4).
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3. Place marker to start point of measurement and press Insert.
@ During measuring the system creates temporary line (“rubber line”), that disappears after

exit from measurements mode. To start temporary line creation click the *— button.

4. Use the Page Up and Page Down hotkeys or rotate mouse wheel to set marker
by Z.

5. Place marker to next point of measurement and press Insert. Parameters of created
segment are displayed in the Measurements window.

@ Measurements are performed between current marker position and the last point where
the Insert key was pressed.

@ The system provides possibility to input using keyboard marker geodetic coordinates and
segment parameters to fields of the Measurements window. Marker moves to a point with
specified coordinates and segment parameters after pressing the Enter key.
6. To complete measurements, close the Measurements window.
@ To leave the Marker layer active, close the Measurements window holding pressed Ctrl

key.

@ The system provides possibility to make measurements both in 2D-windows during stereo
vectorization, and in the Points measurement.

4. Vector layer creation

There are two vector layer types supported by the program:

* vector layer without classifier —is a vector objects layer without thematic classification;
o co-editing vector layer without classifier.

* vector layer with classifier — is a vector objects layer assigned to a classifier;

To create a vector layer without classifier select Vectors » Create layer. After that the
Vector layer is created in the Manager and it has a serial number (starting from the
second).

To create a co-editable vector layer, first create a vector layer without a classifier.
Choose Vectors > Save as. In the window that opens, choose Co-editable vector
objects (*.cx-data) in the appropriate drop-down list. Set the name and path to save
a layer in the active profile resources and click Save.

PHOTOMOD Geomosaic program primarily creates vector layers available for collaborative
editing, with automatic creation of so-called cutlines (special topologically connected vector
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polygons, see “Cutlines creation” in the “Orthophotomaps creation” User Manual and the recom-
mendations in Section 16).

To create a vector layer with classifier select Vectors > Create layer with classifier.
After that the Veector layer is created in the Manager and it has a serial number (starting
from the second) and the Classifier window opens.

4.1. Vector layer display settings

It is possible to adjust color, symbols and symbol size of objects in the vector layer
without classifier, (and also for the pre-regions, points and contour lines layers).

To change colors and symbols of objects perform the following:

1. Double-click on layer objects color button ([_]) in a Manager layer. The Raster
layer parameters window opens.

r 1
. Layer display settings [i:_?-]
Layer: Stereo quality map (Vectors)
Colors Symbaols
Active object Curve control nodes Point (@ Symbol
o trol li . s
Hrve contratlines Selected line vertex Point @ Symbol |::,:

Curve control nodes -

Selected vertex Point (@ Symbol
Selected line vertex

Line vertices @ Point Symbol 3 % pix
Selected vertex e
objects without cassifier [JJJll  Point objects @ Point () Symbol 3 3] pix
Moved objects Vertices in active line Point @ Symbol | , =
Labels

Selected point objects Point @ Symbol | , =
Paint numbers

Selected points @ Point Symbol 5 % pix
Rubber line

Lines
Selected objects S —

Style —————————— ~|Width 1 .
Selected points
P Label Font
Elevation labels Custom M5 Shell Dig 2, 8
| K. | | Cancel | | Apply

Fig. 39. Raster layer parameters
2. Double-click on the object’s color in the Colors section and choose necessary
color from standard color palette.

3. Inthe Symbols section define a symbol size in pixels and choose a symbol to dis-
play objects.
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A\
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Itis recommended to use ordinal symbol size to display points position correctly, otherwise
points moved from a current position.

Point objects of vector layer could be displayed both symbols and point with defined size.

4. Setthe Lines section set the lines Style and Width;

5. To setthe custom label font set the appropriate checkbox in the label font section;

6. Click the Apply button to display changes in 2D-window.

7. Click OK to save parameters.

7

The vector layer display settings are saved and will be displayed when the vector layer
reopens from the resources.

5. Vector objects

5.1. The “Vectors” toolbar

For quick access to functions of vector objects creating and editing, and also to change
modes with vector objects work the system provides the Vectors additional toolbar,
which buttons partly duplicate the Edit menu items. To show the Vectors toolbar choose
Window > Toolbars » Vectors.

Table 4. The Vectors toolbar

Buttons Function
Fa to enable point objects input mode (P) (see Section 5.3.1)
Feg to enable non-closed polylines input mode (L) (see Section 5.3.2)
e to enable polygons input mode (G) (see Section 5.3.3)
5| to enable creating mode of polylines and polygons as smooth lines (see Section 8.6.2)
& to enable CAD-objects creating mode (see Section 5.3.5)
i to enable roofs creating mode (see Section 5.3.6)
[ to enable orthogonal input mode of vector objects (see Section 5.3.4)
Iy to enable orthogonal input mode of vector objects for additional coordinate system (see
Section 5.3.4)
., to enable streamline input mode of vector objects (see Section 3.4.4)
B to turn on tracing mode (see Section 3.4.3)
7] to enable vertices editing mode (see Section 8.4.1)
oF to convert selected broken lines to smooth ones (see Section 8.6.3)
b to convert selected smooth lines to broken ones (see Section 8.6.3)
- to recalculate automatically smoothing of curve line segments during editing (see Sec-

tion 8.6.4)
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Buttons Function

S to enable curve check points editing (see Section 8.6.5)

S to preserve the smoothness during editing of check points (see Section 8.6.5)

+ to select a vertex, located in marker area on a distance specified in the Swath field
(Service > Settings » Vectors)

. to move marker to the selected vertex automatically (see the “Settings of vector objects
display” chapter of the “General system’s parameters” User Manual)

5 to turn on/off 2D multi-snapping mode (see Section 3.4.6)

% to turn on/off 3D multi-snapping mode (see Section 3.4.6)

i to turn on/off Snapping to points mode (see Section 3.4.6)

o to turn on/off Snapping to medians mode (see Section 3.4.6)

& to turn on/off Snapping to lines mode (see Section 3.4.6)

I" to turn on/off Perpendicular snapping mode (see Section 3.4.6)

[ to turn on/off Snapping to coords mode (see Section 3.4.6)

R to create additional (user) coordinate system which is used as a helping vectorization
tool together with Snapping to coords function: (see Section 8.8)

& to change default axes direction of additional coordinate system (see Section 8.8)

= to delete additional coordinate system (see Section 8.8)

== to hide/show the classifier window (see Section 6)

to hide/show the objects attributes window (see Section 7)

i} to open window that allows to choose autofilled layer attributes (see the Section 7.4.4)

i to refresh values of autofilled attributes (see Section 7.4.4)

to calculate density of canopy

5.2. Types of vector objects

The system supports the following types of 3D vector objects:

point — point 3D objects, defined in the space by X, Y, Z coordinates (see Sec-
tion 5.3.1);

polyline — closed/opened broken line or smooth curve, which consists of vertices
connected by segments — straight or curve lines (see Section 5.3.2;

polygon — an areal object, which boundaries are closed polyline (see Section 5.3.3;

CAD-objects standard geometric figures, for example, ellipse, circle, rectangle, arc
(see Section 5.3.5);

During vector objects creation use the tools for stereomarker managing (see Section 3.4).

7

The system provides possibility to synchronously display marker position in multiple opened
windows for created vector objects. To do this use the Edit » Sync markers menu item.
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To increase vectorization performance the system provides possibility to use special
3D or multibutton mice, as well as to use programming of buttons of usual mouse to
perform particular operations (see the “General system’s parameters” User Manual).

To draw or edit vector objects, create, load or make active vector layer in the Manager
panel.

For quick access to modes and functions of vector objects editing, use buttons of the
Vectors additional toolbar (see Section 5.1).

5.3. Creation of vector objects

5.3.1. Points creation
Perform the following actions for creating a point:

1. Choose Edit » Vectors create mode > Points (P) or click the ;" + button of the
Vectors additional toolbar to turn on points creation mode.

2. Place marker to selected point on image in 2D-window.
3. Press Insert to create a point.

5.3.2. Polylines creation

Perform the following actions for creating a polyline:

1. Choose Edit > Vectors create mode > Polylines (L) or click the 4 button of the
Vectors additional toolbar to turn on polylines creation mode.

2. For each polyline vertex perform the following actions:
» place marker to selected point on image in 2D-window;
» press Insert to create a vertex.

3. Press Enter or Esc to complete polyline creation.

To close a polyline while its creation select Vectors > Topology » Close selected
polylines or use the Shift+C hotkeys after input of the last vertex (see Section 11.4.1).
See description of orthogonal polyline creation in the Section 5.3.4.

5.3.3. Polygons creation
Perform the following actions for creating a polygon:

1. Choose Edit > Vectors create mode > Polygons (G) or click the 4 button of the
Vectors additional toolbar to turn on polygons creation mode.
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2. For each line vertex:
» place marker to selected place on image in 2D-window;
» press Insert to create a vertex.

3. Press Enter or Esc to close polygon and end its creation.

See description of orthogonal polygon creation in the Section 5.3.4.
5.3.4. Creation of orthogonal objects

During vectorization of some types of vector objects (buildings, for instance) polyline
or polygon should be composed of segments connected to each other at right angles.

To do this use the following modes of vector objects creation:
* Orthogonal mode;
* Orthogonal mode for additional coordinate system;

» Snap to coordinates mode.

@ These modes are used during creation of both polylines and polygons (see Section 5.3.3 and
Section 5.3.2).

In order to enable orthogonal mode of vector objects creation use one of the following
ways:

« if it is necessary to make part of a line with right angle, when you enter the next line
segment, press and hold the A key; to continue the line in usual mode, release the
key;

« click the [*4 button of the Vectors additional toolbar or choose Edit » Orthogonal
mode to enable continuous orthogonal vectorization mode.

@ To close a polyline in orthogonal mode after entering of the last vertex select Vectors > Topo-
logy > Close selected polylines or use the Shift+C hotkeys, and then press Esc (see Sec-
tion 11.4.1).

@ In order to finish the vector object to a rectangular shape, after entering the last vertex use
hotkeys A+Enter (or press Enter, if the orthogonal mode is on). As a result, the last vertex of
a vector object is moved so that the object takes a rectangular shape.

@ To move the first vertex use the A+Ctrl+Enter hotkeys (or Ctrl+Enter, if the orthogonal mode
is on).

In order to enable orthogonal mode of vector objects creation for additional coordinate
system perform the following:
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1. create additional coordinate system and change its default axes direction;

2. click the [ button of the Vectors additional toolbar or choose Edit > Orthogonal
mode in coordinate system to enable continuous orthogonal vectorization mode
in additional coordinate system.

Created vector objects will be orthogonal to the axes of the additional coordinate system,
and their directions are user-defined.

In order to enable Snap to coordinates mode of vector objects creation use one of the
following ways:

» choose Edit» Snapping» 2D snapping or Edit » Snapping » 3D snapping to enable
continuous 2D snapping or 3D snapping mode (see Section 3.4.6). Choose Edit »
Snapping > Snap to coordinates to enable continuous Snap to coordinates mode;

» press the B key to enable continuous 2D snapping mode. Press the M key to enable
continuous Snap to coordinates mode;

« click the < or «%; button of the Vectors additional toolbar to enable continuous 2D
snapping or 3D snapping mode. Click the T button of the Vectors additional toolbar
to enable continuous Snap to coordinates mode.

See the detailed description of working in Snap to coordinates mode in the Sec-
tion 3.4.6.

The system also allows to edit vector objects moving their vertices in directions parallel
or perpendicular to the adjacent segments, as well as to move these vertices to the
segments of the edited object (or the segments of the neighboring objects) towards the
perpendicular to these segments using the perpendicular snapping mode.

See the description of orthogonality control in the Section 10.2.6.
5.3.5. CAD-objects creation

To create vector objects of standard geometric shape click the ¢&! button of the Vectors
additional toolbar, or choose Window > Toolbars » CAD objects or choose Edit »
Vectors create mode » CAD objects. The CAD objects window opens.
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(@ CAD objects - |
o0 L NOo

|Axis, arbitrary direction - |

| Dimensions
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Fig. 40. Menu for CAD-objects creation

The »~ button allows to open the options bar for each object type, in accordance with
which the object is created.

Table 5. Functionality of the CAD objects window

Buttons Function

= Ellipse creation ways:

» Axis, arbitrary direction — allows to set a size of one of axes; another axis is created
at arbitrary direction from the specified one;

» Axis, fixed direction — allows to set a size of one of axes; second axis is built strictly
perpendicular to a given one;

» Center, arbitrary direction — allows to set a center and a size of one of axes; another
axis is created at arbitrary direction from the specified one;

« Center, fixed direction — allows to set a center and a size of one of axes; second
axis is built strictly perpendicular to a given one;

o Round creation ways:
» 2 points — allows to specify a diameter of the round created;
» Center, radius — allows to specify the round center and radius;

» 3 points — allows to create a round using three points.

™ Arc creation ways:

» 3 points — allows to create a arc using three points, the first point is the beginning of
the arc;

» Center, arbitrary radius — allows to draw an arc with arbitrary radius, the first point
is the center of the arc;

» Center, fixed radius — allows to draw an arc with fixed radius, the first point is the
center of the arc;
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Buttons

Function

2]

Sector creation ways:
» Center, arbitrary radius — allows to set center, drawing direction and arc radius;

* Center, fixed radius — allows to set center, arc radius and size;

Segment creation ways:

» Start, end, arc — allows to set start and end points of straight part of segment and arc
size;

» 3 points — allows to create segment using three points, the first point is the beginning
of the segment;

» Center, arbitrary radius — allows to set center, drawing direction and arc radius;

* Center, fixed radius — allows to set center, arc radius and size;

Rectangle creation ways:
» 3 points — allows to specify three vertices of the rectangle;

» Axis, arbitrary direction — allows to set a center and a size of one of sides; the
second size is created at arbitrary direction from the specified one;

« Axis, fixed direction — allows to set a center and a size of one of sides; second axis
is built strictly perpendicular to a given one;

Polygon creation ways:
» 2 points — allows to create a polygon using two specified points.

» Center, radius — allows to set center, drawing direction and polygon radius;

% Creation of any type of CAD-objects starts from pressing the Insert key.

Perform the following actions to create CAD-object of arbitrary type (ellipse, round, arc,
sector or segment):

1. Click one of buttons of the CAD objects window toolbar.

2. Specify approximation accuracy in the Precision field.

7

CAD-objects, presented in the form of curves are approximated by broken lines, that is
why, curvature of the object can be measured by approximation precision, that is maximal
distance from broken line segment to the curve between its two closest vertices. Creation
precision could be specified for objects that contain curvy parts (ellipse, round, arc, sector,
segment). This parameters default value is — 0.5, in measurement units of current project.

3. Press Insert to start create object.
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4. Move mouse and press Insert to specify parameters and size of the object.

5. To complete drawing press Enter, to cancel object creation — Esc.

@ To create in a layer with classifier linear CAD-objects (arcs), select in classifier type (L), if it is
necessary to create areal object — select type (C) (see Section 6).

Perform the following actions to create polygon:

1. Click the & button of the CAD objects window toolbar.

@ CAD objects |
o0 L NO[gN

| 2 paint - |

e
w

Mumber of vertices 3

Fig. 41. Menu for CAD-objects creation

2. Specify number of polygon vertices. By default creates polygons with 3 vertices.

é It is possible to create polygon with up to 500 vertices.

3. Press Insert to start create object.

4. Move mouse and press Insert to specify parameters and size of the object.
5. To complete drawing press Enter, to cancel object creation — Esc.

Perform the following actions to create rectangle:

1. Click the 1 button of the CAD objects window toolbar.
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Fig. 42. Menu for CAD-objects creation
2. [optional] If the rectangle must have fixed dimensions, set the corresponding
checkbox:
* [optional] Specify rectangle width and height, in project units;

 [optional] To specify the required rectangle width and height on the screen,
perform the following (step-by-step for both values):

o Set the specify on screen checkbox. The measurement mode is switched on;
o To start measuring, click the left mouse button,;

o Move the mouse and click its left button to complete measuring. The resulting
value is displayed in the appropriate field,;

o Press Esc to quit the measurement mode .
3. Press Insert to start create object.
4. Move mouse and press Insert to specify parameters and size of the object.
5. To complete drawing press Enter, to cancel object creation — Esc.
Conversion of vector object to geometric shape is described in Section 11.4.3.
Adding an arc to a polyline

The system allows for adding an arc-type CAD-object to a polyline (as its fragment)
directly during polyline creation. As a result, the system allows to immediately create a
single vector object, partially eliminating appropriate topological operations.

To do this, perform the following:
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10.

1.

12.

13.

14.

15.

16.

Choose Service > Settings or click & button of the main toolbar. In Settings window
select Vectors tab and set the Join polylines and arcs checkbox;

Start polyline creation;

Not finishing polyline creation, select an arc object by clicking the appropriate button
on the CAD objects toolbar;

Switch on the Snap to points mode (2D snapping or 3D snapping depending on
the need);

Using enabled Snap to points mode, place the marker at the location of the latest
input vertex of the created polyline by clicking the left mouse button. The End label
appears in the vicinity of this vertex;

Press Insert to start create arc.
Move mouse and press Insert to specify parameters and size of the arc.

To complete arc creation press Enter. A single vector object is created, which is a
polyline with an arc as an end fragment;

@ The system allows to go on creating this polyline as a single vector object using standard
topological operations. To do this, perform the following:

Switch off the CAD objects creation mode;
[optional] Switch off snapping mode;

[optional] Clear the Join polylines and arcs checkbox in the Vectors tab of the
Settings window;

Select polyline in 2D-window;

Place marker in vicinity of vertex of polyline fragment beginning, to which it is ne-
cessary to add new vertices;

Choose Vectors > Topology > Object fragment > Select start point of fragment
(Alt+S);

Add more vertices to continue creation of polyline;

Press Esc to complete polyline editing.
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Fig. 43. A polyline with an arc as its fragment

5.3.6. Roofs creation

The PHOTOMOD system provides tools for rapid stereovectorization of buildings. These
tools allow for creating topologically connected combinations of polygons and polylines
that describe the roofs of various buildings, therefore manual project processing becomes
less labor-consuming.

The system provides for rapid creation of vector object combinations with preset options
that describe the most common types of roofs:

Shed — rests on two outer walls of varying heights;

Flat — rests on outer walls of the same height;

Gable — rests on two outer walls of the same height;

Butterfly — gable roof with slopes directed “inside” to collect moisture;

Mansard — single-level with gamble roof;

Hip — gable roof with ridge beam;

Gambrel — gable roof, each plane slope is 2 rectangles connected at an obtuse angle;
Combi — consists of elements of a mansard and attic roofs;

Steeple — roof with highly elongated cone or pyramid;

Hangar — arch-type elongated roof;

Cone — Steeple with an arbitrary number of faces;
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» Parapet — low barrier at the edge of building roof. The system allows to create such
type of roofs in manual and semiautomatic mode;

* Multi-section;

* Dome - in automatic mode. To set the dome’s surface curvature precisely or create
a dome of irregular shape, the manual mode of dome creation is used.

* Arc hipped roof;

* Box bay — wide top or pointed top;

+ Semi hexagonal bay — wide top or pointed top;
+ Semi octagonal bay — wide top or pointed top;

+ Semi cone bay — arc or semi-circle.

@ Elevations of vector polygon vertices that delineate roofs can be set manually after the appro-
priatecalculation .

Perform the following actions for creating a roof:
1. Open a stereopair for vectorisation and turn on stereo mode.

2. Click the & button of the Vectors toolbar, or choose Window > Toolbars » Roofs
or choose Edit » Vectors create mode » Roofs. The roofs creation mode turn on
and the Roofs window opens.

In the left part of Roofs window a list of roof types is placed. In the right side — a
figure of selected roof type and an order of roof corners to be drawn (1, 2, 3 etc.).

Various roof shape and/or corner denotation order options are provided for shed,
flat, gable and mansard roofs.

For Hangar, Cone and Parapet roof types in the right side of the window fields to
input additional parameters are placed.
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Fig. 44. Roofs types

3. Select desirable roof type in the Roofs window.

4. [optional] Choose the appropriate roof shape and/or corner denotation order;
5. [optional] Set the Topological connectivity checkbox;

6. Place marker to roof lower corner and press Insert.

7. Sequentially place marker to other corners of the roof and press Insert in each
corner.

@ Rotate mouse wheel to set the ridge height.
% Press Backspace to undo the latest corner input.

§ If to set a height of Gable rooftop less than a height of its bottom corner, the roof is rebuilt
automatically (a rooftop and the bottom corner will «change places»). Respectively for a
Butterfly, roof type a converse is true.

8. [optional] Edit a width of the roof keeping left mouse button.

9. To complete editing press Insert.
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@ Roof vertices edit in the same way as any vector objects.
§ To exit roofs creation mode, close the Roofs window.

QA Is it possible to view DTM (including vector objects) in a 3D-space in mono or stereomode (see
the “Process in 3D-window” chapter of the “General information” User Manual). To perform
visual control of roofs creation choose Window > 3D window. The 3D window opens.

Topological connectivity mode

Enabling the mode of topological connectivity of elements of the created roof determ-
ines the set of vector objects the roof is to be assembled of and also affects the assigning
of classifier codes to the created roofs in the case of working in a layer with a classifier:

+ [optional] If the Topological connectivity checkbox is cleared, the roof being created
is a set of polygons with some segments coinciding with each other. Classifier codes
(if working in a layer with a classifier) are assigned to the objects being created in
the normal course;

* [optional] If the Topological connectivity checkbox is set, the roof being created is
a set of an external polygon and internal polylines (see below), thus this object cannot
be immediately automatically linked to the classifier code (if necessary, this can be
done manually later).

Topological connectivity of elements of the created roof allows for selecting various
functional elements within the roof for further editing.

When the Topological connectivity checkbox is set, the corresponding attributes are
assigned to various elements of the created combination of vector objects:

+ "type": object — for the roof outline;

+ "type": break — for the roof’s ridge, if any (except for shed, flat, and parapet roof
types)..

% To check the attribute value, select a vector object and choose Window > Object attributes or
click the {4y button on the Vectors additional toolbar. The Object attributes window opens.

Topological connectivity also ensures correct import of vector objects for further
processing in PHOTOMOD 3D-Mod (Vectors » Open vectors in 3D-Mod).

Set this checkbox for further creation of integrated 3D objects when importing vector
data into 3D-Mod (see “Import from PHOTOMOD” chapter of the “Three-dimensional
modeling” User Manual).
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topological connectivity enabled

Creating Hangar roof type

Perform the following actions to create a Hangar roof:

1. Open a stereopair for vectorisation and turn on stereo mode.

2. In the Roofs window choose the Hangar roof type.
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Fig. 47. Hangar roof type

In the Precision type set the precision of arches cycle approximation (in meters).
Place marker to roof lower corner and press Insert.

Place marker to the second lower corner (to set width of roof) and press Insert.

6. Place marker to set the length of roof and press Insert.

7. Set marker inside of roof contour.

8. Rotate mouse wheel to set the ridge height.

7

The system generates approximation lines during height setting.

9. To complete editing press Insert. To exit roofs creation mode, close the Roofs

window.

Creating Cone roof type

To create Cone roof type, perform the following:

1. Open a stereopair and turn on stereovectorization mode;

2. In Roofs window select Cone roof type;
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Fig. 48. Roof type “Cone”

Set marker in the rooftop;

Set marker in the bottom corner of the roof and click Insert key;

Rotate a mouse wheel to set a height of the rooftop;

If to set a height of rooftop less than a height of its bottom corner, the roof is rebuilt auto-
matically (a rooftop and the bottom corner will “change places”).

[optional] Edit a size and position of the roof keeping left mouse button,;

To complete editing click Insert key. To exit Roof creation mode, close Roofs

Creating Parapet roof type in manual mode

To create Parapet roof type in manual mode, perform the following:

1.

2.

Open a stereopair and turn on stereovectorization mode;

In Roofs window select Parapet 1 roof type;
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Fig. 49. Roof type “Parapet”

3. [optional] Turn off a checkbox Closed to create non-closed parapet;

4. Set a minimum parapet height with inputting Height of parapet > value;

é A meaning of Height of parapet > parameter is the following. A difference of heights
between point “N” and “N+1” is no less than <...> m. A height of parapet is set by user
while stereovectorization later but no less than input value, otherwise a parapet will not be
built.

5. Move a marker to parapet corners step by step and click Insert key N times;

5 Press the Backspace key to cancel the last corner entry.

é Do not move a marker after corner “N” is specified.

@ A parapet shape is not limited by rectangle one. It can be a polygon with arbitrary number
of vertices.

6. Once specified roof corner “N” with Insert key, no moving marker, set a height dif-
ference between points “N” and “N+1” while rotating mouse wheel.

After a height difference is over Height of parapet > value a parapet is closed
between corners “1” and “N” (in case of creating closed parapet). If a height differ-
ence is less than Height of parapet > value again, a parapet will be unclosed.
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ﬁ Further parapet editing is impossible if specified height difference is less than Height of
parapet > value.

ﬁ In case of creating non-closed parapet, the system does not close it while specifying a
height with rotating mouse wheel.

7. Set a position of point “N+1” (i.e. a width of parapet) with moving a marker;

8. [optional] If necessary, edit a width and a height of parapet with moving marker and
rotating a mouse wheel respectively;

9. To complete editing click Insert key. To exit Roof creation mode, close Roofs

window.
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Fig. 50. Roof type “Parapet” in 3D-window
Creating Parapet roof type in semiautomatic mode
To create Parapet roof type in semiautomatic mode, perform the following:

1. Open a stereopair and turn on stereovectorization mode;
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2.

In Roofs window select Parapet 2 roof type;
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Fig. 51. Parapet-type roof, where: W is the parapet Width, Z is the parapet height, Left or Right is
the parapet'’s position in relation to the polyline segments (between vertices 1, 2, 3, and so on) which
determine the position of the parapet in XY plane (see Width offset parameter).

3. Set the parapet’s width (W) in meters using the following methods:

» Enter the value of the parapet’s width in the Width field:;

+ Set the parapet’s width using a mouse. To do this, perform the following:

1. Set the Specify on screen checkbox;

2. Setthe start point of the interval which sets the parapet’s width by left mouse

button click;

3. Move the marker and click the left mouse button to set the final point of the
interval which sets the parapet’s width. The interval defining the width of the
parapet is displayed on the screen as a gray guide, and its size in meters is

automatically displayed in the Width field;
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4. [optional] If necessary, edit the parapet’s width by moving the marker and
clicking the left mouse button;

5. Press Enter to set the parapet’s width. The Specify on screen checkbox
will be cleared automatically.

4. In Width offset section set the position of the parapet in relation to the polyline
which determine the position of the parapet in XY plane:

» Left — the parapet will be placed to the left of the polyline;
* Right — the parapet will be placed to the right of the polyline;
» Both - the polyline will be the central axis of the created parapet.
5. Set the parapet’s height (Z) in meters doing one of the following:
» Enter the parapet’s height in the Z shift field;
» Set the parapet’s height using a mouse. To do this, perform the following:
1. Set the Specify on screen checkbox;

2. Clicking the left mouse button, turn on the height setting mode;
@ Repeated left mouse button click resets the height value in the Z shift field to

zZero.

3. Set the parapet’s height rotating the mouse wheel (height in meters is
automatically displayed in the Z shift field);

4. Press Enter to set the parapet’s height. The Specify on screen checkbox
will be cleared automatically.

6. [optional] Set a checkbox Closed to create closed parapet;

7. Moving the marker stepwise in the XY plane and pressing the Insert button, create
vertices which determine the position of the parapet in the XY plane according to
the order in the scheme (vertices 1, 2, 3, and so on);

ﬁ Press the Backspace key to cancel the last corner entry.

? The polyline which determine the position of the parapet in XY plane is not displayed on
the screen. The created parapet is displayed as gray polygons until the parapet is finished.
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8. Tofinish the parapet creation, press Enter. The parapet is automatically heightwise
shifted according to the value set in the Z shift field. In case of a closed parapet,
the parapet’s contour closes automatically.

Q‘ To create a non-closed parapet, it is enough to enter two vertices.

ﬁ To create a closed parapet, enter at least three vertices.

c When creating a closed parapet, self-intersection of the polyline determining the parapet’s
position on the plane is not allowed. This is true also for the last segment, which is created
automatically when the parapet closes (i.e. closes the polyline into a polygon).

9. [optional] To exit Roof creation mode, close Roofs window.

Q To create a parapet above the roof (as on the schematic image), perform the following:
1. Create a roof (e.g. gable);

2. Turn snapping mode on to provide exact spatial coincidence of the roof and parapet (e.g.
Snap to lines and Snap to coordinates combination in 3D-snapping mode);

3. “Abutting” to an eave or a hip using 3D-snapping, create a parapet in semiautomatic mode;
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Fig. 52. A parapet above a gable roof created in semiautomatic mode

ﬁ Parapets created in semiautomatic mode (unlike those created in manual mode) have
no vertical hips.
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Q‘ The system allows to vary Z shift manually during parapet creation in semiautomatical mode.
To do this, when creating vertices determining the parapet position (see item 6), move marker
not only horizontally but also vertically (by rotating mouse wheel).
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Fig. 53. A parapet above a gambrel roof in the 3D-window. Z shift of the parapet vertices above
the roof hip is enlarged manually.

ﬁ To change Z shift manually when creating a parapet vertex, you need temporarily
disable 3D snapping mode if it is used (e.g. by turning 2D snapping mode on).

Multi-section roofs
To create a multi-section roof, perform the following:
1. Open a stereopair and turn on stereovectorization mode;

2. In Roofs window select multi-section roof type;
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Fig. 54. A multi-section roof

3. Select the multi-section roof type:

* Hip;
- Gable.

o [optional] set the Closed checkbox.

4. Moving the marker stepwise in the XYZ plane and pressing the Insert button, create
vertices which determine the position of the first section of the roof according to the
order in the scheme (vertices 1, 2 and 3);

7

When the first and the second vertices are entered and the marker is moved at the place
of the third vertex nearby, the first roof section is displayed as gray polygons.

Adjust the first section’s length and width (as well as its position on the plane) by moving
the marker, and press Insert third time to complete the creation of the first roof section.

5. Moving the marker stepwise and pressing the Insert button, create the succeeding

sections;

6. To finish the roof creation, press Enter. In case of the closed gable multi-section
roof, the final (closing) section will be created automatically.
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Fig. 55. A closed gable multi-section roof

Dome creation
To create a dome in automatic mode, perform the following:
1. Open a stereopair and turn on stereovectorization mode;

2. Choose Dome in the Roofs window;
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Fig. 56. A dome. Big figures denote the dome’s vertices. Small figures are the numerical orders of
segments in one of the dome quarters (4 by default)

Levels between vertices 1 and 2 12

3. [optional] clear the Polyline checkbox, if it is set;
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4. Set the following options for a dome construction (according to the sketch):
* Levels between vertices 1 and 2 — is not less than 2 and not more than 100;
+ Segments per quarter of perimeter — is not less than 1 and not more than 100.

5. Sequentially moving the marker in the XY plane and along the Z-axis and pressing
the Insert button, create vertices that define the shape and size of the dome accord-
ing to the order in the sketch:

1. Place the marker at the dome apex, set the required height and press Insert;

2. Moving the marker in the XY plane, choose any point at the basal part of the
dome. The boundary of the dome’s basal part is a gray polygon. Reduce the
marker height so that it matches the height of the basal part of the dome, and
press Insert;
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Fig. 57. Boundary of the basal part of a dome

3. Moving the marker in the XY plane, choose any point on the dome’s surface
(inside the polygon limiting the dome’s basal part). Increase the marker height
until the dome is fully displayed as gray polygons, otherwise, the dome creation
is not complete;

§ The system availability for automatic dome creation (a dome is completely displayed
as gray polygons) depends on the ratio of elevations of vertices 1, 2, and 3.
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Manszard
Hip
Gambrel
Combi
Steeple
Hangar
Cone

Parapet1

Parapet 2

Multi-section

Arc Hipped Roof Levels between vertices 1 and 2 12 %
Box Bay

Semi Hexagonal Bay Segments per quarter of perimeter 4 %

Semi Octagonal Bay

Semi Cone Bay Polyline Create

Fig. 58. A dome ready for construction

6. [optional] varying the marker height, adjust the dome’s surface curvature;
ﬁ To set the dome’s surface curvature precisely or create a dome of irregular shape, use
manual mode of dome creation.

7. To complete the dome creation, press Insert.
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Fig. 59. Automatically created domes with different construction parameters

72



PHOTOMOD 8.1 Vectorization (Windows x64)

Manual dome creation
To construct a dome manually, perform the following:
1. Open a stereopair and turn on stereovectorization mode;

2. Create a polyline with arbitrary number of vertices that describe a shape of one of
the dome ribs (see vertices 1, 3, and 2 in the picture);

@ When entering polyline vertices, move the marker arbitrarily in the XY-plane and/or along
the Z-axis.

@ To create a straight polyline from several segments, use one of snapping modes. A straight
polyline is not obligatory for a dome creation.

3. Open the Roofs window when the created polyline is still not deselected;

4. Choose the Dome roof type in the Roofs window;

Roofs @

Shed

Flat
Gable
Butterfly
Mansard
Hip
Gambrel
Combi
Steeple
Hangar
Cone
Parapet 1
Parapet 2
Multi-section

Arc Hipped Roof

Levels between vertices 1 and 2 12 -
Box Bay
semi Hexagonal Bay Segments per quarter of perimeter 4 =
Semi Octagonal Bay
semi Cone Bay [] Palyline Create

Fig. 60. A dome. Big figures denote the dome’s vertices. Small figures are the numerical orders of
segments in one of the dome quarters (4 by default)

5. Set the following options for a dome creation (according to the sketch):
* Levels between vertices 1 and 2 — is not less than 2 and not more than 100;

+ Segments per quarter of perimeter — is not less than 1 and not more than 100.
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6. Tocomplete dome creation, set the Polyline checkbox and click the Create button.
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Fig. 61. A shaped dome created manually

Arc hipped roof creation
To create an arc hipped roof, perform the following:
1. Open a stereopair and turn on stereovectorization mode;

2. Choose Arc hipped roof in the Roofs window;
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( . Roofs @ﬁ
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Flat
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Butterfly
Mansard
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Gambrel
Combi
Steeple
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Parapetl
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Multi-section

Dome 3 2

Arc Hipped Roof
Box Bay

Semi Hexagenal Bay

Semi Qctagonal Bay
Semi Cone Bay Precision 0.100000 = m

| Topological connectivity

Fig. 62. Arc hipped roof

3. Set the precision of roof construction in meters;

4. Sequentially moving the marker in the XY plane and along the Z-axis and pressing
the Insert button, create vertices that define the position and size of the roof accord-
ing to the order in the sketch (figures 1, 2, 3, 4, and 5). After entering the 5th vertex,
the construction of an arc hipped roof is complete.

Box bay creation
To create a box bay, perform the following:
1. Open a stereopair and turn on stereovectorization mode;

2. Choose Box bay in the Roofs window;
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Multi-section
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Arc Hipped Roof
Box Bay

Semi Hexagenal Bay
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Semi Cone Bay @ Wide top Pointed top

| Topological connectivity

Fig. 63. A box bay (Wide top)

3. Choose the box bay type:

» Wide top. Sequentially moving the marker in the XY plane and along the Z-axis
and pressing the Insert button, create vertices that define the position and size
of the bay according to the order in the sketch (figures 1, 2, 3, and 4).

1. Enter the first vertex to start a bay construction;

2. Move the marker in the XY plane to set the bay’s width. Change the marker’s
height to set the height of the bay ridge. Enter the second vertex;

3. Move the marker in the XY plane to set the bay’s length. The bay is displayed
as gray polygons. Enter the third vertex;

4. Move the marker in the XY plane to set the width of the bay’s ridge (widths
of equal line segments marked with two dashes in the sketch). Press Insert
to complete the bay construction.

* Pointed top. Sequentially moving the marker in the XY plane and along the Z-
axis and pressing the Insert button, create vertices that define the position and
size of the bay according to the order in the sketch (figures 1, 2, 3, and 4);

1. Enter the first vertex to start a bay construction;
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2. Move the marker in the XY plane to set the bay’s width. Change the marker’s
height to set the height of the bay spire. Enter the second vertex;

3. Move the marker in the XY plane to set the bay’s length. The bay is displayed
as gray polygons. Enter the third vertex;

4. Enter the last vertex to complete the bay construction.

( . Roofs @ﬁ
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Flat —

Gable —— 4

Butterfly
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Gambrel
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Steeple 3
Hangar
Cone

Parapetl ] 1 3
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Arc Hipped Roof
Box Bay

Semi Hexagenal Bay
Semi Qctagonal Bay
Semi Cone Bay Wide top @ Pointed top

| Topological connectivity

Fig. 64. A box bay (Pointed top)

Semi hexagonal bay creation
To create a semi hexagonal bay, perform the following:
1. Open a stereopair and turn on stereovectorization mode;

2. Choose Semi hexagonal bay in the Roofs window;
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Fig. 65. Semi hexagonal bay (Wide top)

3. Choose the bay type:

» Wide top. Sequentially moving the marker in the XY plane and along the Z-axis
and pressing the Insert button, create vertices that define the position and size
of the bay according to the order in the sketch (figures 1, 2, and 3);

1. Enter the first vertex to start a bay construction;

2. Move the marker in the XY plane to set the bay’s width. Change the marker’s
height to set the height of the bay ridge. Enter the second vertex;

3. Move the marker in the XY plane to set the bay’s length (and adjust its width
as needed). The bay is displayed as gray polygons. Enter the third vertex to
complete the bay construction;

* Pointed top. Sequentially moving the marker in the XY plane and along the Z-
axis and pressing the Insert button, create vertices that define the position and
size of the bay according to the order in the sketch (figures 1, 2, and 3);

1. Enter the first vertex to start a bay construction;

2. Move the marker in the XY plane to set the bay’s width. Change the marker’s
height to set the height of the bay spire. Enter the second vertex;
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3. Move the marker in the XY plane to set the bay’s length (and adjust its width
as needed). The bay is displayed as gray polygons. Enter the third vertex to
complete the bay construction;
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Fig. 66. Semi hexagonal bay (Pointed top)

Semi octagonal bay creation
To create a semi octagonal bay, perform the following:
1. Open a stereopair and turn on stereovectorization mode;

2. Choose Semi octagonal bay in the Roofs window;
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Fig. 67. Semi octagonal bay (Wide top)

3. Choose the bay type:

* Wide top. Sequentially moving the marker in the XY plane and along the Z-axis
and pressing the Insert button, create vertices that define the position and size
of the bay according to the order in the sketch (figures 1, 2, 3, and 4);

1. Enter the first vertex to start a bay construction;

2. Move the marker in the XY plane to set the bay’s width. Change the marker’s
height to set the height of the bay ridge. Enter the second vertex;

3. Move the marker in the XY plane to set the bay’s width. Enter the third vertex;

4. Move the markerin the XY plane to set the bay’s length. The bay is displayed
as gray polygons. Press Insert to complete the bay construction.

* Pointed top. Sequentially moving the marker in the XY plane and along the Z-
axis and pressing the Insert button, create vertices that define the position and
size of the bay according to the order in the sketch (figures 1, 2, 3, and 4);

1. Enter the first vertex to start a bay construction;

2. Move the marker in the XY plane to set the bay’s width. Change the marker’s
height to set the height of the bay spire. Enter the second vertex;
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3. Move the marker in the XY plane to set the bay’s length. Enter the third vertex;

4. Move the markerin the XY plane to set the bay’s length. The bay is displayed
as gray polygons. Press Insert to complete the bay construction.
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Fig. 68. Semi octagonal bay (Pointed top)

Semi cone bay creation
To create a semi cone bay, perform the following:
1. Open a stereopair and turn on stereovectorization mode;

2. Choose Semi cone bay in the Roofs window;
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Fig. 69. Semi cone bay (arc)

3. [optional] To create a flat bay, set the appropriate checkbox;
4. Setthe number of faces between 3 and 100;
5. Choose the bay type:

* Arc. Sequentially moving the marker in the XY plane and along the Z-axis and
pressing the Insert button, create vertices that define the position and size of the
bay according to the order in the sketch (figures 1, 2, and 3);

1. Enter the first vertex to start a bay construction;

2. Move the marker in the XY plane to set the bay’s width. Enter the second
vertex;

3. Move the marker in the XY plane to set the bay’s length. Change the marker’s
height to set the height of the bay, if it is not flat. Enter the third vertex to
complete the bay construction.

+ Semi-circle. Sequentially moving the marker in the XY plane and along the Z-
axis and pressing the Insert button, create vertices that define the position and
size of the bay according to the order in the sketch (figures 1 and 2);

1. Enter the first vertex to start a bay construction;
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2. Move the marker in the XY plane to set the bay’s size. Change the marker’s
height to set the height of the bay, if it is not flat. Enter the second vertex to
complete the bay construction.
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Fig. 70. Semi cone bay (semi-circle)

5.3.7. Building height calculation

In certain circumstances, the system allows to measure a building height using a simple
vector polygon that delineates the lower boundary of a building’s roof. The obtained
value of building height (from the building’s foot to the roof’'s boundary) can be in its
turn used further in different ways. For example, during further, more detailed vectoriz-
ation of the abovementioned roof, this height value can be attributed manually to vector
vertices delineating the lower boundary of the building’s roof (see the previous chapter).

The system allows to measure building heights in two ways:

+ Calculate by wall;

» Calculate by shadow.

A\

Building height measuring is available only for an adjusted project. The measuring accuracy
greatly depends on initial data quality and geometric parameters of the imaging of each single

object.
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To calculate by shadow is possible only for an adjusted satellite scanner imaging project.
Metadata of initial images of the mentioned project must contain the values of the Sun elevation
angles at the time of survey, acceptable in accuracy.

To calculate by wall is possible both for scanner projects and central projection projects as-
suming that the off-nadir angle was obtained from metadata (which is usually always the case
for most central projection projects).

To measure building heights, perform the following:

1.

> W DN

Choose Rasters » Show rasters » Source only;
[optional] Enable one of the modes of snapping to vertices;
To open the Orthorectification toolbar, click the 2 button of the main toolbar;

Open one of project images in a separate window by clicking <=, [ or = buttons
of the Orthorectification toolbar;

Click the i button of the Orthorectification toolbar and choose the data source,
which is a vector layer that contains (or will contain) polygons delineating lower
boundaries of building roofs:

’. Building height calculation lﬁ

'ZIEZ' Choose data source

[ Create new vector layer

l
I Open new layer from resources I
I

I Use current layer {objects11)

Close |

Fig. 71. Choosing vector data source

6. The Building height calculation window opens:
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. Building height calculation P
| Pararmeters | |Ca|cu|atebywa|l | |Ca|cu|ateb}rshad0w|

Height | Calculation type Q-y vertices
1 31633351 By shadow 4

Fig. 72. The Building height calculation window
The Building height calculation contains the following elements:
+ A button allowing to set Parameters of building height calculation;

+ Calculate by wall and Calculate by shadow buttons that allows to enable ap-
propriate calculation modes (see below);

* The |%] button allowing to update window contents (see below);

+ Atable containing the calculation results (after performing at least one calculation).
The number of lines in the table is equal to the number of polygons in the vector
layer chosen at the step 5 (if an empty vector layer is chosen/created, it is needed
to create polygons delineating building roof boundaries).

ﬁ The |#] button allows to update the table contents after working with vector polygons.

This table includes the following columns:

o A numerical number of a polygon (roof) / height calculation (one calculation is
available for each polygon);

o Calculated height;
o Calculation type (see above);
o Q-ty vertices — the number of polygon vertices.

After the calculation, the Height and Calculation type (optional) are also writ-
ten/rewritten into the attributes of the vector polygon for which the measurement
was made (see below).
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7. [optional] to set the Parameters of building height calculation, click the appropriate
button. The Height calculation parameters window opens:

i ™
. Height calculation parameters . S

Height attribute name: Height
Use calculate type attribute:

Height calculation type attribute name MeasMode
By wall calculation type attribute value:
By shadow calculation type attribute value: |shadow

@ relative

Height type:
absolute

[ CK l | Cancel |

4

Fig. 73. The “Height calculation parameters” window
Set the following parameters:

* Height attribute name, that appears for the appropriate polygon after the first
calculation;

 [optional] set the Use calculation tape attribute checkbox in order to additionally
record the calculation method in the attributes of the abovementioned polygon,
and set the following parameters:

o Height calculation type attribute name;
o By wall calculation type attribute value;
o By shadow calculation type attribute value.
* Choose Height type:
o relative height of the object (building) itself from the foot to the roof’s boundary;

o absolute height of the lower boundary of building roof in the project’s coordinate
system according to the current terrain model (see the Type of DTM tab in the
Orthorectification parameters window).

? To open the Orthorectification parameters window, click the % button of the Or-
thorectification toolbar.

To close the Height calculation parameters window, click OK.

For direct building height calculation, perform the following:
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8. Choose a building to be measured. The building’s shadow, roof, bottom, and wall
are to be clearly seen in the image under processing (see the picture below).

@ Choose Rasters » Show rasters > Source only, if not done yet.

9. [optional] Create a vector polygon that delineates the building’s roof boundary, if
not done yet.

r. Building height calculation |i| Orthorectification
beER ! S PR RE EeE>
’ Parameters ] ’ Calculate by wall ] ’ Calculate by shadow ] D| r’ﬁ .l - *' | Eh ﬁ

e T - r
' -|‘: ‘h_ o _I" ‘il"- -
Height | Calculation type | Q-y vertices | B
31.63235] By shadow 4 P

Type of DT

@ Constant elevation 997274384732

Fig. 74. The selected polygon delineates a flat roof of a multistore building, the shadow and sheer
wall are clearly seen. The marker is at the building’s foot (ground level, if the relative height is
calculated; otherwise, absolute building height will be calculated, according to the current terrain
model — see the Type of DTM tab in the Orthorectification parameters window).

10. [optional] To calculate the building height by wall, perform the following:

* Move the marker as accurately as possible to the foot of the building so that it is
located vertically below one of the vertices of the polygon delineating the building’s
roof boundary (see the pictures - it is recommended to make calculations along
building edges, if applicable);

» Select the abovementioned polygon;

» To enable this height calculation mode, click the Calculate by wall button in the
Building height calculation window, (colored button border means that the
mode is turned on);
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* Move the marker to the polygon vertex where it was initially at the building foot
(enabled one of the modes of snapping to vertices is recommended):

@ Building height calculation 2 | onhorectification B

’ Parameters ] ’Calculatebywall] ’Calculatebyshadow]

Height | Calculation type | Q-y vertices |
1 31633351 By shadow 4

Fig. 75. Moving the marker from the building’s foot to the polygon vertex (roof boundary).

» Press Enter. If successful, calculated Height and Calculation type are recorded
into the appropriate table row in the Building height calculation window (the
appropriate attributes of the selected vector polygon are also created according
to the parameters set in item 7). Otherwise, a message about an error of height
calculation appears.

11. [optional] To calculate the building height by shadow, perform the following:

* Move the marker as accurately as possible to the foot of the building so that it is
located vertically below one of the vertices of the polygon delineating the building’s
roof boundary (see the pictures);

+ Select the abovementioned polygon;

+ To enable this height calculation mode, click the Calculate by shadow button
in the Building height calculation window (colored button border means that
the mode is turned on);

* Move the marker to the border of the building shadow, focusing on the selected
vertex, vertically below which the marker was originally located, placed at the
foot of the building (see the picture below):
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i
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PeHBEG HE 6 PPRED| heE+%

it
r Au Ll
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| Height | Calculation type | Q-y vertices |

1 31.633351 By shadow 4

Fig. 76. Moving the marker from the building foot to the shadow boundary

» Press Enter. If successful, calculated Height and Calculation type are recorded
into the appropriate table row in the Building height calculation window (the ap-
propriate attributes of the selected vector polygon are also created according to
the parameters set in item 7). Otherwise, a message about an error of height
calculation appears.

5.3.8. Vector object properties

To display linear vector object properties, select the object and choose Vectors »
Polyline properties or use the | hotkey. The Object properties window contains the
following parameters of 2D-object:

* number of vertices;

ﬁ, If there were selected several vector objects, the number of selected linear vector objects is
displayed in the Vertices number field.

* maximal and minimal object coordinates separately and for each axes;
* length/perimeter;

ﬁ, If there were selected several vector objects, the sum of lengths/perimeters of selected linear
vector objects is displayed in the Length/Perimeter field.
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 plain area (in case of polygon) — in project coordinate system or on the reference

surface;

g Reference surface (during baseline measurements) — level surface that coincides with the
sea-level surface and is used for reducing the measurement results on the physical surface

of the Earth.

é A value of the area on the reference surface is calculated only when using global working

coordinate system.

é If there were selected several vector objects, the sum of areas of selected polygons is dis-
played in the Object properties window.

* length of polyline or length of polygon boundary projected on plane.

In the Object vertices section is displayed the list with numbers and coordinates (XYZ)
of selected object vertices. The vertices are numbered in the order they were created

during vectorization.

. Cbject properties

===

Vertices number 155

xmin 581065.307

Xmax 581455127

Length/perimeter
3362.459

Object vertices

5.4. Vector objects loading

1: 581124.709 5410272,745 450.000
2: 581128.656 5410274, 241 450.000
3: 581139,530 5410254.980 450.000
< 581149.070 54102586.875 450.000
5: 581152, 115 5410292, 171 450.000

Ymin 5410259.996 m Zmin 0,000

Ymax 5411077.526 m Zmax 450.000

¥ plane area

in project c.s. 277470.466
on the reference surface -
¥ plane length 2479, 388

Close

m"2

ms2

Fig. 77. The Object properties window

In order to load vector objects perform the following actions:

1.

Choose Vectors > Load or click the (=" button of the main toolbar.
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> Swazy_group sheets 20.08.2
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» 3DAS
> A3 frames
4 Aalen_Group
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> Aalen_DMC
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mosaic
— - | Filter
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[7] open read-only
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coordinates
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’ Open ] ’ Cancel
| fTechsuppart/aalen_Group/Aalen_DMC copy for DSM,Data | 5 resources  43.00 KB (selected: 1resources f 43.00 KB)

Fig. 78. Vector layer loading

2. Select one or multiple vector files with *.x-data or *.cx-data extension.

§ After that when multiple files are selected the system suggests two ways of loading: to load
all in the same layer or to load each file in a separate layer.

3. [optional] To disable saving and rewriting of selected file, set the Open read only
checkbox on.

4. [optional] Select method of objects coordinates recalculation For different coordin-
ate systems transforms via — using pixel or geodetic coordinates (see details in
the “General system’s parameters” User Manual).

5. Click the Open button. If one or multiple vector layers are already loaded to active
project, then during loading of new vector layer the window of loading type is opened.
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(@ Loading o |

'ZEZ' Layer Vectors contains data.

[ Replace layer

| Create new layer

|
|
| Add to layer |

Close

Fig. 79. Vector layer loading

The system provides the following variants of new layer loading to existing vector
layer:

* Replace layer — vector data of active layer is replaced by data from loading layer;
» Create new layer — vector data is loaded to a new layer;

+ Add to layer (without unloading existing data) — during loading vector data is
added to objects of active vector layer.

When it is necessary to load two or more vector files at once, there is the following
ways of loading:

» Clear layer and load all files into it — vector data of active layer is replaced by
data from loading layers;

5 First, make sure that important data will not be lost during the replacement process,
especially if the active layer is co-edited by several users.

* Load all into one new layer — vector data is loaded to a single new vector layer;

é The system provides for combined data loading both from ordinary and co-editable
vector layers (with *.x-data and *.cx-data extensions, respectively). However, the
active vector layer created as a result of such an operation will not be co-editable. The
co-editing functionality can only be available for a vector layer already saved in the active

profile resources (see Section 4).

» Create separate layer for each file — vector data of each file are loaded to
separate layers;

* Load all layers into Vectors without unloading existing data — vector data
of all files adds to objects of active vector layer.
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i . Loading @1

'Z'E' Layer Vectors contains data. 2 files selected to load

[ Clear layer and load all files into it ]
[ Load all into one new layer ]
[ Create separate layer for each file ]

[Lnad all layers into Vectors layer without unloading existing daiﬁ]

Close

Fig. 80. Vector layer loading
Vector layers are displayed in Manager.

If vector data layer is saved to different coordinate system or in a project with differ-
ent adjustment results, the system recalculates coordinates automatically. After
loading produces information message about coordinates recalculation.

i '
€ PHOTOMOD 6.0.1.1806 | B o
l ] *-i.-j 10.08.2015 17:00:04: Objects were saved in ancther coordinate system or in a project with

S different adjustment results,
¥ |0 Coordinate calculation options used:
- - with calculation via pixel objects coordinates
‘131 - with automatic switching to alternative calculation via global/pixel coordinates
0 - with transformaticon via geccentric coordinate systern, if calculating via glebal
5 coordinates
- with automatic switching to alternative strategy of transforming global coordinates
P =

Fig. 81. Coordinates recalculating during vector layer loading

The system provides a possibility of quick access to recently loaded vector data files.
To do this use the Vectors » Recent menu item. If necessary, the default coordinates
recalculation uses.

To close a vector layer, select Vectors » Close. To close all vector layers, select Vec-
tors > Close all opened layers.
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5.5. Vector objects saving

To save (or rewrite) active vector data layer select Vectors > Save or click the layer
name by mouse right button in the Manager and choose the Save in context menu.

To save active layer with new name select Vectors > Save as or click the layer name
by mouse right button in the Manager and choose the Save as in context menu, specify
file name and path in active profile resources.

To save just selected vector objects, select all vector objects that should be saved and
select Vectors > Save selected as. After that vector objects are still associated with
classifier.

The Vectors » Recent menu item allows to load the last saved version of active vector
layer.

The system also allows to save vector data automatically. Use the Auto-save tab of
the Parameters window to specify the settings (see the “Settings of auto-save” chapter
in “General system’s parameters” User Manual).

Vector data is saved in the PHOTOMODS8.VAR\AutoSave folder. A name of resource
with save date is used as a name of vector file during auto-save. Auto-save becomes
possible only after editing of opened vector layers (changed layers are marked by as-
terisk symbol in the Layer manager).

In order to load automatically saved files choose Vectors » Restore. Choose an auto-
saved file in the AutoSave folder to load it into project. Choose necessary file and click
the Open button to load auto-saved file to a project.

5.6. Displaying objects list
The system provides possibility to show list of active layer objects and their parameters.

Choose Window > Objects list. The Objects list window opens.

é After first creation or loading layer with classifier the Objects list window opens automatically
(see Section 6).

The Objects list window is located at the lower part of the 2D-window by default. The
system interface is flexible for customizing the locations this window according to the
user’s needs.

The Objects list window can either be fixed in designated sections of the work area
(top or bottom, right or left) or undocked by the user and placed in any place in the 2D
window.
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Fig. 82. The Objects list window located by default

To undock the Objects list window (or pinpoint it in any place), move the cursor over
the window title and, holding down the left mouse button, drag the window to the area
of its targeted location.

?, Use the & button on the right side of the window title to undock a docked window.

\ﬂj, To quickly return a window to the area where it was docked last time, double-click the left mouse
button on the window title
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Fig. 83. The Objects list window (undocked window moved to the top of 2D-window)

Objects list (=]
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ﬁ MNarme Code Code name Type Size Vert. number Perimeter (Length) Area i
0 44211000  CTPOEHWMEQr.. C 1.0 6 37.793 87410
1 44211000 CTPOEHWMEQr.. C 1.0 6 36.448 82955
2 44211000  CTPOEHWMEOQT.. C 1.0 6 34938 76199
3 44211000  CTPOEHWECQT.. C 1.0 6 37.578 88.127
4 44211000  CTPOEHWMEOQT.. C 1.0 6 35221 77.529
5 442111000 CTPOEHWMEOr.. C 1.0 4 21956 29179
6 44211000  CTPOEHWMEQr.. C 1.0 6 38557 91.393
7 44211000 CTPOEHWMEQr.. C 1.0 6 32633 66.552
g 44211000  CTPOEHWMEQr.. C 1.0 6 33112 68617
9 44211000  CTPOEHWMEQr.. C 1.0 6 36.031 80.682
10 44211000 CTPOEHWMEQr.. C 1.0 10 41.261 92,765 -
Vectors | Total objects: 2511 / Selected chjects: 0

Fig. 84. The Objects list window (undocked)

The lower part of the window displays the number of vector objects in the active layer
(both the total number and the number of selected ones, if any).

The window displays the table containing the following columns:
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N — the object’s number. The N column is used for the objects selection. The object
selected in the table is highlighted in 2D-window, marker is placed to the first vertex
of the object (in case of polylines and polygons), and the screen is centered by
marker;

Name — a unique object name (see Section 6);
Code — a code in classifier, to which the object is assigned (see Section 6);

Code name — a code name in classifier, to which the object is assigned (see Sec-
tion 6);

Type — object type: P — point, L — polyline, C — polygon (see Section 6);

Size — real number, which describes the size of a vector object used in a real system
of coordinates; for points this parameter determines the size of the characters, that
display them on the image (see Section 6);

Vert. number — vertices number;

Perimeter (Length) — length, in measurement units of current project (for the polylines)
or perimeter (for the polygons).

Area — area, in measurement units of current project (for the polygons).

@ The area measurement is available only for the polygons without self-intersections.

? To sort objects in the table by data of column, click on the name of this column. This function

is also available for the columns, containing an object’s attributes.

The table refresh automatically after any changes of objects on active layer.

Table 6. Overview of the Objects list window toolbar

Buttons Function
dirt to save the list of objects to *.dbf file format
= to save the list of objects to *. txt file format
to refresh window manually
e to show only selected objects in a table

AT to show in the table attributes of all layer objects. The system provides for editing object
attributes not only in the Object attributes window, but also directly in the table of Ob-
jects list window. Left double-click the appropriate table cell to edit an attribute. Press
Enter to save the input data, or press Esc to stop editing and discard changes.

to open the List of columns window (see below)

=(f=:

to open the Object attributes window (for this, first select an object in the N column of
the table in the Objects list window or select the object in the 2D window)
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To display only selected attributes in the table instead of all ones, click the ] button
in the Object list window toolbar. The List of columns window opens:

( . List of columns Iﬁw

@ an

COCTOAHWE -
COBCTBEHHOE HASBAHMWE

YACNO 3TAKEN, KAMEP LLMKI3A
OYHKLMOHANBHOE HASHAYEHWE
HOMEPA JOMOB

MATEPWMAN COOPYKEHMA
KOMMEHTAPMIA

HOMEP MO FEHMAAHY

MAAH BT

MACLUTAE OTOBP.3HAKA B MPOLEHTAX
BLICOTA LWPWDTA

HA3BAHME LUPMOTA

TONWMHA TAHAK B MM

TONWWHA OKOHYAHNA TAHAK B MM -

m

QK ] I Cancel

Fig. 85. The List of columns window
The window toolbar contains the following elements:
. — allows to select all items;
+ _ —allows to deselect all items;
» K — allows to invert items selection.

Select attributes to be displayed in the table by setting the appropriate checkboxes and
click OK.

The saved (&) *. txt-file containing the Objects list completely duplicates the structure
of the table described above. The first line contains column names, the following lines
contain the table cell values. The semicolon (;) sign is used as a delimiter, the dash
(-) is used for empty values. Cell values that initially contain a semicolon are enclosed
in quotation marks ("").

6. Classifier

6.1. The “Classifier’ window

The classifier is a set of standard attributes, used for thematic objects classification.
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All vector objects created in the classifier layer, are assigned to one of classifier’s record.

The system allows to create, edit, import and export a classifier. The Classifier window

is used for this purpose.

Classifier is a tool to systematize vector objects. For example, during work with classi-
fier there is a possibility to highlight all objects with the same code, delete them or display

different objects classes using different colors.

@ Vector objects codes are used for vectors export to different exchange formats.
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The left part of the window contains a list of project thematic layers, the right part — a

Fig. 86. The Classifier window

table of vector objects codes, and includes three tabs: Codes and Attributes.

Table 7. Overview of the Classifier window toolbar

Buttons Function

N to close opened classifier and create a new one (see Section 6.2)

= to open created classifier

= to save changes to a classifier

to open a window used to select a file to import codes to active classifier

to open a window used to select a file to export codes to Panorama format with *. rsc
extension

= to change a code of object selected in 2D-window (see Section 6.6 1 Section 6.7)

= to assign a code to all non-assigned objects of the same type (see Section 6.6 and
Section 6.7)

e to select all objects with this code (see Section 8.2.3)

= to select all un-assigned objects (see Section 8.2.3)

= to select all objects of the code group (see Section 8.2.3)
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Buttons Function

- to select all visible objects of the layer, except for those with disabled visibility (to disable
object’s visibility, click the ® button to the left from a codename or a word); is used for
batch export of all selected objects

=22 to display codes of vector object in a classifier when it is selected in 2D-window

= to scroll the codes list to selected code

LRBEL to set a note for active code (see Section 6.5)

=] to set a note for all codes of a layer (see Section 6.5)

z to assign height values to object vertices, if after import these values were added to a
classifier attributes (is used to import contour lines from MIF/MID and SIT formats, see
Section 13.11))

& to assign height values to vertices of all objectsl, if after import these values were added
to a classifier attributes (is used to import contour lines from MIF/MID and SIT formats,
see Section 13.11))

5 to display in the codes list all codes of vector objects, that belong to the selected layer

E to enable classifier editing mode (see Section 6.3)

E to open window used for editing of selected code or attribute (see Section 6.3)

= to open window used for creation of new code or attribute (see Section 6.3)

[ to add selected code to a separate list of codes, that is used for easy search for frequently
used codes. To display the list set the Favourites checkbox in the left lower part of the
Classifier window

=3 to delete selected code or attribute from the classifier

Filel to assign selected hotkeys (Shift+1,2,3,4,5) to active vector object code, and to use
them for code quick code display in classifier

] to search string By code or By code name0

] to perform further search for records in selected mode

= to load existing classifier during creation of a new layer with classifier by default

The Attributes tab in a classifier is used to create and edit attribute information.

On the Codes tab there is a table of classifier properties, that contains the following

columns:

Visible — shows visibility of the objects with selected codes in 2D-window;

» Code — an object code;

* Name - arbitrary text, unique name, for example, “Earth roads”;

» Type — object type: P — point, L — polyline, C — polygon (see Section 6.2);

» Color — a color of object display;

» Symbol — ASCII symbol corresponding to objects code, is used for point objects and
is selected from the symbols list in existing library;
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» Size — real number, which describes the size of a vector object used in a real system
of coordinates; for points this parameter determines the size of the characters, that
display them on the image;

* Q-ty — number of objects with specified code;
« Attr. — number of object’s attributes (see Section 7.2.1).
To sort lines in the Code, Name, Type or Q-ty columns click on column name.

If the = to the left from the layer name or object code is active, objects of active code
or layer are displayed in 2D-window.

To switch visibility mode of selected objects or layers in 2D-window, perform one of the
following actions:

+ click on the = icon to the left from the layer name or object code;
« use the &, buttons to show and ¢ button to hide the layer.

6.2. Classifier creation

Perform the following actions for creating a classifier:

1. Load or create vector layer with classifier.

2. Choose Window > Classifier. The Classifier window opens.

@ After first creation or loading layer with classifier the Classifier window opens automatically.

. Classifier ﬁ
DzEde2bh e~ -~ ZxosBmBr 42 BEECEBE™ Al B
BEEES % [ Codes | Attributes |
Vision Code editor Vision Code Code editor Type Color Symbol S5ize Q-ty Aftr.
& Layers

Favorites

Fig. 87. The Classifier window
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3. [optional] To create a new classifier instead of opened one click the [ button.

4. Click the [ button of the Classifier window additional toolbar to create a layer.

"
0 Classifier | 8|
DzEdebh ad@cs- - ZoB=wH a8 BECSEBE™ AY E
ﬁ@ ® = [ Codes | Attrbutes |
Vision Code editor Vision Code Code editor Type Color Symbol 5ize Q-ty Attr,
& Layers

Vegetation

OK

. New layer @I&J
] [ Cancel

|:| Favorites

Fig. 88. Creation of layers list in classifier

5. Select layer to create new code.
6. Click the B button to set on the classifier edit mode.

7. Click the [ button of the Classifier window main toolbar to create a new code in
the classifier. The Add code window opens.

. Classifier |i|
NEE®h BeEsiE - ReEnE: s GQEEEA™ AN = |
ﬁ ﬂ ﬂ 9‘3’ Ex Codes IM . Ac‘i'd-code léjl
Vision Code editor Vision  Code Code
4 W |ayers 110514

W Vegetation S
Pine forest
Type Color Symbaol Size Line style

— D F
[ Polygons fill density

Fill parameters

Fill color ’—

Fill transparency (%)

0 100

[T] Favorites Ok ] [ Cancel

Fig. 89. Creating new code

8. Specify unique object Code, for example, its serial number or a numerical code.
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10.

1.

12.

13.

Specify unique object Code name, arbitrary text (for example, “Water object”).
Select the object type:

« for the point object select its type P and define the symbol (from standard symbols
library), and symbol’s color (from standard color palette of MS Windows(the Win
button) of fromAutoCAD program palette (the ACI button)) and a size (in points
in corresponding field).

« for linear object select its type L, for polygon — type C; for these objects it is
possible to specify a color of line (from standard color palette of MS Windows
(the Win button) of fromAutoCAD program (the ACI) button).

[optional] To change line style and size for polylines and polygons click on the Line
style button.

,. Line style ) |
Line type Line width
| - 1 :
| ok || Ccaneel

Fig. 90. Select line style
% Selected line style is preserved during export of linear objects to DXF and DGN formats
(see Section 14.4 and Section 14.5).

[optional] To configure color and transparency of C (or L) type vector objects set
the Polygons fill checkbox on. In the Fill parameters section define the following
settings:

* Fill color —is used to select fill color;

 Fill transparency (%) — is used to setup fill transparency.

ﬁ Fill color saves during import/export in KML format.

Click OK. Created code is added to the layer, which name is selected in the layers
list, id objects are not divided into layers.

In order to save codes and layers classifier click the g button. Define file name and
path in active profile resources. During following program launches the classifier is
loaded automatically.
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To load another classifier click the [ button and select a file with classifier in active
profile resources. For more details about classifier import see Section 6.4.

To use existing classifier during new layer creation use the B button.
6.3. Classifier editing
In the Classifier window there is a possibility to edit a list of layers in the left panel and

a list of codes and attributes — in the right one. For more details about attributes list
editing see Section 7.2.1.

IS ™
& Classifier &J

(EEdeh BeEES - ZcExt i (EEEE" A0 =

ﬁ n u 9\3’ E;‘ Codes | Atfributes

Vision Code editor Vision Code Code editor Type Color Symbol Size Q-ty Attr,

4 B layers & 110514  Pine forest ¢ [ 00

& Vegetation
[ Favorites

Fig. 91. The Classifier window

Above the Classifier window there is an additional toolbar, that includes the following
buttons:

« [ - allows to change selected layer name (F2).

é T o save changes press Enter, to cancel editing — Esc.

« [ - allows to create new classifier layer;

« [ - allows to delete selected layer from layers:

« ®_ _ allows to display all objects of a layer, including sublayers;
« ®. —allows to hide all objects of a layer, including sublayers;

To edit classifier it is possible to use the following buttons of the main toolbar of the
Classifier window:
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« [ - allows to open the Code editing window (see Section 6.2);

@ Change of a code type is possible only if a layer does not contain objects of a given code.

« [ - allows to open the Add code window to input values of each classifier field of
a new record,;

[ — allows to add selected code to separate codes list, that is used to search for
frequently used codes and is displayed, if the Favourites checkbox is set on in the
left lower part of the classifier window;

« [& - allows to delete selected catalogue from layers list with preliminary warning;
Context menu of layer list contains the following menu items:

» Copy layer — allows to copy a layer selected in the list to clipboard;

» Paste layer — allows to paste a layer from clipboard to the layers list;

* Move layer — allows to cut selected layer and it list or inside selected layer (as a sub-
layer);

+ Show layer with sublayers — allows to display in 2D-window objects, which codes
belong to the selected layer (when the “eye” = to the left of the layer name is enabled);

» Hide layer with sublayers — allows to hide in 2D-window objects, which codes belong
to the selected layer (when the “eye” * to the left of the layer name is disabled);

Context menu of code list contains the following menu items:
» Copy code — allows to copy a code selected in the list to clipboard;
* Insert code — allows to paste a code from clipboard to the codes list;

* Move code — allows to paste a code from clipboard to the codes list and to delete it
from its previous location;

+ Add code to favourites — allows to add a code selected in the list to the Favourites.

6.4. Classifier import

The system provides possibility of vector objects codes import during creation or updating
of active classifier. To import is used the ¥ button.

The system provides import of classifier from the following formats:
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 import of a rsc-file to classifier layer. In files with the *.rsc extension the symbols
libraries (classifier) are used to display and print digital maps. A set of standard
classifiers (files with *. rsc extension) is included to the system delivery package and
is stored in the \VectOr\DOC folder after system installation. During import of classi-
fier from Panorama a set of standard classifiers is used for correct codes display;

 import of classifier assigned to existing map (files *.sit, *.map) to a code table of
layer with classifier.

During import of vector objects to a layer with classifier from supported exchange
formats, their codes are also imported to a new classifier or are added to the existing
one, depending on settings, see Section 13.

6.5. Labels creation

For vector objects the system provides creation of special label (label), that is displayed
in 2D-window as a label near point object or near vertex of linear object, depending on
settings (see the “General system’s parameters” User Manual).

§ Such a label is also displayed next to an object after export to DXF file of the AutoCAD program
(see Section 14.5).

é Labels creation is performed after creation oa all objects and prior to their export to DXF.

In order to create labels for vector objects perform the following actions:
1. Select object code in classifier.

2. Click the e button of the Classifier window toolbar. The Set label window opens.
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(@ set label () |

Choose option

@ Code
Code name
Type
Symbal
Size
Object name
Layer
z
(X,Y,Z)
Attribute value

Attributes: | -

Decimal places: E =

Label attribute name: Label

[ Ok ] | Cancel

Fig. 92. Label creation

3. Inthe Source data section select one of the data sources to be used to move data
to a label (see Section 6).

4. [optional] If the Attribute value was chosen, select code attribute in the list. These
values show as label to an object in 2D-window or in theAutoCAD program (after
export of selected code objects to DXF file).

5. [optional] Define decimal places to display in numerical labels. By default decimal
number is three.

6. [optional] By default the Label attribute name is specified as the Label. To change
the name input necessary name to appropriate field.

7. Click OK. Labels creates for all objects of selected layer. Labels display content of
selected source. The labels are also displayed in the object’s attributes list (see
Section 7) with the Label name by default.

LABEL

To set a label for all objects of selected layer, click the “ggbutton, after that the label is
assigned to all objects in selected layer.
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6.6. Association of vector objects with classifier.
Classifier’s records are assigned to vector objects using two ways:

» during vector object creation select desired code in the classifier and start object
vectorization, after that the code is assigned to the object automatically;

 assign code to existing object; to do that select vector object or object’s group in 2D-
window and desired code in classifier and click the B button (see Section 8.2).

6.7. Conversion of vector objects types

The system allows to convert polyline to polygon and vice versa while working with
classifier.

@ When working in vector layer without classifier objects types conversion is performed automat-
ically during closing/opening of a polyline (see Section 11.4).

In order to convert a polyline to polygon perform the following actions:
1. Select a polyline or a group of polylines.

2. Select in the classifier the C code type (polygon) and click the Ef] button in the
Classifier window. Polyline becomes closed and selected code is assigned to it.

In order to convert a polygon to polyline perform the following actions:
1. Select a polygon or a group of polygons.
2. Select in the classifier the L code type (polyline).

3. Click the Ef] button of the Classifier window toolbar. The Parameters of converting
’C’ ->’L’ window opens.

. Conversion 'C' -> 'L’ parameters L-";_E-J

Choose option

@ Keep lines dosure
set lines non-dosed with same first and last vertices

Delete last segment

Ok ] | Cancel

Fig. 93. Parameters of polygon to polyline conversion
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4. Select one of the following ways of conversion:

* Keep lines closure — a polygon is converted to closed polyline (non-areal object);

+ Set lines non-closed with the same first and last vertices — a polygon is
converted to opened polyline, which the first and the last vertices coincide;

* Delete last segment — a polygon is converted to a polyline, and the segment
between the first and the last vertices is deleted.

5. Click OK. Polygon converts to a polyline and selected code assigns to it (see the

Section 6.6).

7. Vector objects attributes

To perform operations related to vector objects’ attributes, Vectors > Attributes menu

items are intended.

@ The functionality of the Vectors > Attributes menu is designed to work with the attributes of
vector objects that were created in a layer without a classifier (as well as with additional attributes
not referenced to the classifier code, created in a layer with a classifier; see below). Editing at-

tributes created in a layer with a classifier and referenced to classifier codes is carried out in

the Classifier window.

7.1. The “Attributes” menu

Table 8. Brief description of the “Attributes” menu”

Menu items

Function

Copy attributes from points to polygons

provides possibility to copy attributes of point objects
and to assign them to polygonal objects

Merge point objects by attribute

to find all groups of points objects with equal values
of defined attribute or replace any group of found
points objects with one, placed in the center of all

group

Select by attribute

provides possibility to search objects both by value
and by attribute values list

Select by attribute value range

provides possibility to search objects by attribute
values range

Select by attribute list

to search objects using attributes values list

Attribute value range...

to display minimal and maximal value of selected
attribute

Color by attribute value...

provides possibility to display layer objects by differ-
ent colors depending on the height, or by selected
attribute of numerical type

Collate objects...

to perform search on a vector layer objects closest
to the objects of another vector layer

Interpolate attribute value...

to to interpolate attribute values
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Menu items

Function

Set labels...

provides possibility to create labels to vector objects
both from attribute values and code table fields, and
in the form of coordinates

Assign unique attribute value...

to assign a unique values to attributes of vector ob-
jects

Assign height from attribute

to set a height of vector objects from attribute

Assign height by DEM

for analyzing DEM heights within polygons (see the
“Assigning extreme DEM heights within the polygon
as attributes” chapter in “DTM Generation” User
manual)

Save the objects height in the attribute

to save the objects height in the attribute

Arithmetic operations...

provides for arithmetic operations on the values of
attributes of vector objects

Obligatory layer attributes

to assign required attributes to all layer’s objects

& Autofilled layer attributes...

to fill layer’s attributes automatically

i8] Automatic attributes filling

to automatically calculate area in specified measure-
ment units

Label attributes

provides possibility to display labels of vector objects
combined from multiple attributes with delimiters

Check layer semantic...

provides possibility to check layer's semantics —
type, size and accuracy of selected attribute; exist-
ence of attribute value; uniqueness of attribute val-
ues set

Calculate canopy of forest

provides possibility to calculate a value of canopy
of trees cover (in range from 0 to 1) using measuring
grid

7.2. Creation of vector objects attributes

The system provides possibility to create attributes both for vector objects codes (created
in layer with classifier) and for vector objects created in a layer without classifier. Any
additional parameter of the object, for example, object number, could be specified as

attribute.

The Vectors » Attributes menu provides to work with attributes the system, as well as
the Attributes tab in the Classifier window. Attributes table is displayed in the tab. It
consists of attributes Name, Type and Size fields.

7.2.1. Attributes creating and editing in layer with classifier

During work in a layer with classifier perform the following actions:

1. Select necessary code on the Codes tab of the Classifier window.

2. Select the Attributes tab and click the [=§ button. The Add attribute window opens.
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(@ Attribute adding (RS

Mame

Height
Type Size

float v] 1

4|k

Max decimal places 1

Description for export

Height of the tree|

Values list

PEEUEW

[ OK l [ Cancel

Fig. 94. The Add attribute window

3. Define the following parameters:
* Name of attribute;
+ Type of attribute:
o integer — attribute of integer type 4 bytes long;
o float — attribute of real type 8 bytes long;

o text —text attribute; text length is determined by its content, but not more than
8 bytes, otherwise — specifies fixed text length in bytes.

+ Size (in bytes) — for numeric types of attributes is defined automatically, otherwise,
is specified by user (for text attributes, for instance);

 [optional] Max decimal places after comma (for the float type of attribute only);

» Description for export — text field for correct import/export of attributes to
MIF/MID format.
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The Values list section allows to create list of preset values of integer attributes.
The toolbar of section contains the following buttons:

« [ - allows to add the attributes value;
« [ - allows to remove selected attribute value from the list.
. ﬁ — allows to edit name and value of attribute value;

. D — allows to clear the attribute values list;
@ If there is a list of attribute values, it is possible to select values only from this list, otherwise,
it is possible to select arbitrary values.
4. Click OK. After that for selected code the attribute with specified parameters is

created.

To edit attribute parameters is used the Edit attribute window. In order to open the
window click the [E button of the Classifier window.

(@ Attribute editing =)

Mame

COCTOAHWE
Type Size
integer =4

Description for expart

Values list

"NEACTEYIOWMA" -> 1 =
"CTPOAWMACA" -= 2
"PAIOEPAHHLIN" -= 3
"HEAEWCTBYHOLLMIA® -= 4 _

] [T 3

FREUW

[ Ok, ] I Cancel

Fig. 95. Editing of object attribute

To delete active field of the attributes table click the [Z3 button on theAttributes tab of
the Classifier window.

Toolbar on left part on Attributes tab allows to perform the following:
* % —move record to the top position;

* % —move record one position up;

112



PHOTOMOD 8.1 Vectorization (Windows x64)

* % —move record one position down,;
« % —move record to the bottom position;

« B2 — rebuild the list of attributes in the reverse order.
7.2.2. Additional attributes creating and editing in layer with classifier

In addition to creating the attributes attached to the classifier record, it is possible to
create additional attributes, which are unique for the selected object. That means that
all objects assigned to some classifier code, have common attributes specified in clas-
sifier, and it is possible to assign unique (“additional”) attributes to each of them.

@ In contrast to conventional attributes of objects, the system does not support the ability to export
additional attributes to *.rsc files.

To create additional attributes perform the following:
1. Select a vector object or vector objects group.
When multiple objects with attributes are selected, select only attributes with the same

values in the table of Objects attributes window. Strings of attributes with different values
highlights by red color.

2. Choose the Window » Object attributes or click the [ button of the Vectors ad-
ditional toolbar. The Object attributes window opens.

[ @ Object attributes =)

coEEE

Property Value
Code 71324170
Code name Qoroeraj
Type C

- Colar B 0. 0,01 (255)

Symbol
Size 10

Property Value
COBCTBEHHOE HAZBAHWE
MACIITAE OTOBP.3HAKA B MPOLEHTAX 0.00
BHICOTA WPNDTA 0.00
HAIBAHKE WPADTA
TONWWHA AMHIAK B MM 0.00
TONWWHA OKOHYAHIAA NKMHIAK B MM 000
BEC LIBETA OBBEKTA B MPOUEHTAX 0.00

Fig. 96. Additional attributes (layer with Classifier)
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The window that opens contains two tables. The upper table contains information
on the classifier code (see Section 6.1). The lower table contains the list of object
attributes. First of all, this table lists attributes referenced to the classifier code;
below are unique (additional) object attributes (see above).

@ To see the list of classifier-code-referenced attributes (without additional attributes), open
the Attributes tab in the Classifier window.

The following buttons are used to create and edit additional attributes:

« [} — allows to delete all additional attributes of selected objects:

« [ — allows to delete additional attributes, common for selected objects;
« [ - allows to add a new additional attribute and its parameters;

. ﬂ — allows to delete additional attribute selected in the table;

« [ - allows to edit properties of selected additional attribute;

3. Click the [ button. The Additional attribute adding window opens:

@ Additional attribute adding SRS

Mame

Type Size

float -

4|

Max decmal places 1

Description for expaort

QK ] | Cancel

L A

Fig. 97. The Additional attribute adding window

4. Define the following parameters:
* Name of attribute;
» Type of attribute:
o integer — attribute of integer type 4 bytes long;

o float — attribute of real type 8 bytes long;
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o text —text attribute; text length is determined by its content, but not more than
8 bytes, otherwise — specifies fixed text length in bytes.

+ Size (in bytes) — for numeric types of attributes is defined automatically, otherwise,
is specified by user (for text attributes, for instance);

+ [optional] Max decimal places after comma (for the float type of attribute only);

» Description for export — text field for correct import/export of attributes to
MIF/MID format.

5. Click OK.
To input or edit existing attribute values perform the following:

1. Select a vector object or vector objects group.

When multiple objects with attributes are selected, select only attributes with the same
values in the table of Objects attributes window. Strings of attributes with different values
highlights by red color.

2. Choose the Window > Object attributes or click the |} button of the Vectors ad-
ditional toolbar. The Object attributes window opens;

3. Click on the table field in the Value column opposite to name of selected attribute.
The field becomes editable then.

© Object attributes =5
D@
Property Value
Code 44211000
Code name CTPOEHWE OMHECTOMKOE XWNOE
Type C
> Color [252, 168, 84] (255)
Symbol
Size 1.0
Code editor Value it
"COCTOAHWE" OEVCTEYHIULY -
"COBCTEEHHOE HAZBAHMWE" oo iR — |
"UWACNO 3TAXKEN, KAMEP LLNKO3A" PA3O. HHEIA | =
"@YHKLWOHANBHOE HASHAHYEHME" HEE... FOLL A
"HOMEPA JOMOB" AKAnon -
p . HEKWMNOA _
MATEPWAN CO?P}')KEHMH PA3P.. HHBIA
"KOMMEHTAPILA" MPOEZKIANA
"HOMEP MO TEHMAAHY" HEHP';'B)KMM
"TIAH ETIA" cyxon -

Fig. 98. Editing attribute value
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4. Input attribute value.

5. To complete editing and save changes press Enter or pass to the next cell.

@ To exit without saving changes press Esc.

The system provides possibility to copy attributes of point objects and to assign them
to polygonal objects. To do this the Vectors » Attributes » Copy attributes from points
to polygons menu item is used.

7.2.3. Creating and editing attributes in layer without classifier

In addition to creating vector objects attributes attached to a specific code of the classi-
fier, the system has the ability to create attributes of objects in the layer without classi-
fier.

In order to add attributes, that are not attached to classifier code, perform the following
actions:

1. Create or load vector layer without classifier.
2. Select a vector object.

3. Choose the Window » Object attributes or click the [ button of the Vectors ad-
ditional toolbar. The Object attributes window opens.

r’ Object attnbutes lﬁﬁ
COEESE 2P

Mame Value

.........................

"Width" 10

Fig. 99. Vector objects attributes (layer without Classifier)
The table in the Object attributes window contains the list of object attributes.
The following buttons are used to create and edit attributes:
« [0 - allows to delete all attributes of selected objects;

+ [} — allows to delete common attributes of selected objects;
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« [ - allows to add a new attribute and its parameters;
. ﬂ — allows to delete selected attribute;

« [ - is used to edit selected attribute properties;

HBe — allows to sort attributes of selected objects;
« 2] — allows to invert attributes of selected objects.

4. Click the [ button. The Add attribute window opens:

(@ Add attribute |

Attribute name

Attribute type float - |

4|k

Attribute value 0.0

4|

Max decimal places 1

[ QK ]| Cancel |

Fig. 100. The Add attribute window

5. Define the following parameters:
* Name of attribute;
» Type of attribute:
o integer — attribute of integer type 4 bytes long;
o float — attribute of real type 8 bytes long;

o text — text attribute; text length is determined by its content, but not more than
8 bytes, otherwise — specifies fixed text length in bytes.

+ Value of attribute;
+ [optional] Max decimal places after comma (for the float type of attribute only);
6. Click OK.

In order to edit attributes, that are not attached to classifier code, perform the following
actions:
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1. Create or load vector layer without classifier.

2. Select a vector object.

3. Choose the Window > Object attributes or click the [fi§ button of the Vectors ad-

ditional toolbar. The Object attributes window opens.

4. Click on the table field in the Value column opposite to name of selected attribute.

The field becomes editable then:

’. Object attnbutes

SO

00 @i

2l BO

Mame

Value

"sheet_name" aalen_cutlines_test

"create" E

P

A

Fig. 101. Vector objects attribute editing (layer without Classifier)

5. Input attribute value.

6. Tocomplete editing and save the input value press Enter or pass to the next attribute

value cell.

é To exit without saving changes press Esc.

7.2.4. Adding required attributes of a layer

The system allows to assign required attributes to all layer’s objects.

In order to add required attributes to a layer objects, perform the following actions:

1. Make editable a layer for which to add required attributes.

2. Select Vectors » Attributes > Obligatory layer attributes. The Required attributes

window opens.
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r’. Cbligatory attributes @ﬁ
O E =
Marme Value Def. value
Height integer 0
Square float 0.000000
OK. ] [ Cancel

Fig. 102. The Required attributes window
The following buttons are used to create and edit additional attributes:
« [ — allows to clear the obligatory attribute values list;
« [3 - allows to add a new attribute and its parameters;
. ﬂ — allows to delete attribute selected in the table;
« [ - is used to edit selected attribute properties;
3. To add attribute click the [Zbutton. The Edit attribute window opens.

(@ Add attribute ==

Attribute name

Attribute type Default value
float | 0

L1l

4k

Max decmal places 1

[ oK ] [ Cancel

Fig. 103. Attribute parameters

4. Define the following parameters:
» Attribute name;
» Attribute type:
o integer — attribute of integer type;

o float — attribute of real type;
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o text— text attribute; text length is determined by its content, but not more than
8 bytes.

+ [optional] Max decimal places after comma (for the float type of attribute only);

» Default value — a value assigned automatically to all objects of selected layer
as an attribute.

5. Click OK. Attributes from the list of the Required attributes window are assigned
to all objects of selected layer.

7.2.5. Arithmetic operations on attribute values

The system provides for arithmetic operations on the values of attributes of vector objects
created in the layer without a classifier (also on the values of extra attributes that are
not referred to a classifier code, and created in the layer with a classifier).

é Arithmetic operations are not available for attributes referred to a classifier code.

The results from arithmetic operations are saved as new attributes (or new values of
the existing attributes). The system also allows for concatenation of attribute values.

Concatenation (latin concatenatio) is the operation of linking linear objects, usually strings. For
example, the concatenation of the words “micro” and “wave” yields the word “microwave”.

To perform arithmetic operations on attribute values, perform the following:

A All attributes are to be of the same type.

1. Create or load a vector layer that contains objects with proper attributes. Make this
layer editable;

2. [optional] To perform arithmetic operations for the selected objects only, select the
desired vector object (or a group of objects);

3. Choose Vectors > Attributes > Arithmetic operations. The Arithmetic operations
window opens:

120



PHOTOMOD 8.1 Vectorization (Windows x64)

I N
0 Arnthmetic operations &J
Operand 1
| Height - |

Arithmetic operation

[+ )

Choose operand 2 type

@ Attribute value Constant

Width -

Mame of resulted attribute
Width nd height sum -

@ Al Only selected

Canvert string operands to float

[ (0]4 ] | Cancel

Fig. 104. The Arithmetic operations window
? If loaded vector layers containing objects with proper attributes are absent, an appropriate

info message is issued.

4. Inthe Operand 1 drop-down list, select the name of the attribute on the values of
which it is needed to perform an arithmetic operation;

5. In the drop-down list, select the arithmetic operation to be performed (addition,
subtraction, multiplication, or division);

6. Select the Operand 2 option to be used and set its values:

* [optional] Attribute value — select the name of an attribute the value of which is
to be used as the operand 2;

 [optional] Constant value — is to be set in the appropriate field.

7. Enter the name of resulted attribute in the appropriate input field (in case if the
result is to be recorded as new attribute values) or select the name of the existing
attribute from the drop-down list (to overwrite the calculation results instead of its
current values);

? One of operands can be used as an attribute for recording the result.

8. Select objects in the editable layer subjected to an arithmetic operation, all or only
selected,;
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10.

Leave the Convert string operands to float checkbox set;
Click OK.

After the operation is complete, an appropriate message on the number of processed
and skipped attributes is issued.

If the value of the first and/or of the second operand is not a number, this vector
object will be excluded from the processing ant its attributes will be marked as
skipped.

It must be considered, that the drop-down lists intended for selecting the attribute
name (used to record the result or as the operand 1 or 2) display all the attributes
not referred to classifier codes assigned to vector objects of the editable layer.
These may include attributes assigned to only some (but not all) objects.

Accordingly, in order for an arithmetic operation on the attributes of a particular
vector object to be performed, both attributes used as the first and second operands
must be assigned to this object.

Similarly, if an already existing attribute is selected for recording the results, its
values will be overwritten for the objects to which it was previously assigned, while
the specified attribute will be assigned to other involved objects as a result of the
operation.

& PHOTOMOD 7.3.3872 b=l &

] \_i_) 13/02/2023 18:31:18: Total changed: 0 attributes
Skipped: 8

0

1

CEE]

0

]
|

—

Fig. 105. An info message
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To perform concatenation (merging together) of attribute values, perform the following:

A All attributes involved (operand 1 and operand 2) are to be of the same text type.

1. Create or load a vector layer that contains objects with proper attributes. Make this
layer editable;

2. [optional] To perform arithmetic operations for the selected objects only, select the
desired vector object (or a group of objects);

3. Bbibepute Vectors > Attributes » Arithmetic operations. The Arithmetic opera-
tions window opens:

i '\
& Arithmetic operations Iﬁ
Operand 1
| Height - |

Arithmetic operation

[+ ]

Choose operand 2 type

@ Attribute value () Constant

Width -

Mame of resulted attributs
Width nd height sum -

@ Al ) Only selected

[] convert string operands to float

oK ] I Cancel

Fig. 106. The Arithmetic operations window
é’ If loaded vector layers containing objects with proper attributes are absent, an appropriate
info message is issued.
4. Select the name of the desired attribute in the Operand 1 drop-down list;
5. Select the addition operation in the arithmetic operation drop-down list;

6. Select Value from attribute as Operand 2 option and in the appropriate drop-down
list select the name of the attribute the values of which is to be used as the operand
2
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10.

Enter the name of resulted attribute in the appropriate input field (in case if the
result is to be recorded as new attribute values) or select the name of the existing
attribute from the drop-down list (to overwrite the calculation results instead of its
current values);

@ One of operands can be used as an attribute for recording the result.

Select objects in the editable layer subjected to an arithmetic operation, all or only
selected;

Clear the Convert string operands to float checkbox;
Click OK.

After the operation is complete, an appropriate info message on the number of
processed and skipped attributes is issued. The merged values of the first and
second operands will be written as the values of the attribute selected for recording
the results.

7.3. Vector objects labels

7.3.1. Labels creation

The system provides possibility to create labels to vector objects both from attribute
values and code table fields, and in the form of coordinates.

To create labels to vector objects perform the following actions:

1.

Select Vectors > Attributes > Set labels. The Set label window opens.
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r. Set labels @1

[7] For zelected objects only

@ Attribute value IHeight 'I
! Coordinates

Point objects [] centers of line ohjects

Template Yok %o YoY% Wl %o

Substitutions: 36X% , 36Y%, %Z% - coordinates as floating-point numbers; when
coordinate system is latitude longitude, also %XD% and %eYD%%6 - longitude and latitude in the form
correspanding to lower left pane in the Marker window.

[7] In another coordinate system

Cartesian Right (Local right Cartesian reference system) Select, @

Orientation: right, geo-referending: local coordinate system

Ok ] I Cancel J

Fig. 107. Labels parameters

2. [optional] To set labels to selected objects, set the For selected objects only
checkbox on.

3. Select one of options of labels creation:
« Attribute value — labels create from values of selected attribute;
» Coordinates — object coordinates display as labels (depending on object type);
o Point object — display coordinates of points and polygon/polyline vertices;
o Centers of line object — display coordinate of line objects centers;

Coordinates should by created using the template %X% %Y % %Z%.

§ Set on both objects to display labels for all object types.

% The system allows to create labels in the coordinate system different from project co-
ordinate system. To do this set the In another coordinate system checkbox on and
select coordinate system to be displayed.

4. Click OK. After that labels to selected objects are displayed in 2D-window.
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@ There are hotkeys to hide labels: in active layer — Ctrl+H, in all layers — Ctrl+Shift+H. Also
the Edit > Active layer > Show/Hide labels in active layer menu item allows to hide labels.

@ The value specified in the Import/export etc. field is used to define number of decimal

places for attributes labels (see the “Setup of modules start” chapter of the “General system’s
parameters” User Manual).

@ The value specified in the Import/export etc. field is used to define number of decimal

places for coordinates labels (see the “Setup of modules start” chapter of the “General
system’s parameters” User Manual).

7.3.2. Labels attributes

The system provides possibility to display labels of vector objects combined from multiple
attributes with delimiters.

In order to show combined labels perform the following actions:

1. Select Vectors » Attributes > Label attributes. The Layer label attributes window
opens.

r. Layer label attributes @ﬁ

Label attributes

Label s
™y
W
n
[

Attributes separator
QK l I Cancel
e -

Fig. 108. Layer labels
The window Layer label attributes contains the toolbar for the following operations:

» % — moving attribute to the top position;
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* % —moving attribute one position up;
* % —moving attribute one position down;
« % —moving attribute to the bottom position;
« [ — allows to clear the attributes list;
« [ - allows to add new attribute;
« [E - allows to add attribute from list of existing layer attributes;
« [ - allows to remove selected attribute.
2. Inthe Label attributes section the list of available attributes with labels is displayed.

3. Inthe Attributes separator section specify a symbol to be used as a separator of
attributes.

@ The system supports special symbols of XML markup language that are used as separators.

% Line spacing is set on the Labels tab of the Settings window (see the “General system’s
parameters” User Manual).

4. Click OK. As a result, for vector objects vertices having attributes the labels in the
form of attribute values with specified delimiter are displayed in 2D-window.

% During automatic polygon attributes assigning or at manual attributes change labels attrib-
utes are updated automatically.

7.4. Attributes assigning

7.4.1. Assigning of unique attribute value

Unique values could be assigned to attributes of vector objects. This simplifies combining
objects into groups by attribute values and automate the assignment of attribute values
to vector objects. This function is used for further work in 3D-Mod program.

To assign unique attribute value to objects, perform the following actions:
1. Select a vector object or multiple objects in 2D-window.

2. Select Vectors > Attributes > Assign unique attribute value. The Assign unique
attribute value window opens.
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i !
. Assign unique attribute value lﬁ

Attribute name (choose existing or enter new name)

Gru:uupID| -
Mumbering origin
@ Assign new unigue value
Copy from active object

Begin numbering fram the value: g

The value for selected objects
@ Unigue for each object
Equal for all objects

oK ] | Cancel

Fig. 109. Parameters of unique attribute values

3. Select attribute in the Attribute name field to input unique value or specify a new
attribute name.

§ When you define a new attribute name the system creates an additional attribute of integer
type for the selected objects.

4. Select one of the following ways of unique value assigning:

+ Assign new unique value — allows to specify new unique value of active object
attribute;

» Copy from active attribute — allows to copy a value of selected object attribute;

* Begin numbering from the value — allows to start numbering from arbitrary
number specified in this field.

5. Select a way to specify the value of selected objects:
» unique for each object;
+ equal for all objects.

6. Click OK. Unique attribute value is assigned to selected vector objects.
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7.4.2. Save the objects height in the attribute

The system allows to save the objects height in the attribute. Height calculates as dif-
ference between the value of the DEM cell and height of the object vertices.

@ This function may be used to save roof heights over the ground level as attributes.

In order to save the objects height in the attribute perform the following actions:

1. Load a vector layer and a DEM in the project.

% For correct work of the function make sure, that only one layer with vector object and only
one DEM is opened in the current project.

2. Select Vectors > Attributes » Save objects height above DEM to attribute. The
Layers selection window opens.

( . Select layer ﬁﬁ

Attribute name  height

Attribute type | text - |

4k

Decimal places 3

Ohjects height

@ Average Minimal Maximal
DEM height

@ Average Minimal Maximal

Apply to selected

oK l I Cancel

LS "

Fig. 110. Parameters of saving the objects height in the attribute

3. Define the following parameters in the window:
+ Attribute name — "height" by default;
+ Attribute type — text, integer or float;

» Decimal places — allows to specify the number of decimal places (from 0 to 24);
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* Objects height — allows to use average, minimal or maximal height of vector
object vertices to define difference with DEM,;

* DEM height — allows to use average, minimal or maximal value of DEM cells
around vector object to define difference with the object.

4. [optional] To assign objects height only to attribute of selected objects, set the Apply
to selected checkbox on.

5. Click OK. As a result, height difference is assigned to all or selected objects of
vector layer as attribute.

7.4.3. Assigning height from attribute

The system allows to set a height of vector objects from attribute.

c Given function works correctly if an attribute regardless of its type constitutes a number. Otherwise
specified value of vector object height will be equal zero.

To assign a height of vector objects from attribute perform the following actions:
1. [optional] Select vector objects, height of which is necessary to set;

2. Select Vectors > Attributes > Assign height from attribute. Assign height from
attribute window is opened.

g !
’. Aszsign height from attribute I,&J
Attribute name
| Height -|
@ Al Only selected
Ok l | Cancel |
ey "

Fig. 111. Settings of assigning object heights to attributes

3. Select from the list an attribute value of which will be set as a height;

4. [optional] Set parameter Selected to assign height from attribute to selected objects
only;

5. Click OK. As a result the value of attribute selected is assigned as a height to the
all or to selected objects of vector layer which have a given attribute.
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7.4.4. Automatic filling layer’s attributes

The system allows to fill layer’s attributes automatically.

Perform the following actions for creating autofilled attributes:

1.

2.

Make editable a layer for which to add autofilled attributes.
Create attribute with float type.

[optional] To display a value of autofilled attribute in 2D-window specify labels at-
tributes for created attribute.

@ Labels attributes refresh automatically.

Choose Vectors > Attributes > Autofilled layer attributes or click the B button
of the Vectors additional toolbar. The Autofilled attributes window opens.

r. Autofilled attributes o
O E 3=
Mame Value Units
Square éArea on the reference surface Project units
Area Area in project c.s. ha
K ] | Cancel
. J

Fig. 112. The Autofilled attributes window

The window Autofilled attributes contains the toolbar with buttons used to perform
the following operations:

« [ —is used to clear the attributes list;

« [3 - is used to add new obligatory attribute;

« [ - is used to remove selected attribute.

« [ - is used to edit parameters of selected attribute.

To add click the [E3button. The Edit attribute window opens.
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6. Click the [#4 button to select attribute from attributes list.

TONWMHA OKOHYAHIA NWMHKIA B MM

COBCTBEHHOE HAZBAHWE
MACLUTAE OTOBP.ZHAKA B MPOLEHTAX

10.

& Attribute editor

(o |

Attribute name

Square]

Value

=]

[Area on the reference surface

Linear units

[F‘rnjer.:t units
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Fig. 113. Attribute editing
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Fig. 114. Selection from list of mandatory attributes

é A name of autofilled attribute should be the same as a name of attribute.

In the Value list select a value to be used for autofilling: Area in project CS or Area

on the reference surface.

% A value of the area on the reference surface is calculated only when using coordinate

system matched with WGS-84.

Select one of the following area measurement units: project units, sq.m, ha,

sq.km.
Click OK.

Choose Vectors > Attributes > Automatic attributes filling or click the 8 button
to automatically calculate area in specified measurement units. The value is dis-
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played in the Object attributes window and/or as attributes labels (see Sec-
tion 7.3.2).

The polygon square, created or edited after setting autofilling attributes, also could be
displayed. To do this choose Vectors > Attributes > Automatic attributes filling or
click the 8 button. Attribute value refresh for all polygons in active layer.

@ If not mandatory attributes are used as autofilling, they are not assigned to a new objects. To

display square of a “new” polygons, it is required to create float attribute with name, equal to
name of autofilling attribute and click the 8 button.

7.4.5. Objects collation

Objects collation operation is used to search on a vector layer objects closest to the
objects of another vector layer.

This operation is a specialized and used to automate search of differences between two versions
of the file with exterior orientation parameters, if there is a possibility that one of them contains
wrongly compared names and images and projection center coordinates.

Perform the following actions to do collation:

1. Select Vectors > Attributes » Collate objects. The Collate objects window opens.

@ Collate objects 5
Warking layer
|test_attributes (Vectors) - |

Reference layer
|a||_ver_tors (Vectors (2)) - |

Attribute containing reference object name:

- source {on reference layer) MName

- target (on working layer)  Refame

-

Search range 0.0 = m

[ Ok ] | Cancel

L A

Fig. 115. Parameters of objects collation

2. Select Working layer, where it is necessary to perform objects collation.
3. Select Reference layer, where to search objects closest to working layer objects.

4. [optional] To perform search for objects with specified attribute name, input the
Attribute containing reference object name to the source (on reference layer)
field.
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5. [optional] To record the values of found objects attributes of the reference layer to
attributes of the working layer objects, input the Attribute containing reference
object name to the target (on working layer) field.

6. Specify the Search range value in meters, within which the search is performed.

7. Click OK. After that each object of the working layer contains attribute with the name
of closest object of the reference layer.

@ The working layer is available for export to format which supports tabular format of attributes
recording (for example, to DBF) to create match list of one layer objects to another for further
analysis.

7.4.6. Using attributes when building 3D-objects

The 3D-Mod software supports import of vector objects from ASCII-A-files as initial data
for automatic creation of 3D-objects (see the “Three-dimensional modeling” User
Manual). When building 3D-objects in the 3D-Mod software, there is also a capability
to use values of the type attribute of imported vector objects that determine the way of
object data using when building.

The system allows for creating the type attribute and assigning values to it directly
during the vectorization process as part of data preparation for further work in the 3D-
Mod.

To assign type attribute values, use 3D-Mod toolbar (Window > Toolbars > 3D-Mod).

Table 9. The “3D-Mod” toolbar

Button Purpose

v enables the value input mode for the type attribute

Hone to create a type attribute and assign the none value to it for all vector objects to be
created

Okj to create a type attribute and assign the object value to it for all vector objects to be
created

Brk to create a type attribute and assign the break value to it for all vector objects to be
created

Lik to create a type attribute and assign the library value to it for all vector objects to
be created

Set to create a type attribute and set the chosen value to it (Hume, 0&i, Bk or Lik), for all se-
lected already existing objects

To assign type attribute values to vector objects to be created, perform the following:

1. Open the 3D-Mod toolbar (Window » Toolbars » 3D-Mod);
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To enable the type attribute value input mode, click the % button on the 3D-Mod
toolbar;

Choose one of the type attribute values by clicking the Hme oki Bk or Lik buttons;
Create one or more vector objects;

To disable the type attribute value input mode, click the ¥ button on the 3D-Mod
toolbar.

é The user can change type attribute values before creation of the next vector object by
clicking the Hme, 0ki | Erk or Lik buttons, if appropriate.

é To check the attribute value, select a vector object and choose Window > Object attributes
or click the [# button on the Vectors additional toolbar. The Object attributes window
opens.

To assign type attribute values to already existing vector objects, perform the following:

1.

2.

Open the 3D-Mod toolbar (Window > Toolbars > 3D-Mod);

To enable the type attribute value input mode, click the % button on the 3D-Mod
toolbar;

Select one or more vector objects;
Choose one of the type attribute values by clicking the Hme 0k, Btk or Lik buttons;
Click the 2et button;

To disable the type attribute value input mode, click the ¥ button on the 3D-Mod
toolbar.

% To check the attribute value, select a vector object and choose Window > Object attributes
or click the [ button on the Vectors additional toolbar. The Object attributes window
opens.

7.5. Operations with objects using attributes

7.5.1. Merging point objects by attribute

Operation of merging point objects by attribute allows:

+ to find all groups of points objects with equal values of defined attribute;

* replace any group of found points objects with one, placed in the center of all group.
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Q This operation is used, for example, to perform generalization of map, where some physical
objects are displayed by point objects groups, and in the attributes of each group objects is re-
gistered a name of a real object, to which these point objects relate to.

@ If it is necessary to merge closed polygons groups using the same principle, use the Convert
polygons to points function in advance.

For transformation perform the following actions:

1. Choose Vectors » Attributes » Merge point objects by attribute. The Group
objects by attribute window opens.

. Group objects by attribute I,&J

Attribute name for grouping

| Height - |

oK ” Cancel |

Fig. 116. Attribute name selection

2. Selection attribute name from the list, which values are used for the merging.

3. Click OK. The system performs search of all point objects with specified attribute.
Objects found are grouped by attribute value, then in each group all objects are
removed, except for the one randomly selected. The remaining object is moved to
mass center of the original group.

? If in the active vector layer there is no point object that has an attribute with the specified
name, the system displays an error message.

7.5.2. Object search using attribute value

The system provides possibility to search objects both by value and by attribute values
list.

To search objects using attributes values perform the following actions:

1. Select Vectors » Attributes > Select by attribute. The Find by attribute window
opens.
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. Find by attribute

Attribute name

| Height

Search template (number to compare)

Searching mode

@ Exact match Regular expression

Comparison operator

Case-insensitive search

Find not matching

Mumerical comparison

Substring match

(0]4 ] | Cancel

Fig. 117. Search by attribute

2. In the Attribute name field select attribute that values will be used to perform the
search.

3. Inthe Search template field input text line or number, that will be used to perform
the search. The value of this field is interpreted by the system depending on the
search mode.

Select one the search modes:

itive search checkbox on.

Substring match — the system searches for objects whose attribute value con-
tains the string template;

Exact match — the system searches for objects whose attribute value is exactly
the same as search template;

Regular expression — the system searches for objects whose attribute value
matches the regular expression specified in the Search template field;

Numerical comparison — the system searches for objects, for which the numer-
ical value of the search string is compared with the attribute value using one of
the comparison operators=, >, <.

[optional] To search for objects using case insensitive search set the Case insens-
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7.

7

[optional] To search for objects that do not have the specified attribute or which
value does not satisfy the search condition, set the Find not matching checkbox
on.

Click OK. Found objects are highlighted in 2D-window.

Found objects highlight considering active group selection mode.

To search objects using attributes values perform the following actions:

1.

Select Vectors > Attributes » Select by attribute list. The Search by attribute
values list window opens.

i N
. Search by attribute values list S

Attribute name
|Height -
File with a list of values

Select objects with attribute value not in list

Case-insensitive search

[ QK l | Cancel |

Fig. 118. Search by attributes list
In the Attribute name field select attribute that values will be used to perform the
search.

In the File with a list of values field click the _... | button and select a *.txt file
containing a list of values for search (each value on a new line).

[optional] Set the Select objects with attribute value not in list checkbox on, to
found those objects that have no attribute values in the selected list.

[optional] To perform search using case insensitive search set the Case insensitive
search checkbox on.

Click OK. Found objects are highlighted in 2D-window.

% Found objects highlight considering active group selection mode.

7.5.3. Select by attribute value range

The system provides possibility to search objects by attribute values range.
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Perform the following actions to do this:

1. Select Vectors > Attributes > Select by attribute value range. The Search by
attribute values range window opens.

. Search by attribute values range [&J

Attribute name

| Height ~|

Minimum 0.0 % Maximum 0.0 =

Range

@ Within range Qut of range

Including minimum Induding maximum

[ OK ] | Cancel

Fig. 119. Search by attribute
2. In the Attribute name field select attribute that values will be used to perform the
search.
3. Inthe Minimum and Maximum fields specify value range for search.
4. Choose the task for processing in the Range section:
« Within range — to find attributes with values within specified range;
» Out of range — to find attributes with values out of specified range.

5. [optional] Set the Including minimum/maximum checkboxes on to consider
min/max values during search.

6. Click OK. Information message about loaded vectors is displayed. Found objects
are highlighted in 2D-window.

@ Found objects highlight considering active group selection mode.

7.5.4. Custom object paint

The system provides possibility to display layer objects by different colors depending
on the height, or by selected attribute of numerical type.

In order to change objects coloring on active layer, perform the following actions:
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1. Select Vectors» Attributes » Color by attribute value. The Custom objects paint
window opens.

i . Custom objects paint ﬁ

@ Standard layer style

Color by 7 value

Color by attribute value

L A

Fig. 120. Parameters of objects paint using attributes

2. Select one of the ways to change the color of layer’s objects:
« Standard layer style — vector objects color set in the layer properties;

» Color by Z value — color of vector objects changes by altitude scale depending
on object Z-coordinate value;

» Color by attribute value — color of vector objects changes by values of selected
attribute.

§ It is possible to use text attribute if all its values could be converted into number;

3. [optional] To fill the layer’s polygons in accordance with values of selected attribute,
set the Fill polygons checkbox on.

4. Click OK. As a result, the coloring of objects is changed depending on selected
options.

ﬁ Objects that have no selected attribute are displayed in gray.

7.6. Attribute value range
The system allows to display minimal and maximal value of selected attribute.
Perform the following actions to do this:

1. Make vector layer active.
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2. Select Vectors » Attributes » Attribute value range.

i . Attribute value range ﬁﬁ
Attribute name
| Height - |
[ oK ] I Cancel ‘

Fig. 121. Attributes value range

3. Choose attribute name to find its maximum and minimum value.

4. Click OK. Information window with the following information about the attribute
displays. If the selected attribute has text type or has no values, the system displays
an appropriate error message.

7.7. Attributes value interpolation

The system provides possibility to interpolate attribute values. It is used to define images
exterior orientation parameters, acquired by unmanned aerial vehicles and having only
the data about the time of image acquisition.

To interpolate attributes values, perform the following actions:

1. Load a vector layer;

§ For vector objects, it is necessary to have at least one layer with at least two different at-
tributes.

2. Select Vectors > Attributes > Interpolate attribute value:

. Interpolate attribute values [ﬁ

Attribute with function argument

|Height -|
Attribute with function value

| width -|

L8 4

Fig. 122. The Interpolate attribute values window

3. In the Attribute with function argument field select attribute name of numeric
type that will be used for interpolation as a function argument.
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4. In the Attribute with function value field select attribute name of numeric type
that will be used for interpolation as a function value.

5. Click OK. As aresult, an interpolated value of attribute, specified as a function value
is assigned to objects that contain only argument attribute.

7.8. Layer’s semantics check

The system provides possibility to check layer’'s semantics. The following parameters
is checking:

* type, size and accuracy of selected attribute;
» existence of attribute value;
* uniqueness of attribute values set.

The Check semantics window is used to configure parameters of the operation, and
it contains the following buttons:

« [ - allows to clear the attributes list;

« [ - allows to add a new attribute and specify semantics check parameters for it;
« [E - is used to add attribute existing in the list of layer attributes;

. ﬂ — allows to remove selected attribute from the list;

« [ - allows to edit selected attribute properties;

» L= — allows to load the attribute template file;

. — allows to save the attribute list to file for further using as a template.

To perform semantic check, perform the following actions:

1. Select Vectors > Attributes » Check layer semantic. The Check semantics window
opens.
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. Check semantics

==

NEEEE =8

Mame

Type Size

Precision

Criteria check

[7] selected objects

Check key unigueness within the layer
Check values type
Check values existence

[ ok

l [ Cancel

Fig. 123. The Check semantics window opens.

2. Prepare attribute list with one of the following way:

« to select existing attribute from the list, click the [ button. The Attributes selec-
tion window opens. Select single or multiple attributes by mouse click and click

OK.

. Attribute selection Iﬁ
TONWIMHA OKOHYAHIMA NAHLAL B MM
COBCTBEHHOE HA3BAHWE
MACIUTAE OTOBP.3HAKA B MPOUEHTAX
BEHICOTA LWPAGTA
HAZBAHWME WPNGTA
TONWIAHA NAHKIA B MM
BEC LIBETA OBBEKTA B MPOLEHTAX

[ OK ][ Cancel l

L

4

Fig. 124. The window used to select attributes from existing ones

« to add a new attribute click the [ button. The Edit attribute window opens.

(@ Attribute editor =)

Attribute name

Attribute type [ Size [ Precision

[ OK H Cancel ]

b 4

Fig. 125. The Edit attribute window
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3.

[optional] Define attribute parameters. When create a new attribute, the Edit attrib-
ute window opens automatically. To open window for attribute from the list, double-
click on attribute name or click the [ button.

Define the following parameters:
» Attribute name — arbitrary name;
* Type — attribute type; the system supports the following types:
o integer — attribute of integer type 4 bytes long;
o float — attribute of real type 8 bytes long;
o text — text attribute.
+ Size (in bytes) — [for number types of attributes] to check the attributes size;
* Precision — [for number types of attributes] decimal places.

[optional] To check semantics of selected objects only, set the Selected objects
checkbox on, otherwise, the check operation will be performed for all objects.

The Criteria check section is used to select single or multiple criteria to check
layer semantics:

ﬁ If the specified attribute is absent for object, the system displays error message.

» Check key uniqueness within the layer — the system creates a key (a set of
consecutive parameters) for values of selected attributes and checks uniqueness
of the key value for each object of the layer.

» Check values type — for specified attributes of each object of the layer the system
checks for the compliance of the attribute value to type, size and accuracy;

» Check values existence — for specified attributes of each object of the layer the
system checks for the attribute values other than the default.

@ As default values for attributes of “text” type is provided an empty string, for attributes
of “float” and “integer” type — “0” value. If the attribute is mandatory, the system also
performs check its default value.

Click OK. The system starts operation of layer semantics check. If there are some
discrepancies the system shows warning and the Errors in attributes window
opens. It contains the list of errors found:
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-
. Attnbute errors

EAttriI::lute not found

Attribute name="Width"

Attribute not found
Attribute not found
Attribute not found
Attribute not found
Attribute not found
Attribute not found
Attribute not found
Attribute not found
Attribute not found
Attribute not found
Attribute not found
Attribute not found
Attribute not found

Attribute name="Height"

Attribute name="Width"

Attribute name="Height"

Attribute name="Width"

Attribute name="Height"

Attribute name="Width"

Attribute name="Height"

Attribute name="Width"

Attribute name="Height"

Attribute name="Width"

Attribute name="Height"

Attribute name="Width"

Attribute name="Height"

Fig. 126. The Errors in attributes window

@ During check of the key uniqueness the error message informs about number of objects
with non-unique attributes.

7. Select aline with error in the list by mouse click. The appropriate object (or objects)
select in the layer, marker is moved on a stereopair with the object and is placed
to the object center. Error correction is performed manually in the Objects attrib-

utes window.

7.9. Calculation canopy of forest

The system provides possibility to calculate a value of canopy of trees cover (in range
from 0 to 1) using measuring grid.

To perform canopy calculation perform the following actions:

1. Open a stereopair with the investigated woodland.

2. Select Grid » Create.

3. Select Grid > Properties and specify the grid step considering image resolution.
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Fig. 127. Measuring grid creation

4. Press and hold the Shift key to draw rectangular grid for woodland area.
? The grid should extend beyond the woodland area.

5. Choose Vectors » Create layer to create a layer without classifier.

6. Create a polygon in such a way that its boundary coincides with woodland bound-
aries.

7. Select Grid > Create boundaries from vectors. After that grid boundary coincides

with created polygon.
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Fig. 128. Measuring grid creation

8. Make active the Grid layer in the Manager.

9. Choose Vectors > Pathway » Activate or click the & button of the Pathway mode
additional toolbar (detailed description of Pathway mode see in the “DTM Generation”
User Manual). After that marker is placed to the first grid node.

10. If grid node is on the top of tree, press Enter to create point in this node. Press
Delete to skip a grid node. Passing to the next grid node is performed automatically.

7

To pass to the previous grid node, press the Backspace key.

11. After passing of all grid nodes the system displays the “Pathway complete” message.

7

The system also provides possibility to create points on the grid manually in frames of
polygon without pathway mode. At that it is necessary to comply with the positioning accur-

acy of points in XY plane for the grid nodes within 1/3 of the distance between grid nodes.

12. Make active the Vector layer in the Manager.
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13. Choose Vectors > Attributes » Calculate canopy of forest or click the L button
of the Vectors additional toolbar.

. Canopy of forest calculati... &J

Calculate reticulation nodes

@ Onthe trees | Between trees

OK J l Cancel

L8 oy

Fig. 129. Parameters of forest cover canopy

14. To calculate canopy value select Calculate of reticulation nodes — On trees. To
calculate a value inverse to canopy select Calculate of reticulation nodes —
Between trees.

@ It is better to create points between trees in case of high trees density. In this case choose

Between trees to calculate cover canopy.

15. Click OK. After that the system displays a message with information about value
of forest cover canopy.

@ PHOTOMOD 6.0.1.1806 ESREEn

‘ ] -'\i'.; 11.08.201514:21:17: Pickets/Grid nodes: 114,343
— Canopy of forest: 0.332362

0

i1

0

Fig. 130. Forest cover canopy value
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8. Operations with vector objects

8.1. The “Edit” menu

The system provides possibility to edit objects in a layer, to change marker position or
vectorization and selection modes and other operations of vector layer editing. The Edit
menu allows to do this.

Table 10. Brief description of the “Edit” menu

Menu items

Function

Group selection

contains menu items to choose mode of vector ob-
ject selection

Snapping

contains menu items for processing in the snapping
mode (see the Section 3.4.6)

Vectors create mode

contains menu items to change mode of vector ob-
ject creation: points, polyline, polygons, and creating
mode of polylines and polygons as smooth lines
(see Section 5.3)

Curve transforms

menu items to create and edit smooth curve lines
(see Section 8.6)

3 Undo (Ctri+2)

to cancel the last operation of vector objects editing
on a layer (see Section 8.7)

Undo log

to open the Undo log containing a list of recent
editing operations

« Redo (Ctrl+Shift+Z)

to redo the last undone operation (see Section 8.7)

f= Points editing mode

to move common vertices of objects together (see
Section 8.4.1)

., Streamline mode (Y)

to enable streamline mode of linear objects input
(see Section 3.4.4)

[ Snap-to-ground mode (T)

to enable snap-to-ground mode

[*:, Orthogonal mode (A)

to enable orthogonal mode of linear objects input

[ Orthogonal mode in coordinate system

to enable orthogonal mode of linear objects input in
additional coordinate system

£ Add coord system

to create additional (user) coordinate system as a
helping vectorization tool

Edit coord system

to change default axes direction of additional coordin-
ate system

L= Delete coord system

to delete additional coordinate system

Alignment mode

turns the alignment mode on

Scale when align

to scale vector objects during their transformation
in the alignment mode

Rotation mode

turns the fast vector objects transformation mode
on
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Menu items

Function

Select vertices when marker moves over them

to select a vertex, located in marker area on a dis-
tance specified in the Swath field (Service > Set-
tings > Vectors)

Move marker to selected vertex

to move marker to the selected vertex automatically
(see the “Settings of vector objects display” chapter
of the “General system’s parameters” User Manual)

Sync markers

to turn on/off synchronous marker moving in all
opened 2D-windows

fi% Copy marker to clipboard (Ctrl+Alt+INS)

to copy position of marker in 2D-window to clipboard

fiz; Paste marker from clipboard (Ctrl+Alt+INS)

to move marker to position in 2D-window copied to
clipboard

Cancel selection

to unselect all objects in active 2D-window (see
Section 8.2)

Invert selection

to invert objects selection in active 2D-window (see
Section 8.2)

Select all (Ctrl+A)

to select all objects in active 2D-window (see Sec-
tion 8.2)

Highlight selected objects

to highlight vector objects selected in 2D-window
(see Section 8.2)

Fit to window current layer

to display the data of the current layer completely.
This function is supported by all types of layers (see
section “Image scaling in 2D-window” in “General
information” User Manual)

Active layer

contains menu items to work with current active
layer (see the “General information” User Manual)

Show/hide labels in all layers (Ctrl+Shift+H)

to configure curves smoothing (see Section 8.6.6)

Toggle Raster layer visibility in Stereopair win-
dow

to show/hide the Raster layer when working in the
stereopair window, duplicates the ® button in the
Layer manager

7

the “General information” User Manual).

8.2. Vector objects selection

8.2.1. Objects selection tools

When working with vector objects in the stereopair window, for ease Toggle Raster layer vis-
ibility in Stereopair window function use it is recommended to set an appropriate hotkey (see

Objects on active vector layer could be selected both manual and automatically.

To select object manually are used the following tools:

* mouse double click or the S key to select single polyline/polygon;

» one mouse click to select point near to marker;
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* rectangle — select objects inside of rectangle;
* polygon — select objects inside of free form polygon.

To highlight objects on active vector layer inside a rectangle choose Edit » Group
selection » Rectangle or click the | ] button of the Tools toolbar. Press and hold the
Shift key and drag a rectangle by mouse.

To select objects inside of free form polygon perform the following:

1. Choose Edit » Group selection » Polygon or click the button of the Tools

toolbar.

2. Press and hold the Shift key. Then make mouse click to create the first polygon
vertex and a “rubber line” directed to current cursor position. Input subsequent
vertices by mouse clicks.

3. To complete objects selection by polygon use mouse double click. To break off
selection, press the Esc key.

To select all objects of active vector layer choose Edit » Select all or use the Ctrl+A
hotkeys.

The Edit » Highlight selected objects menu item allows to highlight selected objects
in 2D-window using additional lighting.

c If selected objects have attributes in the table of Objects attributes window displays only attrib-
utes with the same values. Strings of attributes with different values highlights by red color.

8.2.2. Objects selection modes

To change selecting mode for vector objects the system provides the Edit » Group
selection menu items:

Rectangle — to select objects inside a rectangle;
Polygon — to select objects inside arbitrary polygon;

« [l Normal — during vector objects selection previously selected objects will be unse-
lected;

[l Add to selection — each newly selected object (objects group) is added to a group
of selected objects;

Subtract from selection — allows to unselect selected object (objects group);

« I Invert selection — allows to invert selected objects (objects group);
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« [E Fully inside — allows to select objects that hit the selection area;

« [& Partly inside — allows to select objects in which one or more segments intersects
a border of selection area;

« [], At least one point inside — allows to select objects in which at least one vertices
are in the selection area;

@ The Tools panel partially duplicates menu items Edit > Group selection.

The Vectors » Selection menu contains the following items used to sequentially select
vector objects and their vertices:

» Select previous object (Ctrl+<) — allows to select an object, previous to selected;

» Select next object (Ctrl+<) — allows to select an object, next to selected;

» Select previous line vertex (<) — allows to select a polyline vertex located before
the selected one; sequence of vertices is displayed when you select a vector object
(see Section 5.3.8);

» Select next line vertex (<) — allows to select a polyline vertex located after the se-
lected one; sequence of vertices is displayed when you select a vector object (see
Section 5.3.8);

To unselect objects press Esc.

Table 11. Brief description of the Tools toolbar

Button Function
to select vector objects inside a rectangle
to select vector objects inside arbitrary polygon
Iy during vector objects selection previously selected objects will be unselected
| each newly selected object (objects group) is added to a group of selected objects
to unselect selected object (objects group)
Iy to invert selected objects (objects group)
El to select objects that hit the selection area
(& to select objects in which one or more segments intersects a border of selection area
L to select objects in which at least one vertices are in the selection area
= turns the alignment mode on
S8 to scale vector objects during their transformation in the alignment mode
% turns the fast vector objects transformation mode on
iy to copy position of marker in 2D-window to clipboard
iz to move marker to position in 2D-window copied to clipboard
0l to paste vector objects from clipboard to active vector layer into marker position
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@ Vector objects are pasted to the point of marker position at the time of copying objects to the
clipboard. If the marker is not moved between the copy and paste operations, objects are located
in the same coordinates as the original; otherwise they shift on a vector that connects marker

positions during copy and paste operations.

8.2.3. Selecting classifier layer object

During work in a layer with classifier the system provides the following options for

automatic objects selection:

+ selection of all layer objects — select a layer in the list of the Classifier window and
click the -=button; all objects of selected layer are highlighted in 2D-window (see

Section 6).

+ selection of objects with specified code — select necessary code in the codes list of
the Classifier window and click the “=button; all objects with specified code are

highlighted in 2D-window (see Section 6).

8.3. Vector objects copying

The system provides possibility to copy all, highlighted or selected by type objects of

vector layer to defined or new vector layer.

To copy objects of vector layer perform the following actions:

1. Make vector layer active.

2. [optional] To copy objects to existing layer, open this vector layer. Vector layer with

objects to be copied should be active.

3. Select Vectors » Copy to layer. The Copy objects to another layer window opens.

i !
. Copy objects to another layer &J
Source layer: s
Copy
Selected A

Types

Points | Polylines | Polygons
Assignment

Existing layer |test_attributes (Vectors) |
@ Mew layer

[ 0K ] | Cancel |

e

A

Fig. 131. Parameters of objects copying to layer
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4. To copy just selected objects, in the Copy section choose Selected, otherwise,
choose All (default setting).

5. Inthe Types section choose one or more object types to copy:
* Points;
* Polylines;
* Polygons.

6. In the Destination section choose a layer to copy object:
» Existing layer — choose one from the list of opened layers;
* New layer.

7. Click OK to copy obijects.

The system also allows to create several copies of vector object placed at the same layer (see
Section 11.4.6)

The system also allows using of clipboard for vector layer editing.

The Vectors » Clipboard » Copy (Ctrl+C) menu item allows to copy selected vector
objects to the clipboard.

The Vectors > Clipboard » Paste (Ctrl+V) menu item allows to paste vector objects
from clipboard to active vector layer.

The Vectors » Clipboard > Cut (Ctrl+X) menu item allows to cut vector objects from
active layer and copy them to clipboard.

The Vectors > Clipboard > Paste into marker position (Ctrl+Shift+V) menu item allows
to paste vector objects from clipboard to active vector layer into marker position.

@ Vector objects are pasted to the point of marker position at the time of copying objects to the

clipboard. If the marker is not moved between the copy and paste operations, objects are located

in the same coordinates as the original; otherwise they shift on a vector that connects marker
positions during copy and paste operations.

8.4. Vector objects editing
8.4.1. Vertices editing

The system provides the following editing operations both for point objects and for
polylines/polygons vertices:

+ delete — to delete selected point/vertex press Delete;
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* remove together with adjacent segments — see Removing vertices together with
adjacent segments;

* move — to move selected point/vertex press Ctrl; In XY-plane point moves with mouse
or arrow keys, by Z — with Page Up, Page Down hotkeys or by rotate mouse wheel,

* move to marker position:

o to move point/vertices to marker position is used the Vectors > Geometry >
Move point to marker (J);

o to move marker to selected vertices is used the Vectors » Geometry » Move
marker to selected point (~);

o to move all vertices to marker height select object and choose Vectors > Geo-
metry > Move to marker height (K).

@ Marker positioning to necessary position is performed manually (see Section 3.4) or using
the Markerwindow by input coordinate values from keyboard.

 line orthogonalization on vertex — to move polygon or polyline vertex, connected
to the selected one, use menu items Vectors » Geometry » Orthogonalization for-
ward (Ctrl+F) and Vectors » Geometry > Orthogonalization backward (Ctrl+B).
The vertex is moved so that the angle at the selected vertex is a multiple of 90. During
orthogonalization forward the system moves a vertex following the selected, and
during orthogonalization backward — a vertex preceding the selected. Sequence of
vertices is displayed when you select a vector object (see also Section 5.3.4).

@ If the Edit » Point editing mode parameter is selected, then moving common vertices is per-
formed at the same time (see Section 11).

@ If the Edit > Point editing mode parameter is selected and some amount of vertices of different

objects are “connected”, after that it is possible to edit them simultaneously using snapping to

nodes option (see Section 3.4.6) and the menu item Vectors » Geometry > Move to marker
position.

8.4.2. Adding vertices to a line segment
The system allows to add vertices into a polyline or polygon segment.

In order to insert a vertex to selected polyline/polygon, place marker to necessary pos-
ition and press Insert.

@ If the Edit > Point editing mode parameter is selected, when inserting a vertex between two
connected vertices located on the common border of several polygons, the new vertex is inserted
into all of polygons.
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8.4.3. Polyline moving

To move selected polyline/polygon press the Ctrl key. Move a polyline in XY plane using
mouse or arrow keys. To move it by Z, use Page Up,Page Down keys or mouse wheel
rotation;

@ If there are selected vertices in polylines, the system moves only these vertices, and not the
entire polyline.

@ When moving an object, to display a displacement vector as a dashed line between the first

and final marker positions, click the [ button and set the appropriate checkbox in the Vectors
section of the Settings window.

8.4.4. Polyline deleting
To delete selected polyline/polygon use the Delete key.

If there is selected vertex in selected polyline, this vertex deletes first, and after the next
press of the Delete key the whole polyline will be deleted.

8.5. Vector objects interpolation

8.5.1. Quick linear vector objects interpolation

Operation of “fast” objects interpolation is used to smooth the angles of linear vector
objects and is applied, when the accuracy and quality of results are not significant. The
operation consists of moving vertex of polyline to the middle of the adjacent segment.

% Positions of the first and the last vertices of a polyline remain the same. Thus, each Fast inter-
polation of a polyline results in a new vertex added.

% Applying this operation to polygons is not recommended

To execute fast interpolation perform the following actions:

1. Select Vectors > Interpolate » Quick interpolate. The Fast interpolation window
opens:

. Fast interpolation [&J

Apply

Fig. 132. Quick interpolation parameters
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Fig. 133. Quick interpolation scheme

2. [optional] Select Selected to interpolate selected objects only, otherwise, select —
All;

3. Click OK to apply the interpolation.
8.5.2. Corners round off

The system provides for vector object corner round off through the increase of vertex
number.

ﬁ, The system also provides for vector object corner round off without change of their vertex
number.

ﬁ, Vector object corner round off is often used while editing the contour lines (see the “Contour
lines” chapter of the “DTM Generation” User Manual).

To perform the round off corners at vertices of vector objects perform the following ac-
tions:

1. Select Vectors > Interpolate » Round off corners. The Settings window opens:
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Fig. 134. Parameters of vector objects corners round off

2. Select objects to round off their corners:
* Apply to all — allows to round off corners of polylines/polygons;

» Apply to selected objects — allows to round off corners of selected polylines/poly-
gons only;

» Apply to selected vertex — allows to round off corners of selected polylines/poly-
gons only;

3. Move slider or input the Curvature radius for smoothing curve;

é The smaller the radius, the closer the smoothing curve to initial polyline vertices.

4. Specify in the input field or using the Precision slider the precision parameter —
maximal distance from polyline segment to a curve in the area between the two
closest vertices;

é Change the Curvature radius and Precision values using appropriate sliders to display
results of round off operation in real time. That is why the sliders are enabled only when
there is a single selected object, in order to avoid start of a long calculation process.
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'. Round corners g |

() Apply to all
Apply to selected objects

Apply to selected vertices

U

Curvature radius:  0.001 E m
U

Precision: 0.5 E m

[ ok || cance |

— 4

Fig. 135. Parameters of vector objects corners round off

-
. Round corners g
) Apply to all
Apply to selected objects
Apply to selected vertices
Curvature radius: 77000923 E m
| Precision: 0.5 E m
[ ok || cancel |

. Round corners g‘

() Apply to all
Apply to selected objects

Apply to selected vertices
Curvature radius:  77.000923 E m

Precision:  7.700923 £l m

[ ok || cance |

— -

Fig. 137. Round off operation preview

5. Click OK. After that the corners near vector objects vertices are round off considering
specified parameters.
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8.5.3. Vertices thinning out
The operation is used to reduce the number of vertices in all or selected vector objects.
To perform thinning out vectors vertices perform the following actions:

1. Select Vectors > Interpolate > Thin out polylines. The Thinning parameters
window opens:

. Thinning parameters li_E-J

Calartad Abisrd
SEIeCied DIMEeCTs

e

Max. distance: D.100 =1 m

[ Ik, ] | Cancel

L™ A

Fig. 138. Parameters of linear objects thinning out

2. [optional] Set the Selected objects checkbox on to thin out vertices for selected
objects only;

3. Inthe Max. distance field specify distance between two adjacent vertices. If vertices
located closer than a specified distance, one of vertices is deleting;

4. Click OK. After that operation the vector objects vertices located closer to each
other then the specified distance are removed.

8.5.4. Interpolation by Bezier curve

During interpolation polylines/polygons are smoothed by adding additional vertices
along calculated Bezier curve.

Perform the following actions to perform interpolation of polylines/polygons:

1. Select Vectors > Interpolate » Interpolate. The Settings window opens:
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i !
’. Interpolation parameters lﬁ

Selected objects
Curvature for non-smooth lines: 0,30 —
Step: 10.00 = m
Predision: 0.500 =] m
Create new layer for interpolated objects
2K, ] | Cancel | | Apply
\ y,

Fig. 139. Parameters of polyline interpolation

2. Inthe Curvature for non-smooth lines field specify the degree of curvature of the
Bezier curve;

? Recommended values range is from 0.1 to 1.0.

3. In the Step field specify the distance between the polyline vertices approximating
the Bezier curve;

4. In the Precision field specify maximal distance from the Bezier curve to polyline
approximating it. At a distance greater than the specified, additional vertices are
added to a polyline until the condition is satisfied;

5. [optional] To interpolate selected objects only, set the Selected objects checkbox
on, otherwise, this operation will be performed for all objects;

6. [optional] To save the interpolation results to a separate layer, set the Create new
layer for interpolated objects checkbox on;

7. [optional] Click Apply to preview interpolation results;
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F. Interpolation parameters ‘ u
Selected objects
Curvature for non-smooth lines: 0.3 %
Step: 10 % m
Precision: s % m
Create new layer for interpolated objects
[ ok | [ Concel | [ Appy

Fig. 140. Parameters of polyline interpolation

-
. Interpolation parameters

Selected objects
Curvature for non-smooth lines 0.3 %
Stem: 107 % m
Precision: 057 % m
Create new layer for interpolated objects

[ ok | [ cancel | [ Appy

Fig. 141. Interpolation results preview

8. Click OK to perform interpolation of vector object.
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Fig. 142. Interpolation results in new layer

8.5.5. Elevations interpolating

When perform vectorization of linear objects on the terrain, which relief uniformly
changes, it is possible to use interpolation of polylines/polygons by their elevation.

Perform the following actions to do this:

1. After polyline creation choose Vectors > Interpolate > Interpolate elevations. The
Z interpolation window opens:

r‘ Z interpolation g1

Ohjects

Current Selected @ All

oc [ Cance

Fig. 143. The Z interpolation window

2. Choose objects for interpolation:

» Current — selected object chosen by double-click; displayed with bold line in a
2D-window;
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» Selected in 2D-window obijects;
» All objects.

3. Click OK. Elevations of vertices located between the start and end points are inter-
polated proportional to the distance between the intermediate vertices and the dif-
ference in elevation between the start and end vertices.

8.5.6. Convolution smoothing

The system provides possibility to perform convolution smoothing to reduce the prob-
ability of the intersections obtained during interpolation of contours generated from TIN.

g Convolution is performed for each coordinate axis. Each axis described as a function of the
length of the polyline with the kernel specified using Exponential or Gaussian methods.

@ Vector object corner round off is often used while editing the contour lines (see the “Contour
lines” chapter of the “DTM Generation” User Manual).

To smooth contour lines using convolution, perform the following actions:

1. Select Vectors > Interpolate » Convolution smoothing. The Convolution
smoothing window opens.

i !
& Convolution smoothing &J

Smoothing kernel

@ Ewponential Gaussiarn

Smoothing radius [10.000 w1 m

13
3

Step 20,000
Apply

_'|' Calarter

e | Ll B o )

QK ] | Cancel | | Apply

Fig. 144. Parameters of convolution smoothing

2. Select smoothing method: Exponential or Gaussian.
3. Define the following parameters of smoothing:

+ Corner smoothing radius (between segments of the original object);
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? An angle can be rounded by inscribing a circular arc of a given radius in it. The smaller
the radius, the closer the smoothing curve to initial polyline vertices.
» Step, to specify the characteristic distance between vertices.

? Step affects the number of additional vertices created.

4. [optional] In the Apply to section select Selected to smooth selected objects only,
otherwise, select — All (by default).

5. [optional] Click Apply for contour smoothing preview. Change smoothing parameters
if needed;

? This function is available only when there is a single selected object, in order to avoid start
of a long calculation process.

Fig. 145. Convolution smoothing preview

6. Click OK. The system performs smoothing operation.
8.5.7. Smoothing vector objects
To smooth a shape of vector objects, perform the following actions:

1. [optional] Select all the vector objects to which it's necessary to applied a smoothing
procedure.

2. Choose Vectors > Interpolate » Smooth. The Smooth objects window opens.
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r. Smooth objects I&ﬁ

Smoathing
Smoothing degree per iteration  0.5000 =
Mumber of iterations 3 =
Apply
A Selected
K ] | Cancel
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Fig. 146. Parameters of smoothing vector objects

3. In Smoothing section set parameters of smoothing vector objects:

* Smoothing degree per iteration — the maximum value of Smoothing degree
per iteration — 1;

* Number of iterations — the maximum value is 100;

4. In Apply section select objects to which a smoothing is applied:
» All — allows to smooth all the vector objects;
+ Selected — allows to smooth selected polylines/polygons only.

5. Click OK. As a result vector objects are smoothed with parameters specified.

8.5.8. Vertices densification
The system provides possibility of vector objects vertices densification.
To do this perform the following:

1. Choose Vectors » Interpolate » Densify objects. The Vertices densification
window opens:

- it
. Densification step L ? &J
Vertices densification
10,000 =
oK ] | Cancel

% A

Fig. 147. Vertices densification parameters
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2. Input densification step — the fypical distance between vertices;

3. Click OK.
8.6. Editing of smooth curves

8.6.1. The “Curve transforms” menu
The system allows to create and edit smooth curve lines.

To do this there are menu items Edit » Curve transforms and buttons of the Vectors
additional toolbar (see Section 5.1).

Table 12. Brief description of the “Curve transforms” menu

Menu items Function
.J Convert polygonal chains to curves to convert selected broken lines to smooth ones
(see Section 8.6.3)
.2 Convert curves to polygonal chains to convert selected smooth curves to broken lines
(see Section 8.6.3)
=. Resmooth on editing to recalculate automatically smoothing of curve line
segments during object editing (see Section 8.6.4)
4 Edit control nodes to enable curve check points editing (see Sec-
tion 8.6.5)

== Smooth editing of curve control nodes |to preserve smoothing during editing of curve check
points (see Section 8.6.5)

Curves smoothing to configure curves smoothing (see Section 8.6.6)

8.6.2. Smooth curves creation mode
The system provides smooth curves creation mode.

To create smooth curves choose Edit > Vector create mode > Curves or click the £
button of the Vectors additional toolbar.

Smooth curves creates as ordinary polylines (see Section 5). When work with classifier
object code with L (line) type should be selected.

To perform automatic curve smoothing during its creation select Edit » Curve trans-
forms » Resmooth on editing or click the = button of the Vectors additional toolbar.

8.6.3. Conversion of smooth curves

The system provides opportunity to convert selected broken lines to smooth curves and
vice versa.
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To perform conversion of selected broken lines to smooth curves is used the Edit »
Curve transforms > Convert polygonal chains to curves menu item and the _ button
of the Vectors toolbar.

To convert selected smooth curves to broken lines is used the Edit » Curve transforms »
Convert curves to polygonal chains menu item and the . button of the Vectors
toolbar.

8.6.4. Automatic smoothing

The system provides opportunity to automatically change the degree of the curve
smoothing, while its creating or editing.

[optional] To do this select Edit » Curve transforms > Resmooth on editing or click
the = button of the Vectors additional toolbar. During any editing of smooth curve
vertices using markers of nodes control the smoothness of the curve does not change.

8.6.5. Editing of curve line segments

The system provides possibility to edit curve line segments. To enable such mode select
Edit > Curve transforms > Edit control nodes (X) or click the & button of the Vectors
additional toolbar. The position of the segments of created smoothed curves is edited
by pressing Ctrl key and by right mouse button, using “traction” of markers of polyline
vertices control.

To switch the option of angles forming when editing the curve segments, select Edit »
Curve transforms » Smooth editing of curve control nodes or click the button of the
Vectors additional toolbar.

8.6.6. Smoothing control
The system provides possibility to smooth existing curves.
To change smoothing degree perform the following actions:

1. Choose Edit» Curve transforms > Curves smoothing.

( . Curves smoothing [&r
Smoothing U
Apply to Selected objects
@ Al objects
[ OK ] | Close | | Apply

Fig. 148. Curves smoothing degree
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2. Set the smoothing degree using the appropriate slider.
3. [optional] Choose objects to transform: to Selected objects or to All objects.

4. Click Apply to show changes in 2D-window. Click OK to complete operation.

8.7. Undo editing operations

The system allows to undo edit operations of vector objects, and also to redo recently
undone operations (see the “General information” User Manual).

To cancel the last operation of vector objects editing, select Edit » Undo (Ctrl+Z) or
click the ¥ button of the main toolbar. To redo the last undone operation of vector ob-
jects editing, select Edit » Redo (Ctrl+Shift+Z) or click the T#button.

In order to open the recent editing operations list select Edit » Undo log or click the
button.

To cancel a group of operations double click in the Undo log on line with action to which
you want to undo changes. Lines with undone operations are marked by italic font. To
redo all undone operations, double click the line with action to which you want to redo
changes.

. Undo log: Vectors Lﬂ"j—]
o |
Offset -
Transform ohjects coordinates
Convert to figure
Interpolate
Move vertices
Delete point
Delete objects
Round corners
Create object
Create object
Create object
Create object
Create object
Add vertex
Add vertex
Add vertex
Move vertices i
Close

Fig. 149. Undo log
To clear log is used the {f} button. After that undo and redo actions become unavailable.

§ List of undo operations is maintained for each layer separately.

The undo log clears automatically in the following cases:
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« after exceeding of information volume about operations list;

* when you start the large volume of automatic transformations or calculations (for
example, during creation contour lines using large volume data source).

In these cases the system displays a warning that it will be impossible to cancel the
transformations.

@ When working with a fair amount of vector objects using of undo mode slows down editing op-
erations. To increase the performance, disable the undo log creation (see the “General system’s
parameters” User Manual).

8.8. Additional coordinate system

The system allows to create additional (user) coordinate system which is used as a
helping vectorization tool together with Snapping to coords function:

» To create additional (user) coordinate system select Edit » Add coord system or
click L= button in Vectors toolbar. Axes direction of the additional coordinate system
is shown at the left bottom corner of 2D-window;

» To change default axes direction of additional coordinate system perform the following:

1. Select Edit » Edit coord system or click 2 button in Vectors toolbar to turn on
mode of editing user coordinate system;

2. Set X axis direction of the additional coordinate system while using Polylines (L)
mode (draw one segment line, vertices of which are specified X axis direction).
Axes direction of the additional coordinate system will be changed according to
the specified one. Edit coord system mode will be turned off automatically.

+ To delete additional coordinate system select Edit » Delete coord system or click
= button in Vectors toolbar.

The system allows to add to the marker guides in the form of red and green dash lines
which are co-directed with the active (main or additional) coordinate axes. The red line
is aligned with the X-axis, and the green one is aligned with the Y-axis. The guides
enable us to assess mutual alignment of the objects on images.

To add guides to the marker select Service » Settings. The Settings window opens.
On the Windows tab of the Settings window set the Coord lines under marker
checkbox.

The system also allows to rotate the marker crosshair according to the additional co-
ordinate system axes (see the “Marker settings” chapter in the “General system’s
parameters” User Manual).
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9. Vector objects filtering
To edit vector objects the system provides the following filters:

* Filter by Z-range —filtering points and vertices of polylines/polygons, which Z-coordin-
ate is out of specified range;

* Median Z filter — filtering points and vertices of polylines/polygons using mask of
specified size;

* Filter adjacent point objects — filtering of closely located points (located nearer than
specified distance);

» Linear objects filtering — filtering polylines/polygons, that linear size (coordinates
range by one of axes) is more or less of specified value;

» Surface objects filter — filtering points, which have fallen on particular tall objects or
pits of specific size.

The set of filters used for editing vector objects partially coincides with the instruments
for points filtering (Terrain » Points » Filter menu, see “Points filtering” section of the
“‘DTM Generation” User Manual).

9.1. Points filtering by Z-range

The system provides possibility to remove points and vertices of polylines/polygons,
which Z-coordinate falls outside specified range.

To perform objects filtering of active vector layer by elevations range, execute the fol-
lowing actions:

1. Select Vectors > Filter » Filter by Z-range. The Z-range filter window opens.

s !
’. Z-range filter [ﬁ,l
Layer PasmeTka (Vectors)
Zmin 497.6359 m Zmax 498.0680 m
Filter range
Zmin 497.54 S| m Zmax 498.07 = m
K ] | Cancel

Fig. 150. Parameters of points filtering by Z

The Layer field displays a name of selected active vector layer, the Zmin and Zmax
fields show terrain elevation difference in meters, calculated by all layer objects.
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The Filter range section by default shows values of calculated terrain elevation
difference. Specify maximal and minimal Z values in meters to consider for
points/vertices filtering.

Click OK. Filtration removes all points and vertices of polylines/polygons, which Z-
coordinate falls outside specified range. When the filtering operation is completed
the system displays information message about number of deleted points.

9.2. Median points filtering by Z

The system provides possibility of median filtering to remove single sharp spikes in
presence of smooth relief.

The median filtering contains the following sequence of actions:

1.

Sequential scanning of area with vector objects by window-mask. Scanning step
is specified as window-mask halfsize.

Deleting points which elevation is out of range.

@ The range is calculated as average level of vectors elevation that fall into mask. When
calculating the range the system considers specified deviation from average level.

To execute median filtering perform the following actions:

1.

Select Vectors » Filter » Median Z-filter. The Median Z filter window opens.

i N
@ Median 7 filter 5
Mask size looo. 0o “m
Threshold deviation from the mean level 50.000 = m

[ Ok ] | Cancel
L &

Fig. 151. Parameters of median points filtering

In the Mask size field specify a side size of scanning square window-mask in meters.

In the Threshold deviation from the mean level field specify deviation by Z in
meters from mean level of objects elevation in the mask.

Click OK. Filtration removes all points and vertices of polylines/polygons, which Z-
coordinate falls outside specified range. When the filtering operation is completed
the system displays information message about number of deleted points.
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9.3. Filter of adjacent point objects

Filter of adjacent point objects allows to remove points, in which vicinity there are other
objects located closer specified distance.

To filter adjacent points on active layer perform the following actions:

1. Select Terrain» Points» Filter > Filter adjacent point objects. The Filter adjacent
point objects window opens.

. Filter adjacent point chjects &J

Radius [1.000 “Hm

From a group of adjacent objects, delete those
with lesser value of the attribute:

region Imagde Code

oK ] | Cancel

Fig. 152. Parameters of adjacent point objects filter

2. Specify the Radius — maximal distance in meters to each point, and if a points falls
closer that the radius value, the points is deleted.

3. [optional] In order to delete from two points just one which contains the smallest
value of one attribute (for example, if points vector layer was created in automatic
points calculation mode with preserving of quality assessment in attributes), set the
From a group of adjacent objects, delete those with lesser value of the attribute
checkbox on and select in the list an attribute to be considered during points removal.

4. Click OK. Filtration removes points, between which the distance is less than spe-
cified. When the filtering operation is completed the system displays information
message about number of deleted points.

9.4. Filtering of linear objects

The system provides the possibility to delete vector object whose length (perimeter) or
linear dimension (i.e. the range of coordinates along one of the axes) do not match the
specified value.

To use filtering of linear objects perform the following actions:

1. Select Vectors ) Filter » Selective delete objects. The Delete lines window opens;
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Delete line objects:

@ Larger than
1,000 ~| m
Smaller than

Line object size
@ Minimal limits
Maximal limits

Length

QK ] | Cancel

Fig. 153. Parameters of linear objects filtering

2. Set size of objects to be deleted (in meters);
3. Select filtering method:

» Larger than — used to delete objects, size of which exceeds the specified value
(in meters);

« Smaller than — used to delete objects, size of which is less than specified value
(in meters).

4. Inthe Line object size section select the size calculation method:
* Length;
* Minimal limits / Maximal limits — linear size (by one of the axes).

5. Click OK. Filtration removes all linear objects with size that is more or less than
specified.

9.5. Surface objects filter

The system provides possibility to correct blunders of correlation, obtained, for example,
during automatic points calculation. The Surface objects filter allows to delete points
located on terrain surface with specified typical size by XY and Z.

c This filtering type is not used for objects of completely built-up area, forest belts and similar
objects.
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The principle of filtering is to estimate the location and size of the contours created using
TIN, which was generated with help of initial points. A surge is a group of contours that
is not greater than specified size by XY and with elevations in specified range.

@ Surface objects filter is recommended to use to eliminate sharp spikes. For more fine filtering
it is recommended to use this filter along with buildings and vegetation filter (see the “DTM
Generation” User Manual).

To apply filter of objects on surface perform the following actions:

1. Select Vectors ) Filter » Surface objects filter. The Surface objects filter window

opens.
ra T
. Surface objects filter [ﬂ?—]
Typical object size in XY-plane lL5.000 = m
Typical object size along Z axis 5,000 = m
[ OK ] | Cancel
L -

Fig. 154. Parameters of surface objects filter

2. Specify the Typical object size in XY-plane and Typical object size along Z
axis in corresponding fields in meters.

3. Click OK to remove points found.

10. Geometric transformations of vector objects

Table 13. Brief description of the “Geometry” menu

Menu items Function
Move point to marker to move point/vertices to marker position (see Sec-
tion 8.4.1)
Move marker to selected point to move marker to selected vertices (see Sec-
tion 8.4.1)
Delete points around polylines to delete points used for the TIN creation around

linear objects (see Section 10.4.1)

Delete points inside polygons to delete points inside polygons. Points and poly-
gons could be located both in one layer and different
(see Section 10.4.2)

Swap X <->Y to swap X and Y coordinates of vector objects (see
Section 10.5.1)

175


DEM.pdf
DEM.pdf

PHOTOMOD 8.1

Vectorization (Windows x64)

Menu items

Function

Convert coordinate system

provides opportunity of coordinates recalculation
from one coordinate system to another for all ver-
tices of current layer (see Section 10.5.2)

Move

provides possibility both to move vector objects by
a predetermined vector using X, Y, Z coordinates,
and to set a predetermined elevation without vectors
movement (see Section 10.1)

Move to marker height

to move all vertices of the object to marker height
(see Section 8.4.1)

Transform...

to perform geometric transformation of vector ob-
jects: rotation by the angle and scaling (see Sec-
tion 10.1.8)

Projective transform...

to perform projective transformation of vector objects
(see Section 10.1.11)

Convert to figure

provides opportunity to convert arbitrary polygons
into standard geometric shapes: ellipse, round,
rectangle, square, orthogonal polygon (see Sec-
tion 10.1.3)

Convert polygons to points

to convert all or selected polygons into point objects
(see Section 10.1.2)

Cut objects by selected polygons

provides the possibility of cutting vector objects of
one layer by the boundaries of polygons of another
layer (see Section 10.1.5)

Cut objects around selected

to cut vector objects around selected vectors placed
at the same layer (see Section 10.1.6)

Convert all vertices to point objects

provides possibility to convert all vertices both of
polylines, and polygons to point objects (see Sec-
tion 10.1.2)

Split into layers by object type

to split objects into layer depending on their type
(see Section 10.1.7)

Extract objects by location...

to create a new vector layer that contains objects
selected from the source vector layer in terms of
spatial relationship with objects of the third (addition-
al) layer (see Section 10.2.7)

Buffer zone...

to create a buffer zone — a polyline/polygon parallel
to selected line and situated at a predetermined
distance from it (see Section 10.2.3)

Buffer zone to marker

to perform the fast buffer zone creation (see Sec-
tion 10.2.3)

Objects around points...

to create circles with defined radius or squares with
defined side length around vertices of linear objects
(see Section 10.2.4)

Vectors profiles...

provides the function of construction of perpendicu-
lar profiles through the group of linear vector objects
(see Section 10.2.5)
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Menu items

Function

Surface area of polygons

provides possibility to calculate polygon surface
area taking into account the vertices height (see
Section 10.8)

Correct by residuals...

to perform operation of vector layer correction using
residuals vectors is intended to clarify the position
of vector objects (see Section 10.1.4)

Elevation Profile

to create an elevation profile of a linear object (in
the form of chart, whose vertices are the vertices of
a polyline, see Section 10.7)

Vertical DEM profile along selected line

to build a DEM elevation profile along a linear object
(see the “Building DEM elevation profile along a
linear object” chapter of the “DTM Generation” User
Manual)

Add intersection points

provides the ability to automatically add a vertex at
the intersection of vector objects (see Sec-
tion 10.2.1)

Symmetric objects

contains menu items to to create symmetrical
lengthy objects both linear and areal (see Sec-
tion 10.2.2)

Orthogonalization forward / Orthogonalization
backward

to move polygon or polyline vertex, connected to
the selected one (see Section 8.4.1)

Project on stereomodel

provides possibility to project vector objects on relief
of active stereopair (see Section 10.3)

Project on TIN

to project vector objects on TIN (see Section 10.3.2)

Project on DEM...

to automatically assign elevation marks to points
with known XY coordinates from loaded DEM (see
Section 10.3.3)

Cut CSV file by rectangle edges

to delete from CSV-file points out of defined
boundaries (see Section 10.6)

Cut CSV file by selected polygons

to cut CSV file by selected polygons (see Sec-
tion 10.6)

Check orthogonality

provides possibility to check orthogonality of poly-
gons corners (see Section 10.2.6)

10.1. Transformation of vector objects

10.1.1. Vector objects moving

The system provides possibility both to move vector objects by a predetermined vector
using X, Y, Z coordinates, and to set a predetermined elevation without vectors move-

ment.

In order to move vector objects perform the following actions:

1. Select Vectors » Geometry > Move. The Move objects window opens.
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r‘. Move objects {ﬁjﬁ
Maovement
@ By given vector
¥ 0.000 | m
Y 0,000 = m
Z 0,000 = m
SetZ
0.000 m
From attribute  |Z
Apply
A Selected
Ok ] | Cancel

LS A

Fig. 155. Parameters of objects moving

2. Select one of the following ways of moving:

* By given vector — specify X, Y, Z values (in meters), that define a size of moving
vector;

+ Set Z — set Z value (in meters) to move objects to specified elevation.

é, To set zero value double-click on selected field.

3. [optional] Select Selected in the Apply section, to move selected objects only,
otherwise, select All.

4. Click OK. After that vector objects are moved to specified distance or elevation.

10.1.2. Converting polygons to points

The function polygons to points conversion is intended for conversion of all or selected
polygons into point objects.

é The code with P (points) type should be selected to perform operation in the vector layer with
classifier. Otherwise conversion couldn’t be performed.

To perform the conversion, select Vectors » Geometry » Convert polygons to points.
If there is selected objects in the layer, both all and only selected objects could be
converted.
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As a result of the operation the polygons are replaced by point objects. These points
are placed in the mass centers of the boundaries of the original polygons. In the layer
with classifier selected code is assigned to new point objects and all attributes of source
linear objects.

The system also provides possibility to convert all vertices both of polylines, and polygons
to point objects. To perform the conversion, select Vectors » Geometry > Convert all
vertices to point objects. The new vector layer containing point objects is created.

10.1.3. Conversion of vector object to geometric shape

The system provides opportunity to convert arbitrary polygons into standard geometric
shapes:

 ellipse;

* round;

* rectangle;

* square;

» orthogonal polygon.

In order to convert active layer polygons into geometric shapes perform the following
actions:

1.

2. Select Vectors » Geometry » Convert to figure. The Parameters window opens.

3. [optional] Set the Selected objects checkbox on to convert only to selected poly-
gons. Otherwise, all polygons are converting.
4. Define the following parameters:

Make vector layer active.

-
. Parameters

===

Celarted ahi

Figure type

—

=

Ellipse -

Interpolation precision 0,500 -

m

[ o

l | Cancel |

L8

4

Fig. 156. Parameters of vector object conversion into geometric shape

» Figure for conversion;
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* Precision for conversion.

@ The system allows to approximate vector objects presented in the form of curves by
broken lines. This approximation precision, that is maximal distance from the broken
line segment to the curve between two closest vertices, is specified by user. This para-

meters default value is 0.5 in measurement units of current project (usually in meters).

5. Click OK. Polygons convert to selected geometric shape with specified approximation
precision.

10.1.4. Correcting by residuals vectors

The operation of vector layer correction using residuals vectors is intended to clarify
the position of vector objects.

To perform vector layer correction using residuals vectors, execute the following actions:

1. Open the layer with residuals vectors (linear objects).

@ Residuals vector layer should be create, for example, by measuring of residuals on points
manually. To create a new vector layer set the Save measurements in layer checkbox
on in the Measurement window.

2. Open the layer to be corrected.

3. Select Vectors » Geometry > Correct by residuals. The Settings window opens.

( ’. Settings I,ﬁr

test_attributes (Wectors)

| Create new layer for corrected vectors

Correct height

Ok | | Cancel

b A~

Fig. 157. Parameters of correcting by residuals vectors

4. Select a layer with residuals vectors in the list.

5. [optional] To correct objects in active layer, set the Create new layer for corrected
vectors checkbox off. Otherwise new vector layer creates.
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6. [optional] To change not only XY coordinates, but also the height, set the Correct
height checkbox on.

7. Click OK. The new vector layer containing corrected vectors is created.

10.1.5. Cut vectors by selected polygons

The system provides the possibility of cutting vector objects of one layer by the
boundaries of polygons of another layer. Perform the following actions to do this:

1. Open a layer with polygons to be used as borders, or make this layer editable.
2. Select polygons to be used as boundaries.

3. Select Vectors » Geometry » Cut objects by selected polygons.

. Cut by selected polygons Lé]

Layer with boundaries polygons

test_attributes (Vectors)

Cut layers

Pazmertka (Vectors)

| Keep dosed after cutting
Apply to selected
Delete empty files
Mode
@ Cut outside
Cut inside

Batch cutting

o

Fig. 158. Parameters of cutting by boundaries

4. Inthe Cut layers list select a layer with objects to be cut.

5. [optional] In order to not to close the polylines after cutting automatically, set the
Keep closed after cutting checkbox off.
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6. [optional] To apply the operation to selected objects only, set the Apply to selected
checkbox on.

7. Leave the Delete empty files checkbox clear;

8. Select mode:
» Cut outside — to cut vector objects located out of selected polygons;
» Cut inside — to cut vector objects located inside the selected polygons;
« Batch cutting.

9. Click OK. After that the system removes all objects of the layer specified, that are
locates outside the selected boundary.

Batch vector cutting by selected polygons

The system allows for batch cutting of vector objects within one layer by polygon
boundaries within other layer.

The batch cutting results in creation of new vector layers each of which contains objects
cut by the internal boundary of one of enclosing polygons. The initial layer containing
the objects to be cut remains unchanged.

This function can be used e.g. to cut notation sheets by the image block scheme. To
do this, perform the following:

1. Choose Block » Create vector layers from block layout in order to create a Block
scheme vector layer that displays image boundaries (see more details in the “Cre-
ating vector layers from block layout” chapter of the “Creating project” User Manual).

The polygons located in the Block scheme vector layer have the following automat-
ically specified attributes:

* Name of attribute — Label;
+ Type of attribute — text;
* Attribute value — Image name.

ﬁ If polygons used as boundaries have no attributes, create attributes before batch cutting.

2. Create a separate vector layer with notation sheets.

Notation sheets created by generators of splitting into sheets have the following
automatically specified attributes:
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* Name of attribute — Name;
+ Type of attribute — text;

* Attribute value — Sheet name.

ﬁ If vector objects for batch cutting have no attributes, create attributes before batch cutting.

3. Make the layer with polygons to be used as boundaries editable;

é In given case this is the Block Scheme layer.

4. Select polygons to be used as boundaries;

5. Choose Vectors » Geometry > Cut objects by selected polygons;

. Cut by selected polygons

===

Layer with boundaries polygons

test_attributes (Vectors)

Cut layers

Pazmerka (Vectors)

keep dosed after cutting
] Apply to selected
[ Delete empty files

Mode

() Cut outside

(71 Cutinside

@ Batch cutting

Attribute from layer with boundaries polygons

NAME
Target folder
Target attribute from cutting layer
[ oK ] [ Cancel

)

L8

A

Fig. 159. Parameters of batch cutting by polygons
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6.

10.

1.

12.

[optional] In order not to close cut notation sheets with image boundaries, clear the
Keep closed after cutting checkbox;

Select the mode - Batch cutting;

Set the Delete empty files checkbox to not create blank files for those polygons,
within which vector objects intended for cutting will not be found. Otherwise, vector
files will be created for all selected polygons, including “blank” ones, i.e. not contain-
ing any vector objects.

Input the Attribute from layer with boundaries polygons;
@ In given case this is the name of the attributes of polygons displaying image boundaries —

Label.

In the Target folder field, click the _.. | button and select the folder in the active
profile resources where the output vector layers are to be saved.

@ In given case, these are cut notation sheets as separate layers for each image boundary.

Names of output vector layers are to be set automatically from the object attribute

values used as boundaries for cutting.

§ In given case, it is the Label attribute value, i.e. names of the images on the borders of
which the cutting takes place.

Input the Target attribute from cutting layer;

% In given case, this is the name of the attributes of polygons displaying notation sheets —
Name.

Select a layer with objects to be cut in the Cut layers section and press Ok.

? If a layer with objects to be cut was created but not previously saved, a window opens
where the system suggests to save it before operation execution.

B ueneBon nanke co3gatoTcs BbIXOOHbBIE BEKTOPHbIE CIIOU, coaepkaluue (B 4aHHOM
npumepe) oOpe3aHHble HOMEHKNATypHble JIUCTbl, 3aMKHYTble rpaHuLaMu
n3obpaxeHun, B criydae ecnu pnaxok Keep closed after cutting He Obin cHAT.

Output vector layers that contain (in given case) cut notation sheets are created in
the target folder. The cut notation sheets are closed by image boundaries if the
Keep closed after cutting checkbox was not cleared.

Cut notation sheets have automatically specified attributes, as follows:
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* Name of attribute — Name;
+ Type of attribute — text;

* Attribute value — Image name Sheet name.

§ Cut notation sheets keep their attributes only if they are polygons (i.e. the Keep closed
after cutting checkbox was not cleared).

Fig. 161. Open (left) and closed (right) cut notation sheets
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10.1.6. Cutting objects around selected vectors

The system allows to cut vector objects around selected vectors placed at the same
layer. To do this, perform the following:

? The function is available for all types of vector objects.

1. Load or create a layer with vector objects;

2. Select vector objects around which it's necessary to cut all the other vector objects
of the given layer.

3. Bbibepute Vectors » Geometry > Cut objects around selected.

i '
. Input cutting offset &u

1.000 =

L &

Fig. 162. Parameters of cutting objects around selected ones

4. Input cutting offset around vertices and segments of the selected objects in meters.

5. Click OK. As a result, in the current vector layer all the point object and segments
of polylines/polygons placed inside a cutting offset are deleted.

ﬁ, In case of cutting vector objects around polygon, a cutting offset is placed both out of
polygon and in it.

Fig. 163. Cutting vector objects around selected object
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10.1.7. Splitting objects into layers depending on type
The system allows to split objects into layer depending on their type.

The Vectors » Geometry > Split into layers by object type menu item is used for that.
If the layer contains only one type, the system displays an appropriate message. In
other cases two or three new layers are created, each of which contains only one type
of objects.

10.1.8. Vector objects transformation

The system allows to perform geometric transformation of vector objects: rotation by
the angle and scaling.

@ The system also allows to perform geometric transformation of vector objects in alignment mode.

§ The system also allows to perform fast geometric transformation of vector objects.

To do such transformation perform the following actions:
1. Select objects to be transformed.

2. Select Vectors » Geometry > Transform > Transform.... The Geometrical trans-
form of selected objects window opens.

-
. Geometrical transform of selected objects [—S_."hj
Rotation angle:
J h.00 =
-130 90 0 90 180
Scale
u 1.000 =
110 15 12 1 9 5 10
Preview | Ok | [ Cancel ]

Fig. 164. Parameters of geometric objects transformation

3. Move sliders to set the following parameters:
* Rotation angle — the value is set in degrees, in range from -180 to 180;
+ Scale — is changed from 1/10 to 10 times.

4. [optional] To disable preview mode of transformation in real time, set the Preview
checkbox off. It is recommended to set it off when working with a large number of
vector objects to increase the system performance.
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5.

Click OK. After that all selected vector objects are transformed in accordance with
selected parameters without change of elevation value.

To rotate vector objects manually in arbitrary angle, perform the following:

1.
2.

iy
iy

Select objects to be transformed.
Select Vectors » Geometry > Transform > Rotate.

Press and hold Ctrl key and move mouse cursor to the point considered as a pos-
sible rotation center of the object. No moving a cursor press and hold left mouse
button. Keeping Ctrl key and left mouse button rotate vector object with moving
mouse.

Turn off parameter Vectors » Geometry > Transform > Rotate.

The system allows to rotate a specific vertex of the object. To do it, perform actions similar to
the actions mentioned above with selecting an object vertex.

The system allows to rotate specific segments of the object. To do it perform actions similar to
the actions mentioned above with preliminary selecting parameter Edit » Point editing mode
and choosing vertices to which specific segments of the object adjoin.

To scale vector objects manually, perform the following:

1.
2.

7
7

Select objects to be transformed.
Choose Vectors » Geometry » Transform » Scaling.

Press and hold Ctrl key and move mouse cursor to the point considered as a pos-
sible scaling center of the object. No moving a cursor press and hold left mouse
button. Keeping Ctrl key and left mouse button perform scaling vector object with
moving mouse.

Turn off parameter Vectors » Geometry > Transform > Scaling.

Performing this function to the object selected vertex will provide a scaling of the object part
which includes a vertex selected and segments adjoining to it.

To scale specific segments of the object, perform actions similar to the actions mentioned above
with preliminary selecting parameter Edit » Point editing mode and choosing vertices to which
specific segments of the object adjoin.

10.1.9. Fast vector objects transformation

The

system allows to perform fast geometric transformation of vector objects: rotation

by the angle and scaling.

To do such fast transformation perform the following actions:
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1. Choose Edit » Rotation mode or click the &} button of the Tools toolbar to enable
the fast vector objects transformation mode;

2. Select objects to be transformed. The point considered as a possible scaling/rotation
center of the object () would be created automatically;

Fig. 165. The polygon selected in fast vector objects transformation mode

3. [optional] Press and hold Ctrl key and move mouse cursor to the point considered
as a possible scaling/rotation center of the object. No moving a cursor press and
hold left mouse button. Keeping Ctrl key and left mouse button perform relocation
of this point with moving mouse;

Fig. 166. Relocation of the point considered as a possible scaling/rotation center of the object

4. [optional] Keeping Alt key and left mouse button perform vector object movement
in XY plane with moving mouse;
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5. [optional] Keeping Ctrl key and left mouse button perform scaling/rotation of
vector object with moving mouse.

% To perform the vector object rotation and vector object scaling separately the Transform
menu items are used (Vectors » Geometry » Transform).

6. Choose Edit > Rotation mode or click the 5} button of the Tools toolbar to disable
the fast vector objects transformation mode;

10.1.10. Alignment mode

The system enables for geometric transformations of objects in the alignment mode.
The alignment mode allows to perform simultaneously the following operations with
vector objects:

 rotate and scale one vector object relative to another;

* moving (connecting) vector objects on the plane and heightwise.
Connecting is the process of vector object moving so that at least one vertex of one object

completely coincide on the plane with another object’s vertex (see also the “Contours con-
necting” section of the “DTM Generation” User Manual).

To perform geometric transformation of vector objects in the alignment mode, do the
following:
1. Create or open a layer containing at least two vector objects;

2. In order to enable the Alignment mode, select Edit » Alignment mode or click
the &= button of the Tools toolbar;

3. [optional] To scale vector objects during their transformation in the alignment mode,
select Edit » Scale when align or click the &L button of the Tools toolbar;

4. [optional] To connect vector object both on the plane and heightwise, select Service »
Settings > Vectors and set the Change Z of aligned object checkbox;

5. Select two vertices of the object chosen for geometric transformation using the left
mouse button (labels 1 and 2 will appear in the vicinity of the selected vertices).
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Fig. 167. Selecting vertices of the object chosen for geometric transformation.

5 The selected vertices need not be always adjacent.

ﬁ, To cancel the selection, press Esc.

6. Using the left mouse button, select two vertices of the object, relative to which
the transformation will be performed. Labels 1' and 2' will appear in the vicinity of
the selected vertices.
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Fig. 168. Selecting vertices of the object, relative to which the transformation will be performed.

7. Press Enter.

The vector object, chosen for transformation, is rotated and moved on the plane
as follows:

* Vertices 1 and 1' coincide on the plane;

* The vertex 2 is located on the straight line between vertices 1' and 2'.
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Fig. 169. Connected vector objects.

If the Scale when align function was also enabled, the vector object under trans-
formation is scaled after connecting in the way that the length of the segment (dis-
tance) between vertices 1 and 2 would be equal to the length of the segment (dis-

tance) between vertices 1' and 2'.
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Fig. 170. Connected and scaled vector objects.

If the Change Z of aligned object checkbox was set in the Vectors tab of the
Settings window (Service > Settings » Vectors), the height of the object under
transformation after connection will coincide with the height of the object relative

to which the transformation is performed.

The system allows for geometric transformation of several objects at once in alignment mode,
for example in case of roofs. To do this, select several vector objects before choosing vertices.
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Fig. 171. A gable roof consisting of two vector objects (the left pitch is selected).

Fig. 172. A gable roof consisting of two vector objects (the right pitch is selected).
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Fig. 173. Geometric transformation of a roof consisting of two polygons, in the alignment mode (Option
1). The scaling mode is enabled.

Fig. 174. Geometric transformation of a roof consisting of two polygons, in the alignment mode (Option
1). The scaling mode is enabled.
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Fig. 175. Geometric transformation of a roof consisting of two polygons, in the alignment mode (Option
2). The scaling mode is enabled.

Fig. 176. Geometric transformation of a roof consisting of two polygons, in the alignment mode (Option
2). The scaling mode is enabled.
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10.1.11. Projective transform

The system allows to perform projective transformation of vector objects.

Perform the following actions to do this:

1. Select Vectors » Geometry > Projective transform. The Apply projective trans-
form window opens.

e N
. Apply projective transform —

= H »
Transform

2D affine @ 3D projective 30 projective
X all 1.000000 % al2 0.000000 = ~ al4 0,000 = X
T a21 0.000000 +| 222 1.000000 = -| a24 0.000 = ¥

= X
7 a231/0.000000 +| a3z|o.000000 | a44|0.000 : 7
= a41 0.000000 % a42 0,000000 =1 243(0.000000 ~ a44 1.000 = 1
*This fransform changes £ coordnate. The fransform i= frue 20 projective
for obfects with Z=0.

Apply

to all ohjects @ to selected objects

[ Ok ] | Cancel

Fig. 177. Parameters of projective transform

2. Select one of the following transformation types:

2D affine — the system performs transformation by rotation matrix and parallel
displacement;

2D projective — the system performs transformation by rotation matrix, parallel
displacement and scaling;

é This type of transformation leads to change Z coordinate!

3D affine — the system performs transformation by rotation matrix and parallel
displacement, including transformation by Z;

3D projective — the system performs transformation by rotation matrix, parallel
displacement and scaling;

3. Specify transformation coefficients depending from selected transformation type.
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@ The button allows to save coefficients to a CSV-file. The = button allows to load coef-
ficients from a CSV-file.

To reset coefficients to default values click the w2 button.

4. [optional] In the Apply section choose objects to transform:
« All objects;
+ Selected objects.

5. Click OK. After that all or selected vectors of active layer are transformed according
to specified parameters.

10.2. Creation of additional vector objects

10.2.1. Adding intersection points

The system provides the ability to automatically add a vertex at the intersection of
vector objects. Perform the following actions to do this:

1. Select Vectors » Geometry » Add intersection points. The Layers selection
window opens.

i ’. Layers selection Iﬁﬁ

‘PasmeTra (Vectors)
test_attributes (Wectors)

Selected objects
Maximal distance restricted by |0, 10

Take height from first layer

(04 | | Cancel

Fig. 178. Parameters of intersection points adding

2. Selectin the list one or several layers where to search for vector objects intersec-
tions.

3. [optional] To apply the operation to selected objects only, set the Selected objects
checkbox on.
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[optional] To apply the operation only to objects, the distance between which is less
than a predetermined value, set the Maximal distance restricted by checkbox on
and specify distance between the objects.

[optional] In order to take height from first layer — set the appropriate checkbox;

Click OK. After that the system adds points at the intersection of polylines/polygons
in accordance with the specified parameters.

@ Intersection points are added on both intersected objects.

10.2.2. Creating a symmetric objects

The system provides possibility to create symmetrical lengthy objects both linear and
areal. The functions of the Symmetric objects menu are used to automate creation of
conditionally symmetrical objects, such as roads, water bodies, etc.

Perform the following actions for creating a symmetric object (polyline):

1.
2.

Create the polyline (draw one side of an extended object, e.g., river bank).
Highlight the polyline for symmetrical reflection.

Place marker on another side of the object on image (for example, the opposite
bank of the river).

Choose Vectors » Geometry » Symmetric objects » Polyline. As a result, a high-
lighted polyline is symmetrically copied to the marker position.

% A correctness of the function to be performed depends on mutual position of marker and
polyline selected.
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Fig. 179. Steps for creation of the symmetric polylines

To create quasi-symmetric polygon object, perform the following:
1. Choose Vectors » Geometry » Symmetric objects » Polygon;

2. Start to draw a polygon;

§ A distance between the second parallel line and initial segments of the creating polygon
is defined with a distance between the first and the second vertices of given polygon (see
figures).

§ A position of the second parallel line regarding initial segments of the creating polygon (on
the left or on the right respectively drawing direction) is defined with an angle between the
first and the second segments of given polygon (see figures).
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Fig. 180. Initial stage of creating “symmetric” polygon object. Selecting distance between parallel
lines and their mutual position

3. Complete polygon creation;
4. Turn off mode Vectors » Geometry » Symmetric objects » Polygon.

ﬁ A correctness of the function to be performed depends on the shape of polygon created.

? Given function does not allow to create ring-shaped polygons. To create ring-shaped
polygons see “Cut out area from polygon” chapter.

? A split segment of the ring-shaped polygon (see figures) is a segment which is placed
between the first and ending vertices of creating polygon. The system allows to create
quasi-symmetric ring-shaped polygons with a function as below.
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Fig. 181. “Symmetric” polygon objects created with function Vectors » Geometry » Symmetric objects >

Polygon

To create quasi-symmetric ring-shaped polygon, perform the following:

1.

2.

Load or create polygon;
Select polygon;
Place marker inside or out of polygon;

Choose Vectors » Geometry » Symmetric objects » Polyline. As a result a quasi-
symmetric ring-shaped polygon is created. Its outer or inner boundary (depending
on marker position — inside or out of polygon) corresponds to initial polygon
boundary.

§ A correctness of the function to be performed depends on mutual position of the marker
and selected polygon.

§ Given function does not allow to create ring-shaped polygons. To create ring-shaped
polygons see “Cut out area from polygon” chapter.

§ A split segment of the ring-shaped polygon is a segment which is placed between the first
and ending vertices of initial polygon. The system allows to create quasi-symmetric ring-
shaped polygons with a function mentioned above as well.
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Fig. 182. Creating “symmetric” polygon objects

The system also allows to create mirror symmetry objects based both on polygons and
polylines (resulted object is a polygon anyway). To create these objects perform the

following:

1. Load or create polyline/polygon;

2. Select given object;

3. Turn on point editing mode in Vectors toolbar. Turn on add to selection mode in
Tools toolbar.

4. Select any two vertices of the object like to set a symmetry axis of creating object;

5. Bbibepute Vectors » Geometry » Symmetric objects » Mirror object. As a result

selected object will be transformed around specified symmetry axis into polygon
object.

\/E, Shape of the resulted object depends on symmetry axis specified (i.e. mutual position of
two selected vertices).

\/E, It is necessary to take into account that a segment placed between the initial and ending
vertices of the polygon will be deleted (in some cases while specifying symmetry axis of
the creating object it is recommended to select these vertices directly).

Ql Points selected while specifying a symmetry axis are duplicated as well.
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Fig. 183. Creating mirror symmetry polygon objects from polyline
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Fig. 184. Creating mirror symmetry polygon objects from polygon
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10.2.3. Building buffer zone

Building of the buffer zone means to create a polyline/polygon parallel to selected line
and situated at a predetermined distance from it.

To create buffer zone perform the following actions:

1. Select vector objects in 2D-window and choose Vectors » Geometry » Buffer zone.
After that the window of buffer zone parameters is opened.

@ Buffer zone could be created both around linear, and areal objects.

If in 2D-window select only one type of objects, automatically set on the Poly-
lines/Polygonscheckbox depending on type of selected objects.

. Buffer zone S )

| Palylines

Left @ Both Right

@ Create 2 polylines
Create a polygan
Create a polygon along the polyline

| Polygons

@ Outside Bath Inside
Distance Z shift

10.0 S{m oo s m

Thin out
Delete source objects

V| Round corners

[ oK l | Cancel |

Fig. 185. Window of buffer zone parameters
2. [optional] Buffer zone could be created for objects of only one type, if needed. If
selected both polylines and polygons, remove one of checkboxes.
3. Define location of buffer zone in regard to selected object.
For polyline the system provides the following ways of buffer zone location:

» Left — to the “left” of the active object in accordance with the numbering of its
vertices;

* Right — to the “right” of the active object in accordance with the numbering of its
vertices;
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Both — on both sides of the selected object. In this case the system allows:
o Create 2 polylines on both sides of the polyline;
o Create a polygon around polyline;

o Create a polygon along the polyline.

For Polygon the system provides the following ways of buffer zone location:

Outside — outside of source polygon;
Inside — inside of source polygon;

Both — on both sides of the selected object.

4. Depend parameters of buffer zone creation:

Distance — a distance from selected object in meters (buffer zone width);
Z shift — shift of buffer zone polyline vertices on specified height;

Thin out — allows to thin out vertices of selected objects during buffer zone cre-
ation;

Delete source object — allows to delete source object during buffer zone creation;

Round corners — allows to round the corners of the outer edge of the buffer
zone.

5. Click OK to create buffer zone for selected vector objects.

The system provides for quick creation of a buffer zone for the vector objects of the
same type (polygon, polyline, or some polylines).

A

The system provides for quick creation of a buffer zone for a single selected polygon. This re-
striction does not apply to polylines.

For the fast creation of the buffer zone perform the following actions:

1. Select vector objects in 2D-window;

2. [optional] move the marker in XY plane to set the buffer zone width;

3. [optional] change the marker height to shift of buffer zone polygon/polyline vertices
on specified height;

4. Choose Vectors » Geometry » Buffer zone to marker to create buffer zone for
selected vector objects.
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@ When working with vector objects, for ease Vectors » Geometry » Buffer zone to marker
function use it is recommended to set an appropriate hotkey (see the “General information”
User Manual).

10.2.4. Geometric figures around objects vertices

The system allows to create circles with defined radius, rectangles or squares with
defined side length around vertices of linear objects.

Perform the following actions to do this:
1. Select a vector objects.

2. Choose Vectors » Geometry » Objects around points. The Settings window

opens.
r. Parameters [&r
| Selected objects
|Cin:|e v|
Radius 10,000 m
Interpolation predsion 0,100 =im

| Delete point objects

[ CK H Cancel |

L9 4

Fig. 186. Parameters of geometric figures creation around objects vertices

3. Specify the following parameters:

* [optional] Selected objects — geometric figures creates only around vertices of
selected objects, otherwise — around vertices of all objects in current layer;

» select a geometric figure type: circle, square or rectangle;
* [optional] Circle radius — allows to specify circle radius in meters;

 [optional] Interpolation precision — allows to specify maximal discrepancy
between segments of polyline that replaces a circle and the circle itself;

* [optional] Height of square — allows to specify square’s side length;
 [optional] Height and Width of rectangle — allows to specify rectangle’s size;

 [optional] To delete point objects when the operation is complete, set an appro-
priate checkbox.
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4. Click OK.

All attributes of a point object around which a polygon (geometric figure) is created
are automatically assigned to the above polygon. This feature can be useful e.g.
for further GCP outline creation (for detail, see the “Splitting into sheets” in the
“Orthophotomaps creation” User Manual).

10.2.5. Creation of profiles through selected objects

The system provides the function of construction of perpendicular profiles through the
group of linear vector objects. The resulting processing profiles (linear or point vector
objects) attached to the selected codes in the classifier and are used to solve a variety
of applied tasks.

@ This function is used, for example, to describe a dam “consisting” of two lines on both sides of
its base, and two lines on its surface.

Perform the following actions to create profile:
1. Selects one object by double-click.
2. Do not unselect object and select the rest objects from the group.

3. Select Vectors » Geometry > Vectors profiles. The Vectors profiles window
opens.

r‘ Vectors profiles — i )

| Create points with code Points

| Create polylines with code  Lines

Y

Distance between profiles 10.000 = m

[ OK ] | Cancel |

L8 -

Fig. 187. Generation profile by vectors

4. In the Distance between profiles field specify a step of profile lines creation (in
meters) to generate profiles approximately perpendicular to the selected vector
object.

5. [optional] To save points of profiles intersection with selected objects as points
codes, set the Create points with code checkbox on and specify the code name.

6. [optional] To save lines of profiles with selected objects as polylines codes, set the
Create polylines with code checkbox on and specify the code name.

% Points and polylines are assigned to classifier as codes of linear (L) and point (P) objects
and are placed to the root layer of the classifier table.
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7. Click OK. After that the system creates perpendicular profiles through selected
vector objects.

10.2.6. Checking orthogonality of polygons corners

The system provides possibility to check orthogonality of polygons corners. A search
of errors of deviation from the right angle between the vertices of the object or the dis-
tance between the leg and then the apex of the object.

In order to find these errors, perform the following actions:
1. [optional] To check orthogonality for selected objects, select them on the layer.

2. Check Vectors » Geometry > Check orthogonality. The Check orthogonality
window opens.

. Check orthogonality —r 5 )

Apply to selected objects

@ Maximum deviation from the right angle (degrees ) 5.00 -

Maximum deviation (m) 1.00

[ CK l | Cancel

Fig. 188. Checking orthogonality of corners

3. [optional] In order to verify orthogonality of only selected objects, set the Apply to
selected checkbox on.

4. Select one of the following ways of moving:

* Maximum deviation from the right angle (degrees) — maximum angle deviation
between two sequence vertices, from 90 degrees.

% Input maximum value of deviation on degrees.

* Maximum deviation (m) — maximum deviation of distance between vertex of
triangle leg (that conditionally completed between two sequence vertices) and
the next vertex of objects.

The right angle of triangle is between conditional leg vertex and the first vertex, from
which is calculates the angle.

é Input maximum value of deviation on meters.
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5. Click OK. Information message with number of orthogonality errors is displayed.
The Orthogonality layer creates. It contains vertices of object with deviations.

10.2.7. Extraction of vector objects by spatial relationship

The system provides for creating a new vector layer that contains objects selected from
the source vector layer in terms of spatial relationship with objects of the third (additional)
layer.

Spatial relationship indicates how a certain object is located in space, relative to another
(reference) object. This feature is available for all types of vector objects, both for point
ones and for polylines (polygons).

The following criteria of object selection in terms of spatial relationship are provided:

* intersect — a vector object located in the source layer intersects a vector object located
in the additional layer;

A Intersection of vector objects in the 3D space is obligatory (see the “Process in 3D-window”

section in the “General information” User Manual). For example, polygons whose planes do

not intersect in the 3D space are not considered intersecting, despite their possible visual
intersection in a 2D window.

Similarly, the location of a point object on the plane of the polygon (inside it) is a sufficient
condition for the intersection of the polygon and the point object, even if there are no intersec-
tions of the point with the segments of the polygon. At the same time, visual crossing of a
point with a polygon segment in the 2D window (without exact spatial coincidence in elevation)
is not a sufficient condition (see the detailed description of 2D and 3D snapping tools in
Section 3.4.6).

» touch —alinear vector object located in the source layer that has at least one common
segment with a linear vector object located in the additional layer;

A Exact spatial coincidence of vector objects’ elements in the 3D space is obligatory (see the

detailed description of 2D and 3D snapping tools in Section 3.4.6). The segment match must

be complete (i.e., it implies an exact geometric match of initial and final vertices of both seg-

ments). A point object is tangent to a polygon (polyline) if it is located in any part of this object
segment (Z-coordinate is taken into account).

» contain — a vector object of the additional layer is located entirely inside a vector
object in the source layer;
C Both objects must be located in the same plane (see the “Process in 3D-window” section in

the “General information” User Manual).

» equal — a vector object in the source layer completely coincides with the vector object
of the additional layer;
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c Complete coincidence of coordinates of objects’ vertices (XYZ) and complete coincidence

of the order of the location of the objects’ vertices are obligatory (see the “Settings of point
numbers display” chapter in the “General system’s parameters” User Manual).

To extract vector objects according to their spatial relationship, perform the following:

1.

2.

Create at least two layers with vector objects;

[optional] if only a part of the existing vector objects are to be processed, perform
the following:

 [optional] select the appropriate vector objects in the layer that taken as source;
+ [optional] select the appropriate vector objects in the layer that taken as additional.

Choose Vectors » Geometry » Extract vectors by spatial relationship. The Ex-
tract by location window opens.

r. Extract by location [ér

Extract objects in layer

|P63METKB (Vectors) - |

Selected objects only

where object (geometric operator)
intersect touch
contain equal

objects from the layer for comparison

|P63METKB (Vectors) - |

Selected objects only

[ OK l | Cancel |

Fig. 189. Object extraction parameters
In the Extract objects in layer drop-down list, specify the vector layer selected as
source;

 [optional] to process the selected objects only in this layer, set the appropriate
checkbox;

Set the required criteria of object selection (see above) by setting (clearing) the
appropriate checkboxes: intersect, touch, contain, equal;

In the objects from the layer for comparison drop-down list, specify the vector
layer selected as the additional one;

 [optional] to process the selected objects only in this layer, set the appropriate
checkbox;
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7. Click OK. After the operation is completed, an appropriate info message is issued,
with data on the number of extracted objects;

(@ PHOTOMOD 7.33809 E=REER N

i ] -ii_j 23/11/2022 15:46:45: Objects extracted: 0
Ny

¥. 10

1

e
s

]

i
|

-~

Fig. 190. An info message

8. Ifobjects are found that meet the specified conditions, a new vector layer is created
containing suitable objects copied from the source layer.

10.3. Vector objects projecting

10.3.1. Projecting onto relief

The system provides possibility to project vector objects on relief of active stereopair.
Perform the following actions to do this:

1. Open a stereopair and load a layer with vector objects.

2. Select Vectors » Geometry » Project on stereomodel. The Parameters window
opens.
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-
. Project on stereomodel parameters

]

Apply to selected
@ Vertices only

Vertices and polylines with step | 1.0

Correlation parameters]

| oo

| | Cancel

Fig. 191. Parameters of vectors projecting on relief

3. Define the following parameters:

* Apply to selected — allows to project only selected vector objects;

* Vertices only — allows to project only points or vertices of all/selected vector

objects;

* Vertices and polylines with step — allows to simultaneously break the linear
objects into broken lines fragments at a predetermined step and project interme-

diate vertices.

4. [optional] To configure correlator’s parameters click the Correlation parameters
button (see the “General system’s parameters” User Manual).

5. Click OK. All or selected vector objects are projected on relief of active stereopair.

10.3.2. Vectors projecting on a TIN
The system allows to project vector objects on TIN.
Perform the following actions to do this:

1. Load vector layer.

2. Load TIN layer, on which it is necessary to project vectors.

3. Select Vectors » Geometry » Project on TIN. The Settings window opens.
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L%

. Project on TIN parameters et e

Apply to selected
Projected data
@) Vertices only

Vertices and polylines

[ 0K l | Cancel |

4

Fig. 192. Parameters of vectors projecting on a TIN

4. Select one the projecting modes:

» Vertices only — only linear objects vertices and points are projected on a TIN;

* Vertices and lines — simultaneously with vertices projection the system performs
intersection linear objects by TIN edges and intermediate vertices projecting.

5. [optional] To apply the operation to selected objects only, set the Apply to selected

checkbox on.

6. Click OK. After that vector objects elevations are replaced by elevations taken from

TIN.

10.3.3. Vectors projecting on a DEM

The system allows to project vector objects on DEM (automatically assign elevations
(Z2) to points/vertices of vector objects from loaded DEM). Perform the following actions

to do this:

1. Load or create vector layer;

2. Load DEM, on which it is necessary to project vector objects;

3. Select Vectors » Geometry » Project on DEM. The Project objects on DEM

window opens:

r. Project objects on DEM =)

Project on MULL cells

@ Keep previous elevation

@ Selected

Interpolate using neghbours Delete vertices

[ oK H Cancel |

4

Fig. 193. Parameters of vectors projecting on a DEM
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4. [optional] Choose Selected, to move selected objects only, otherwise, select All.
5. In Project on NULL cells section select one of following options:

* Keep previous elevation of vector object vertices;

* Interpolate using neighbours (use DEM cells neighboring to null cells);

* Delete vertices “falling” in null cells;

6. Click OK. After that vector objects elevations are replaced by Z coordinate taken
from DEM.

10.4. Deleting point objects using a parameter

10.4.1. Delete points around linear objects

Automatic deleting points around linear objects allows to “filter” points used to the TIN
creation. It is used if points, located near to linear objects, are conflict with these linear
objects.

In order to delete points perform the following actions:

1. Select Vectors » Geometry > Delete points around polylines. The Delete points
around polylines window opens.

. Delete points around polylines I,&J
Working layers
W E: &k

Pazmeria (Vectors)
| test_attributes (Vectors)

Parameters
Delete points doser than  10.000 = m

Apply to selected lines

[ kK l | Cancel |

L8 A

Fig. 194. Parameters of deleting points around linear objects

2. Select Working layers. By default the following layer are available:
« if the TIN layer is active — base vector layers;

 vector layer, if it is active;
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« all vector layers in all other cases.

3. Inthe Delete points closer than field define maximal distance from linear object
to a point in meters.

4. [optional] Setthe Apply to selected lines checkbox on, to delete points only around
selected lines, otherwise — around all.

5. Click OK. Processing is performed on all selected layers together, that is, for each
linear object of each layer are removed point objects that are closer specified dis-
tance.

10.4.2. Deleting points inside polygons

The system provides possibility to deleting points inside polygons. Points and polygons
could be located both in one layer and different.

In order to delete points inside polygons perform the following actions:
1. Load a vector layer with points.

2. [optional] If points and polygons are located in different layers, load a layer with
polygons.

3. Choose Vectors » Geometry > Delete points inside polygons.

i !
. Delete points inside palygons [&J
Layer with points: |Pa3r~1ema (Vectors) - |
Layer with polygons: |Pa3r~1ema (Vectors) - |
Delete points inside 1 % and more polygons

Ik ] | Cancel |

Fig. 195. Parameters of deleting points inside polygons

4. Select layer with points and layer with polygons in appropriate fields.

5. Specify minimal amount of polygons in the Delete points inside .. and more
polygons field.

6. Click OK. After that all points located inside specified number of polygons will be
deleted.

217



PHOTOMOD 8.1 Vectorization (Windows x64)

10.5. Transformation of objects coordinates

10.5.1. Swap of X and Y coordinates

The system allows to swap X and Y coordinates of vector objects. This function is used,
for example, to correct wrongly specified coordinates during objects import and allows
to re-calculate the coordinates from the left-handed coordinate system to the right-
handed one and vice versa.

The Vectors » Geometry > Swap X <->Y menu item is used for this. At that the coordin-
ate system of project do not change.

10.5.2. Change objects coordinate system

The system provides opportunity of coordinates recalculation from one coordinate
system to another for all vertices of current layer.

Perform the following actions to do this:

1. Select Vectors » Geometry > Convert coordinate system. The Convert coordinate
system window opens.

i !
. Coordinate system conversicn I,&J
Input coordinate system
Cartesian Right (Local right Cartesian reference system) Select, @

Crientation: right, geo-referencng: local coordinate system

COutput coordinate system

Cartesian Right (Local right Cartesian reference system) Select, @

Orientation: right, geo-referendng: local coordinate system

Ok l | Cancel

Fig. 196. The Convert coordinate system window

2. Click the Select button to specify initial coordinate system.
Coordinate system is specified using one of the following ways:

* From DB - from international or Russian coordinate system database (see “Co-
ordinate systems databases” in the “Creating project” User Manual);

* From file — allows to select coordinate system from *. x-ref-systenmfiles, located
out of active profile resources;
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* From resource — from files with *.x-ref-system extension, located in active
profile resources, for example, to select coordinate system from another project
of active profile.

* From GeoCalculator — from the list of GeoCalculator program database (see
the “Coordinate Systems” chapter in “The GeoCalculator program” User manual).

é The GeoCalculator program allows to edit coordinate systems, to create new ones, to
perform import and export of coordinate systems (see the “The GeoCalculator program”
User Manual).

ﬁ The system also allows to select coordinate system from a list of recently used coordinate
systems.

3. [optional] When choosing coordinate system from database the Coordinate system
database opens, which contains the list of coordinate systems. To perform fast
search for coordinate system in the list, input the whole coordinate system name
or its part to the Find input filed.

. Coordinate systems database Internaticnal [é]
Find | L
# Name MNote it

1 AGDE6 / AMG zone 48 Australia - 102deg ...

2 AGDE6 / AMG zone 49 Australia - 108deg ...

3 AGDE6 / AMG zone 50 Australia - 114deg ...

4 AGDE6 / AMG zone 51 Australia - 120deg ...

5 AGDE6 / AMG zone 52 Australia - 126deg ...

6 AGDE6 / AMG zone 53 Australia - 132deg ...

7 AGDE6 /£ AMG zone 54 Australia - 138deg ...

8 AGDE6 / AMG zone 55 Australia - 14ddeg ...

g AGDE6 / AMG zone 56 Australia - 150deg ...

10 AGDeb6 / AMG zone 57 Australia - 156deg ...

11 AGD&6 / AMG zone 58 Australia - 162deg ...

12 AGDG6 Australia; Papua M... ~
[ oK ] | Cancel |

Fig. 197. Coordinate systems database window

4. [optional] To choose geoid, click the @ibutton. Select proper type of geoid usage:
* No geoid;
+ EGM 96.

é The system allows to use the EGM2008 geoid. See installation instruction in the User
Manual. After installation the geoid is displayed in the list.
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@ I

Mo gecid
EGM 2008
EGM 96

@ PHOTOMOD GeoCalculator provides for creating a user height system (geoid) with
preset parameters. PHOTOMOD system allows to use previously created custom ver-
tical datum (geoid). See instructions in the “Creating custom height system” chapter of

“The GeoCalculator program” User Manual.

Output coordinate system is specified in the same way.

@ When working with the project by default as input and output coordinate system is used the
project coordinate system. When working without project both coordinate systems should be
specified by user.

10.6. Transformation of CSV file

The system allows to delete from CSV-file points out of defined boundaries. The Cut
CSV file function is used for this with one of parameters:

* by rectangle edge;
* by selected polygons.
In order to cut CSV file by rectangle edges perform the following actions:

1. Choose Vectors » Geometry » Cut CSV file by rectangle edges. The Settings
window opens.

( . Parameters |,i:hjw
Extents
MNorth 5411126.457 =
West East
580029.577 = 581508.692 =
South 5409431.801 =
Input CSV file
=
Output C5V file
=
Exclude Z values: 0.0 | m
Swap X, Y
[ Ok l | Cancel |

L% 4

Fig. 198. Parameters of CSV file cutting by rectangle boundaries
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2. Enter coordinates of rectangular area in project coordinate system into the North,
West, East and South fields correspondingly.

3. In the Output file section click the _.. | button, to select input CSV-file with *.csv
or *.txt extension.

4. Inthe Output CSV file field specify output file name and path to save CSV-file.

5. [optional] In order not to consider points with specified elevation from CSV-file, set
the Exclude Z values checkbox on and specify Z value in meters.

6. [optional] To swap X and Y coordinates in CSV-file, set the Swap X Y checkbox.

7. Click OK. After that the system creates CSV-file, containing information only about
vector objects in frames of specified boundaries.

In order to cut CSV file by selected polygons perform the following actions:
1. To specify borders to cut CSV-file, select polygons.

2. Select Vectors » Geometry » Cut CSV file by selected polygons. The Settings
window opens.

( '. Parameters &Jw

Mode

@ Cut outside
Cut inside

Input CSV file

a

Cutput C5V file

£

Exdude Z values: (0.0 = m

Swap X, Y

oK ]| Cancel |

L A

Fig. 199. Parameters of CSV file cutting by selected polygons

3. Choose the file cutting mode:
» Cut outside — from CSV-file is deleting points located out of selected polygons;

+ Cutinside — from CSV-file is deleting points located inside of selected polygons;

221



PHOTOMOD 8.1 Vectorization (Windows x64)

4. |n the Output file section click the _... | button, to select input CSV-file with *.csv
or *.txt extension.

5. In the Output CSV file field specify output file name and path to save CSV-file.

6. [optional] In order not to consider points with specified elevation from CSV-file, set
the Exclude Z values checkbox on and specify Z value in meters.

7. [optional] To swap X and Y coordinates in CSV-file, set the Swap X Y checkbox.

8. Click OK. After that the system creates CSV-file, containing information only about
vector objects in frames of specified boundaries.

10.7. Elevation profile of a linear object

The system allows to create an elevation profile of a linear object (in the form of chart,
whose vertices are the vertices of a polyline). To create an elevation profile select one
linear object and choose Vectors » Geometry > Elevation Profile.

A window displaying elevation profile of the selected object opens. Z axis shows poly-
line’s vertices elevations, and L axis shows horizontal distances between polyline ver-
tices. On the right hand side of the Elevation profile window there is the slider, used
to change profile scale by Z axis (the lower limit of the scroll bar is the chart minimum
by Z axis).

[ . Elevation profile ﬁﬁ

=

488, 1 ! L3 TEI’J
487.6 " ’
487.1
486.6
486.1
485.6
485.1
484.6
484.1
483.6
483.1
0

tH~1RPOPL

50 100 150 200 250 300 350 400 450 500 550 600 L, m )

4 [}

Visible Layer name Color Z, metre dZ, metre Main
B objects13 D 5035 0.000

[ OK ] [ Cancel

Fig. 200. Elevation profile window
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Table 14. Functions provided by the Elevation profile window

Menu items Functions
&, Zoom in to zoom in by Z axis

&, Zoom out to zoom out by Z axis

&1 1:1 scale to set 1:1 scale

10.8. TIN area info

The system provides possibility to calculate polygon surface area, taking into account

vertices height.

7

The area measurement is available only for the polygons without self-intersections.

To calculate polygons surface area select Vectors » Geometry » Surface area of
polygons. After that the system opens information window with the following data (for
each polygon on the loaded vector layers):

+ information about value of polygon surface area, taking into account vertices height;

+ information about value of area of polygon projection on a plane.
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Fig. 201. The area of a polygon on TIN surface

11. Topological operations

11.1. About topology

The topology concept is one of the key terms used during quality assessment of created
maps. Throughout this documentation, the topology is referred to as set of functions
and operations, that define mutual location of vector objects and are used to create to-
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pologically correct vector data. The system provides the possibility of eliminating typical
topological errors, such as:

+ self-intersection of polylines/polygons;

* intersections of polylines/polygons without the formation of a common node (vertex
at the intersection point);

 polygons overlapping;

* gaps or voids between polygons when a map is covered by polygons, such as
woodlands polygons.

Q Topology — a branch of mathematics that studies the phenomenon of continuity in the most
general form, in particular, the properties of space, which remain unchanged under continuous
deformations, for example, the connectivity.

11.2. The “Topology” menu

For quick access to functions of vector objects editing, and also to change topological
modes the system provides the Topology additional toolbar, which buttons partly du-
plicated in the Topology menu.

In order to show the Topology, toolbar, choose Window » Toolbars » Topology.

Table 15. Brief description of the Topology menu

Menu items Function

*% Topological connectivity mode to automatically set the objects vertices connected
for objects created on a vector layer (see Sec-
tion 11.3.1)

™% Joint points editing mode to automatically set the objects vertices (located
closer than a specified distance) connecting during
to a vector object (see Section 11.3.2)

L} Close selected polylines (Shift+C) to convert polyline to polygon (close polyline, see
Section 11.4.1)

Z% Unclose selected polygons (Shift+B) to convert polygon to polyline (enclose polyline, see
Section 11.4.2)

1 Merge two polylines (Shift+P) to merge selected polylines into a single one by

adding a segment between two last vertices of
merging polylines (see Section 11.4.3)

[’'1 Merge polygons (Shift+G) to merge selected polygons that have overlap or
common border (see Section 11.4.3)

A\ Split polyline (Shift+X) to split a polyline into two ones in the closest to
marker vertex (see Section 11.4.4)

[A1 Split polygons/polylines (Shift+l) to split several polygons and polylines using “cutting”
polyline (see Section 11.4.4)
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Menu items

Function

I¥] Delete segment (Shift+D)

to remove a segment connecting two vertices of
polyline/polygon (see Section 11.6.3)

Delete selected vertices (Ctrl+D)

to delete vertices along with adjacent segments (see
Section 11.6.6)

[d] Cut out area from polygon

to cut an area out from a polygon, and to create a
ring-shaped polygon (see Section 11.4.5)

Fill empty area

to create of a polygon that fills a null area bounded
by at least two polygons whose adjacent segments
coincide exactly in space (see Section 11.9.3)

Duplicate object

to create several copies of vector objects which are
placed in the same layer (see Section 11.4.6)

Select nearest vertex (Shift+S)

to select polyline/polygon vertex closest to marker
position (see Section 11.5)

* Connect to point (Shift+V)

to connect creating line to existed one in a closest
to marker vertex (see Section 11.5

% Connect to line (Shift+L)

to connect creating line to existed one in arbitrary
place of segment (cm. Section 11.5)

Start from line (Shift+N)

to continue construction of the previously created
polyline (see Section 11.5)

Object fragment

to edit a fragment of polyline/polygon (see Sec-
tion 11.6).

Continue along polyline

to continue creating polyline along existed one to
the marker position, to the nearest common vertex,
or to selected vertex (see Section 11.7.1)

"#] Auto-close along polyline(Shift+M)

to draw a border of one polygon along a border of
another one (see Section 11.7.2)

** Make vertices of selected objects linked

to link vertices of selected polylines/polygons (see
Section 11.3.2)

= Make vertices of selected objects un-linked

to un-link vertices of selected polylines/polygons
(see Section 11.3.2)

¥l Topology verifying

to check vectors topology for errors and correct to-
pology errors (see Section 11.8.1)

Subtract one polygon layer from another

to subtract inactive polygon layer from the active
one (see Section 11.9.2)

Intersect one polygon layer with another

to avoid waste space between the layers (see Sec-
tion 11.9.1)

Find polygons relative position errors

to find and analyse errors of polygons relative posi-
tion (see Section 11.8.2)

Find polygons with one coinciding point

to find polygons having common points. Search
results are displayed on a new layer as points. (see
Section 11.8.3)
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11.3. Vertices connection

11.3.1. Topological connectivity mode

The system provides the ability to set some vertices connected for created vector objects.
The Topological connectivity mode is used for that.

@ Such need arises, for example, in the case of using the Vectors > Topology > Continue along
polyline » To selected vertex operation.

To make vertices of created vector objects connected, set Vectors » Topology » Topo-
logical connectivity mode checkbox or click the ™ button of the Topology toolbar.

To disable mode of creation connected vertices set the Vectors » Topology » Topolo-
gical connectivity mode checkbox off or click the % button of the Topology toolbar.
Continue create vectors in an ordinary mode.

c The Topological connectivity mode only affects new vertices of created vector objects.

To make vertices of object, created in ordinary mode, perform the following:
1. Select objects with vertices to make them connected.

2. Choose Vectors » Topology » Make vertices of selected objects linked or click
the == button of the Topology toolbar.

11.3.2. Joint points editing mode

The system provides the ability to set some vertices connected, that is used for co-
editing of two vector objects. The Joint points editing mode is used for that.

§ Such need arises, for example, in the case of complex roofs editing.

Connected vertices are called the vertices, which are considered a common vertex and
are edited simultaneously.

To make connected objects vertices located on specified distance, perform the following
actions:

1. Choose Vectors > Topology > Joint points editing mode or click the *& button of
the Topology toolbar.

2. [optional] Distance, closer which vertices are considered one common vertex and
edited simultaneously, is set in the general settings of the system. To change dis-
tance perform the following:

1. Choose Service > Settings (Ctrl+Alt+P). The Settings window opens.
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2. On the Vectors tab set the Points joint swath for topological operations —
minimal distance between vertices those are not consider as common vertices.

3. Connect creating polyline to existed one (see Section 11.5).

4. Click OK. After that all vertices located at a distance less than the predetermined,

are considered connected.

In order to make connected selected objects vertices, perform the following actions:

1.

2.

Select vector objects in 2D-window.

Choose Vectors > Topology » Make vertices of selected objects linked or click
the == button of the Topology toolbar. After that the vertices of selected objects
become linked.

To edit connected vertices, perform the following actions:

1.

Choose Vectors > Topology > Joint points editing mode or click the & button of
the Topology toolbar.

Choose Edit » Point editing mode or click the /% button of the Vectors toolbar.
Select one of connected vertices.
Press and hold the Ctrl key, and press mouse button to move connected vertices.

[optional] To remove connected vertices, select one of them and press Delete.
Connected vertices are deleting together.

In order to unlink selected objects vertices, perform the following actions:

set the Vectors > Topology > Joint points editing mode off or click the ™% button
of the Topology toolbar. Objects vertices become unlinked and could be edited
separately from each other.

define which linked vertices should become unlinked:

1.

2.

Select a vector object or several objects in 2D-window;

Choose Vectors > Topology » Make vertices of selected objects un-linked or
click the =¥ button of the Topology toolbar. After that the vertices of selected
objects become un-linked.
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11.4. Object editing
11.4.1. Polylines closing

The system allows to convert polylines to polygons — to close polylines.
In order to close single or multiple polylines, perform the following actions:
1. Select polylines in 2D-window.

2. Choose Vectors > Topology > Close selected polylines (Shift+C) or click the I_}
button of the Topology toolbar. After that selected polylines become closed and
converted to polygons.

In order to close a polyline in classifier layer, perform the following actions:
1. Select polyline in 2D-window.

2. In the Classifier window select a code with P type — polygon.

@ To check vertices for duplicates in first or end points, in the Settings window on the Vectors
tab set the Delete/add duplicate vertices while objects closing/unclosing checkbox
As a result:

» when closing polylines the system checks for duplicates of the first and last vertices, the
last vertex is deleted if necessary;

» when closing polygons the first vertex will be added to the end of polyline.

3. Choose Vectors > Topology > Close selected polylines (Shift+C) or click the i}
button of the Topology toolbar. After that the polyline becomes closed and converted
to polygon (see Section 6.7). Selected classifier code is assigned to this polyline.

11.4.2. Polygons unclosing
In order to unclose single or multiple polygons, perform the following actions:
1. Select polygons in 2D-window.

2. [optional] When work in layer with classifier in the Classifier window choose code
with the L type (polyline).

§ To check vertices for duplicates in first or end points, in the Settings window on the Vectors
tab set the Delete/add duplicate vertices while objects closing/unclosing checkbox.
As a result:

» when closing polylines the system checks for duplicates of the first and last vertices, the
last vertex is deleted if necessary;

228



PHOTOMOD 8.1 Vectorization (Windows x64)

» when closing polygons the first vertex will be added to the end of polyline.

3. Choose Vectors » Topology » Unclose selected polygons (Shift+B) or click the
2% button of the Topology toolbar. After that a polygon is converted to a polyline
and polygon’s segment connecting the first and last vertices. When work with
classifier, selected code assign to a new object.

11.4.3. Merging of polylines/polygons

The system provides possibility to merge polylines/polygons, spaced apart from each
other or having a common border or overlaps.

To merge two polylines perform the following actions:

1. Select two polylines in 2D-window.

é The system provides possibility to merge only two polylines.

2. [optional] When work with classifier, select in the classifier window code that should
be assigned to a new object (see Section 6).

3. Choose Vectors > Topology » Merge two polylines (Shift+P) or click the ™ 1 button
of the Topology toolbar.

Selected polylines merge in one, for this a segment adds between two edge vertices
of merging polylines.

To merge two or more polygons that share a border or overlap with each other, perform
the following actions:

1. Select in 2D-window polygons to be merged.

2. [optional] When work with classifier, select in the classifier window code that should
be assigned to a new object (see Section 6).

3. Choose Vectors > Topology > Merge polygons (Shift+G) or click the I’ button
of the Topology toolbar.

Selected polygons merging to one with the following way: intersection points became
to a vertices of a new polygon, overlapped segments deleting after intersection
points.

ﬁ If the polygons have attributes with the same names and mandatory attributes, new polygon
is assigned a value of an attribute whose type is the same type as the mandatory attribute.
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@ If merging polygons have attributes with the same names, but does not have mandatory
attributes, new polygon is assigned a value of an attribute of the polygon, which attribute
type is text. Otherwise, new polygon is assigned a value of an attribute of the polygon,

which attribute type is — float, otherwise — integer.

11.4.4. Splitting polylines/polygons

The system provides the following splitting operations of vector objects of active vector
layer:

 cutting polyline into two in an arbitrary vertex;

« cutting multiple polygons/polylines of a layer simultaneously using “cutting” polyline.
+ cutting polygon located in a layer with classifier using “cutting” polyline.

To split polyline into two ones, perform the following actions:

1. Select polyline in 2D-window.

2. Specify by marker an arbitrary vertex of polyline segment.

3. Choose Vectors > Topology » Split polyline (Shift+X) or click the /A, button of the
Topology toolbar. After the splitting one polyline is divided into two ones in the
vertex closest to marker.

In order to cut several polylines/polygons of the same layer at once using “cutting”
polyline, perform the following actions:

1. Create the “cutting” polyline, that intersects objects to be cut.

§ In order to cut a polyline in several places, cross the polyline as many times as needed.

C In order to cut a polygon, cross this polygon through two points, otherwise the operation
will fail.

Elevations of new vertices of output polygons are calculated in proportion to the elevations
of the neighboring vertices of the original polygon before it is split.

2. Select the “cutting polyline”.

% The system allows to change attribute values of objects, involving to cutting or merging
polylines. To do this in the Settings window on Vectors tab set the Set attributes to default
value while objects merging/splitting checkbox on. Source attributes change with the
following values: text — blank string, float — 0.0, integer — 0. If an object has obligatory at-

tribute with the same name, its value is used as default value.
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3. Choose Vectors > Topology > Split polygons/polylines (Shift+l) or click the [
button of the Topology toolbar.

The Parameters window opens:

f ’. Paramsters I,ﬁ,r

@ Split all

Split selected
| Delete cutting polyline
Split only polygons

K. ] | Cancel

Fig. 202. The Parameters window
Set the options for polygon/polyline splitting:

» Split all — the “cutting” polyline splits all the intersecting vector objects into sev-
eral objects of the same type. New segments are created at the intersections of
the “cutting” polyline (see above);

» Split selected — see below;

* In order to delete cutting polyline after the splitting is performed set an appro-
priate checkbox;

* In order to split only polygons when the both types of objects are intersected
by the “cutting” polyline, set an appropriate checkbox.

After that the “cutting” polyline cuts crossed vector objects by several objects of the
same type. In points of “cutting” polyline crossing the system creates new segments.
After completing the operation the “cutting” polyline is removed.

To split simultaneously some selected polygons/polylines within one layer by the “cutting”
polyline, perform the following:

1. Select only the “cutting” polyline which crosses objects to be split;
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Fig. 203. Selected “cutting” line

2. Add several vector objects to be split to the selected objects;

Fig. 204. The “cutting” line and the objects to be cut are selected

Fig. 205. The “cutting” line and the objects to be cut are selected

232



PHOTOMOD 8.1 Vectorization (Windows x64)

3. Choose Vectors > Topology > Split polygons/polylines. The Parameters window
opens:

r. Parameters |,i&,|1

@) Split all

Split selected
| Delete cutting polyline
Split only polygons

[ QK ] | Cancel |

e y

Fig. 206. The Parameters window
Set the options for polygon/polyline splitting:

+ Split all — the “cutting” polyline splits all the intersecting vector objects into sev-
eral objects of the same type. New segments are created at the intersections of
the “cutting” polyline (see above);

» Split selected — the “cutting” polyline splits only the intersected vector objects
selected in the item 2;

* In order to delete cutting polyline after the splitting is performed set an appro-
priate checkbox;

* In order to split only polygons when the both types of objects are intersected
by the “cutting” polyline, set an appropriate checkbox.

To cut a polygon using “cutting” polyline in a layer with classifier, perform the following
actions:

@ In order to split a polygon in a layer with classifier, convert an object with C type — polygon, into
L type — polyline (see Section 6.7).

1. Create “cutting” polyline which intersects a polygon.
é In order to cut a polygon, “cutting” polyline should intersect the polygon in two points only,
otherwise the operation will fail.
2. Select “cutting polyline”.

3. Choose Vectors > Topology > Split polygons/polylines (Shift+l) or click the [
button of the Topology toolbar.

As a result “cutting” polyline splits the polygon at two ones, that have the same
code as the original polygon. Once the operation is completed, the polyline is re-
moved.
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11.4.5. Cut out area from polygon

The system provides opportunity to generate a ring-shaped polygons. To create such
a polygon, do the following:

1. Create two polygons, which will be used as internal and external borders of the final
polygon.

c Both polygons, internal and external should be in the same layer.

2. Turn the points editing mode on in the Vectors toolbar. Turn the add to selection
mode on in the Tools toolbar.

3. Select one vertex both on internal and external polygon.

4. Choose Vectors > Topology » Cut out area from polygon. An area corresponding
to internal polygon is subtracted from the main polygon, that allows to create a
resulting ring-shaped polygon. The Cut out area from polygon window opens.

Vectors @ £

PP ENAE Y E e YA AN O]
--- e =

Fig. 207. Cut out area from polygon

Additional segment that is necessary for the system to recognise the resulting polygon as
ring-shaped, is located between two vertices, selected prior to subtracting an area from
initial polygon.
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5. r. Cut out area from pol...u1

Delete inner polygon

Set the height of the hole as
(@ Quter polygon

() Inner polygon

| ok || cance |

L A

Fig. 208. The Question window

* [optional]Clear the Delete inner polygon checkbox to leave the internal polygon
as a separate vector object;

» Set the height of the hole as an outer polygon or as an inner polygon.

Fig. 209. The resulting ring-shaped polygon and the internal polygon as a separate vector object

9‘ If the location of an additional segment between the particular selected vertices is not
significant, the system allows us to subtract an area from the polygon by a simplified

method.

To do this, leaving out paragraphs 2 and 3 select both created polygons and choose
Vectors > Topology » Cut out area from polygon. Hence, the system will automatically
determine the location of the additional segment (between the nearest vertices of the

inner and outer polygons).
11.4.6. Duplication of vector objects

The system allows to create several copies of vector objects which are placed in the
same layer. To do it perform the following:

1. Turn on point editing mode in Vectors toolbar.
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2. Select one vertex of the vector object.

3. Move marker in arbitrary distance to set a position of object copies regarding a
parent object (i.e. a vertex of the first object copy corresponding to the selected
vertex of the parent object will be placed in marker position, next object copy will
be shifted at the same distance at the same direction etc.).

If marker is not moved a position of object copies will be identical to position of the
parent object.

@ The system allows to select identical objects one by one. With double click of mouse or
clicking S key Rectangle selection mode helps to select all the objects.

4. Choose Vectors » Topology » Duplicate object. The Duplicate object window
opens.

- Y
. Duplicate object M

Mumber of copies:

3 =

[ OK. J [ Cancel

L A

Fig. 210. The “Duplicate object” window

5. Set Number of copies and click OK. In the current layer a specified number of
object copies is created. These copies are placed in accordance with marker position
or identically to the parent object if the marker was not moved.

EESR =N N

Fig. 211. Object duplication

6. Turn off Point editing mode.
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Copying several vector objects into existing or new layer is described in “Vector object copying”
chapter.

The system also provides for quick duplication of vector objects. For this, perform the
following:

1. Select one or more vector objects;

2. Holding down Ctrl, Shift, and left mouse button simultaneously move the marker
with the mouse. Copies of the selected vector objects will be created in the new
marker position in the same layer.

11.4.7. Filling the attributes after topological operations

Polygons attributes after topological operations assign to all objects involving in the
operation. Thus attributes could be both filling with default values and left unchanged.

The Set attributes to default value while objects merging/splitting checkbox in the
Settings window on Vectors tab is use to fill attributes with default values (Service »
Settings menu item (Ctrl+Alt+P)).

r "
. Parameters @
4 \Windows [~ vectors
Marker (block scheme)
Marker (stereopair) Default curve smoothing 0,30 .
Zoom Points merging radius in topological operations: 10~ -6 =
Accelerated transforms
Control Streamline step 10,00 = m
Medules Selection
4 Bloc}: scheme V| Select vertices when marker moves over them
aster
Stereo | Move marker to selected vertex
Correlator Snapping radius 5 1 pix
DEM )
TIN Snapping
4 Grid Detection radius 100 1 pix
Path d =
athway mode Snapping radius 10 1 pix
4 |Vectors
Labels Cache for snapping to coordinates 8 T pix
Elevation labels Separate 2D and 3D modes
Point numbers 71 Show labet
Coordinate transform LIRS
Display | show tips
Raster Create o irecincnantalines mads
Orientation
Undo [ set attributes to default values while object merging//splitting
Backups
Auto-save . "
Join polylines and arcs
System
Paths Change Z of aligned object
Enable vertex moving of object selected
Display the displacement vector
When replacing a fragment, replace the nearest fragment
oK ] | Caneel
J

Fig. 212. Vector displaying parameters
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Source attributes change with the following values: text — blank string, float — 0.0, in-
teger — 0. If an object has obligatory attribute with the same name, its value is used as
default value.

Also the system provides possibility to automatic recalculate square of polygons after
editing. To do this use the Vectors > Attributes > Automatic filling layer’s attributes
menu item and the & button of the Vectors toolbar.

% To perform automatic value recalculation the attribute should has the float type.

11.5. Connecting to an object

The system provides possibility to connect to creating vector object to other vector ob-
jects.

To connect creating vector object to existing one, execute the following actions:
1. Start to create a vector object (see Section 5.3).
2. Place marker to vicinity of the existing object vertex.

3. Choose Vectors > Topology » Select nearest vertex (Shift+S). The closest to
marker vertex is selected.

4. Press Insert to create common vertex.
5. Add more vertices to continue creation of vector object.

In order to select nearest vertex of vector object, place marker in vicinity of the object’s
vertex and select Vectors > Topology » Select nearest vertex (Shift+S). The closest
to marker vertex is selected.

To connect creating polyline to existing one, place marker in vicinity of vertex of existing
polyline and select Vectors > Topology » Connect to point (Shift+V) or click the ™
button of the Topology toolbar. After that both polylines will have common vertex, which
editing leads to change of both polylines at the same time (see Section 8.4.1).

To connect creating polyline to existing one in arbitrary vertex of polyline segment,
place marker in vicinity of vertex of existing polyline and select Vectors > Topology >
Connect to point (Shift+V) or click the % button of the Topology toolbar. After that
a new vertex is created at the intersection of the continuation of the polyline created
and existing polyline segment. Vertex editing results in change of both polylines at the
same time (see Section 8.4.1).

In order to continue of created polyline, select this polyline in 2D-window and select
Vectors > Topology » Start from line (Shift+N). After that both polylines will have
common vertex, which editing leads to change of both polylines at the same time.
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11.6. Editing of object fragment

11.6.1. Adding/deleting object fragment

The system allows to edit polyline/polygon fragment (see fragment definition in Sec-
tion 2.1).

To add vertices to existing polyline/polygon fragment, perform the following actions:

1.

2.

4.

5.

Select polyline/polygon in 2D-window.

Place marker in vicinity of vertex of polyline/polygon fragment beginning, to which
it is necessary to add new vertices.

Choose Vectors > Topology > Object fragment > Select start point of fragment
(Alt+S).

Add more vertices to continue creation of polyline/polygon fragment.

Press Esc to complete polyline/polygon fragment editing.

Perform the following actions to delete a fragment of polyline/polygon:

1.

2.

Select polyline/polygon.

Place marker in vicinity of fragment staring vertex and choose Vectors > Topology »
Object fragment » Select start point of fragment (Alt+S).

Place marker in vicinity of fragment end vertex and choose Vectors > Topology »
Select nearest vertex (Shift+S).

Choose Vectors > Topology > Object fragment > Delete line fragment (Alt+D).
After that a polyline/polygon fragment is deleted.

11.6.2. Fragment replacing

Perform the following actions to replace a fragment of existing polyline/polygon:

1.

Place marker to vicinity of base polyline/polygon vertex, that will be used as the
start vertex of fragment to be replaced.

Create a new polyline or polygon to replace base fragment. In the process of creating
specify direction of created polyline/polygon, which coincides with the direction of
the fragment to be replaced.

The last vertex of the new polyline enter to vicinity of vertex of the base polyline/poly-
gon, which is the end of the new fragment.
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4. Choose Vectors » Topology > Object fragment > Replace fragment (Shift+R) or
click the f=3 button of the Topology toolbar. As a result, a new fragment became
a part of base line, all old vertices of base line is deleting.

11.6.3. Segment deleting

Perform the following actions to delete a segment of polyline/polygon:
1. Select vector object in 2D-window.

2. Place marker in the vicinity of the vectorization object.

3. [optional] To delete segment from polygon in a layer with classifier, select in the
classifier window the L code type (polyline) (see Section 6).

4. Choose Vectors > Topology > Delete segment (Shift+D) or click the ] button of
the Topology toolbar. Selected segment is deleted and selected polyline is divided
to a two separate polylines. When segment is deleted from polygon, it convert to a
polyline.

@ If marker is located in the vicinity of the last polyline segment, after deleting remains a
polyline and a separate vertex.

@ When segment is deleted from polygon, it converts to a polyline. In this case when working
with classifier also changes the object code.

@ To delete multiple segments use removing vertices together with adjacent segments
function (Vectors » Topology > Delete selected vertices).

11.6.4. Replacing an object’s segment by an object’s fragment from
another layer

g Segment — a straight line, connecting two neighbor vertices;
Q Fragment — a part of polyline/polygon, a set of adjacent vertices/segments of polyline/polygon;

@ This feature set may be useful when editing cutlines (see the “Orthophotomaps creation” User
Manual).

To replace a polygon/polyline segment located in one vector layer by a polygon/polyline
segment from another layer, perform the following:

1. Create at least two vector layers. The first layer must contain the vector object,
whose segment is to be replaced, and the second one must contain the object
whose fragment will be used as a replacement;

2. Make the second layer editable. Turn on any mode of snapping to points;
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3. Select the first vertex of polygon/polyline fragment to be used as a replacement of
the object’s segment from another layer. Snapping to vertices, align it with the first
vertex of the specified segment;

4. Select the final vertex of polygon/polyline fragment to be used as a replacement.
Snapping to vertices, align it with the second vertex of the segment to be replaced.
Turn off the snapping mode;

5. Make the first layer editable. Turn on the point editing mode. At once, select the
first and second vertices of the segment to be replaced;

6. Choose Vectors » Topology > Object fragment » Replace selected segment by
fragment from other layer. As a result, a copy of the selected object fragment
from another layer is formed in place of the selected vector object segment. The
vector object whose fragment was used as a template remains unchanged.

11.6.5. Reverting vertices order

To change vertices order in polylines or polygons select Vectors » Topology » Object
fragment > Reverse vertices order in line objects. As a result vertices order of selected
polyline/polygon is inverted.

@ This operation is necessary during replacing a polyline/polygon fragment to define necessary
area.

11.6.6. Removing vertices together with adjacent segments

To remove vertex or multiple vertices together with the adjacent segments perform the
following actions:

1. Turn the points editing mode on.
2. Select single or multiple vertices of a polyline or polygon.

3. Choose Vectors > Topology > Delete selected vertices or press Ctri+D. Selected
vertices are removed together with adjacent segments, and edited polyline is divided
into several separate polylines. When vertices with adjacent segments are removed
from a polygon, it is converted into a polyline.
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Vectors (8] | Tools (5]

Fig. 213. Removing vertices (right vector object) and removing vertices together with adjacent
segments (left vector object)

§ To select multiple vertices use objects group selection or turn the add to selection mode
on in the Tools toolbar.

ﬁ In order to remove just polygon/polyline vertex, select the vertex and press Delete (see
points editing mode).

11.7. Creating common border

11.7.1. Continuing along polyline

The system allows to create objects common border using the following ways:
» to marker position;

+ to closest common vertex;

+ to selected vertex.

To create polyline along another polyline up to marker position, perform the following
actions:

1. Start to create a polyline (see Section 5.3.2).
2. Place marker to the arbitrary point close to an existing polyline.

3. Choose Vectors » Topology » Continue along polyline » To marker position
(Shift+A) or click the "# button of the Topology toolbar.

After that the last common vertex of two polylines is created in intersection point of
existing polyline and projection of marker position on this polyline.
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@ If marker is located “far” from a polyline segment, the system creates additional segment
of a new polyline, which is continued to the closest vertex.

4. Press Enter to complete polyline creation. After that a new and existing polylines
have common border with coinciding vertices between the first and the last selected
vertices.

To continue creating polyline along another polyline up to vertex, perform the following
actions:

1. Start to create a polyline (see Section 5.3.2).
2. Place marker to the vicinity of an existing polyline vertex.

3. Choose Vectors > Topology » Select nearest vertex (Shift+S). The closest to
marker vertex is selected.

4. Choose Vectors > Topology » Continue along polyline » To nearest joint vertex
(Shift+F) or click the "# button of the Topology toolbar. The system creates com-
mon part of new and existing polylines.

To continue creating polyline/polygon along other vector objects up to necessary vertex,
perform the following actions:

. Prior to perform the operation set the Vectors » Topology » Topological connectivity mode
checkbox on or click the ™ button of the Topology toolbar (see Section 11.3.1), otherwise, the
operation is performed incorrectly.

1. Start to create a vector object (see Section 5.3).
2. Place marker to the arbitrary point close to an existing polyline.
3. To connect creating polyline to existing one select one the following ways:

« choose Vectors > Topology » Connect to point (Shift+V) or click the "5 button
of the Topology toolbar; both polylines/polygons have common vertex;

« choose Vectors > Topology » Connect to line (Shift+L) or click the % button
of the Topology toolbar; a new vertex is created at the intersection of the con-
tinuation of the polyline created and existing polyline segment.

4. Place marker in vicinity of the last common vertex and choose Vectors > Topology »
Select nearest vertex (Shift+S).

5. Choose Vectors » Topology » Continue along polyline > To selected vertex
(Shift+2Z) or click the "ji button of the Topology additional toolbar. After that a new
and existing polylines/polygons have common external border with coinciding ver-
tices.
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11.7.2. Auto-close along polyline

The system provides a possibility to draw part of one polygon along the other. The
function is used when common fragments of two vectorization objects coincide precisely
(for example, land plots borders).

In order to draw part of one polygon along the other perform the following actions:

1. Place marker in vicinity of vertex of existing polygon, to which it is necessary to
draw a fragment of other polygon.

2. Press Insert to create the first vertex of new polygon. Add vertices to continue
polygon creation.

3. Place marker to the right of vertex of existing polygon, from which it is necessary
to draw a fragment of other polygon.

4. Press Insert to add the last fragment vertex.

5. Choose Vectors » Topology > Auto-close along polyline (Shift+M) or click the
"#] button of the Topology toolbar. After that a new polygon fragment is drawn
along the existing one in boundaries specified by user.

6. Press Enter to complete polygon editing.
11.8. Topology control
11.8.1. Topology verifying

In some cases during vectorization there could be mistakes in the topology of vector
objects. In order to check for errors and fix them, the system provides the opportunity
to find and fix the topology of vector objects.

In order to find and correct topology errors, perform the following actions:

1. Choose Vectors » Topology » Verify topology or click the %% button of the Topo-
logy additional toolbar. The Parameters window opens.
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' !
. Parameters [&J
Selected objects
Metrics: | XY (20) - |
Max, distance: n.001 = m

| Search neighbour points

Search near points
| Search invalid polylines (polygons)
| Search duplicate objects

Wrong coding

Equal vertices

Edaes intersection

Ok ] | Cancel

Fig. 214. Parameters of topology check

2. [optional] In order to verify topology of just selected objects, set the Selected objects
checkbox.

3. In the Metrics list specify whether space is used to search for topology errors: XY
(2D) or XYZ (3D).

4. Setone or several checkboxes to define the following parameters of topology errors
search:

Search neighbour points — is used to search for coinciding adjacent vertices
of object, the distance between them is less than the Max. distance value;

Search near points —is used to search for coinciding vertices, located on different
polylines/polygons or points on objects vertices, the distance between them is
less than the Max. distance value;

Search invalid polylines (polygons) — is used to search for polylines with the
number of vertices less than two and polygons with the number of vertices less
than three;

Search duplicate objects — is used to search for coinciding polylines/polygons
or point objects, which vertices completely coincide;

Wrong coding — is used to search for vector objects, incorrectly linked to a
classifier code.
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7

* Equal vertices — allows to find vertices of objects that consider to vertices of

other objects;

* Edges intersection — finds intersecting segments of objects.

5. Click OK. The system starts operation of topology verifying. In the case of error
detection the system opens the Errors correction window. Each line of the list

contains the error name and XY coordinates of the error.

Searching of Wrong coding objects is applied only for vector layers with classifier.

. Correct topology of selected point

===

x X

Error X Y i o
Invalid line 580619.099 5410820723 503679665
Invalid line 580981.901 5410152 689 501.285373
Invalid line 580944.995 5410200.236 510071892
Invalid line 580624602 5411026690 492 406206
Imvalid line 580863.094 5410605615 504858097
Meighbor points  580737.572 5410175405 503482524
Meighbor points  580647.161 5409922.244 494 458722
Meighbor points  580803.155 5409600.744 491002005
Meighbor points 581215.231 5410112840 528 446201
Meighbor points  580832.257 5410689494 501.236262 -

click.

7. To correct errors perform one of the following actions:

+ “link” vertices using snapping;

Fig. 215. Correction of topology errors

« to correct topological errors of any types click the & button;

+ to correct errors only for selected points click the : button.

A\

To pass to the point in 2D-window select the vertex in the list by mouse double

Equal vertices and Edges intersections could be edited only manually.
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After correction of vector objects topology errors the erroneous vertices are joined
into a single vertex with average coordinates value.

11.8.2. Check polygons relative position errors

The system provides possibility to search and analyse errors of polygons position
(crossings, intersections and presence of “holes”). To find such errors select Vectors »
Topology » Find polygons relative position errors.

If errors are found the system displays the window with information about total amount
of polygons and amount of each error type. For each error type the system creates the
layer — Intersections, Self-intersections or “Holes™— in which polygons are located at
the intersection of initial layer polygons or “holes”.

—

’ PHOTOMOD 8.0.4588 l = | ]
A& 11.07.2024 22:07:18: Total polygons: 2365
- Self intersections: 119
@ Intersections: 2174
F |0 Holes: 184
@ | 1
2

Fig. 216. Information window about topology errors
11.8.3. Search for polygons with coinciding points

The system provides possibility to search for polygons having coinciding points (the
points with exact spatial matching in XY plane). To find such points make polygon layer
editable and choose Vectors > Topology » Find polygons with coinciding points.

The system opens informational window indicating total number of points found (equals
0 if there are no points found). When the search is complete the system creates a new
layer (copy of original polygons layer), containing just coinciding points (but not polygons
themselves).

A new layer has a name like — Common points (Vectors(2)), where “Vectors”-is a name
of initial layer which contains polygons being investigated, and “2” number means that
the layer is a copy of “Vectors” layer. After next searches (for example, after adding

new polygons to “Vectors” layer) resulting layers will have indexes “3”, “4”, etc.
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@ If a point of one polygon is situated on the edge of another polygon (e.g. due to Snapping to
lines or Snapping to medians), it is considered to be common.

@ Vertices of different polygons, the distance between which does not exceed the Points joint
swath for topological operations, are also considered to be common.

@ If XYZ coordinates of two points coincide, only one point is moved to a new layer. If only XY
coordinates of two points coincide, both point are moved to a new layer.

r. Information ﬁﬁ

I.o.l Errors found: 2285

L A

Fig. 217. Information window with the search results
11.9. Editing of polygonal layer

11.9.1. Layers intersection

The system allows to intersect two layers with only polygons. At that polygons and its
parts placed out of polygons of selected layer is deleted from the active vector layer.

& It is used, for example, to edit overlap areas of specified sheets images during processing
satellite images, when polygons created by images edges.

é It is recommended to perform operation of layers intersection prior to operation of layers sub-
tracting.

To intersect a polygonal layer with another one, perform the following actions:
1. Make active the image boundaries layer in the Manager.

2. Select Vectors » Topology > Intersect one polygon layer with another. The In-
tersect with polygon layer window opens.

i N
& Intersect with polygon layer @
Intersect polygons of active layer with polygons of layer:
| Intersections - |
Ok l | Cancel |

Fig. 218. Intersection of one polygon layer with another
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3. Select the layer you want to cross with the active layer.

4. Click OK. After that is deleted polygons from active layer placed out of inactive
polygon layers.

11.9.2. Layers subtraction

The system allows to subtract one polygonal layer from the other. At that polygons and
its parts placed inside of polygons of selected layer is deleted from the active vector
layer.

Perform the following actions to do this:

1. In Manager make active a source layer, from which you want to subtract the other
layer of polygons.

2. Select Vectors > Topology » Subtract one polygon layer from another. The
Subtract polygon layer window opens.

i !
’. Subtract polygon layer I,iE-J
Subtract from polygons of active layer, polygons of layer:
|Intersen:ﬁnns - |
O ] | Cancel |

Fig. 219. Subtracting one polygon layer from another

3. Select a layer to be subtracted from an active layer.

4. Click OK. As a result, from polygons of active layer remove area inside of polygons
on active layer. Polygon edge of active layer creates by polygon edge of selected
layer.

11.9.3. Filling null areas

The system provides for the creation of a polygon that fills a null area bounded by at
least two polygons whose adjacent segments coincide exactly in space.

§ This function may be useful during vectorization of areal objects (for example, a lake and its
shoreline).

To do this, perform the following:

1. Using any of the modes of snapping to vertices, create at least two vector polygons
that limit a null area which is to be filled with a polygon;

249



PHOTOMOD 8.1 Vectorization (Windows x64)

? These polygons can be located within various vector layers and can have various elevations.

Fig. 220. A null area limited by polygons whose adjacent segments coincide exactly in space

2. Move the marker to the null area that is need to be filled;

3. Choose Vectors » Topology > Fill empty area. A new polygon that fills the null
area which is limited by parent polygons is created in the active vector layer.

Fig. 221. A polygon filling a null area

To attach a created polygon filling a null area to the classifier code, perform the following:
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1.  Open or create a vector layer with a classifier containing polygons which limit a null
area to be filled with a polygon;

i & Classifier [polygons_for filling (Vectors)] =@ = [
DEE"G HaE s L aBwmY z 4G SfECBT m| AN |E
BSST % | Codes [Amibutes]
0B Layers vism | Code | Name [ Type | Color | Symbol | Size | Qty | Awr. | -
.® 5ONOT 40100 MEPECEYEHWI P
B rEO,ﬂEEH _____EE_-_
@ MNAPO ® 40330 YACTb YUACT C 1
% TPAHW & 40340 A0M C _ 1.0 1 1
.. TPYHTE B 40350 YACTE AOMA C ] 1.0 0 2
-8 JOPOM ® 40360 MOCTPOAKA | C I 10 0
. 3AM0N - B 40170 TOUKA MAKE P 1 10 0
4 [y > & 1628 NAHAA PA3N L [ ] 1.0 0
Favori‘ts E 3 An1 &l MIAVET ~ TEWe R 1 1n n i

Fig. 222. A null area limited by polygons located in the layer with the Classifier

2. Move the marker to the null area which is need to be filled;
3. Select the appropriate classifier code in the Codes tab in the Classifier window;

4. Choose Vectors » Topology » Fill empty area. A new polygon that fills the null
area which is limited by parent polygons is created in the active vector layer. This
polygon is attached to the selected classifier code.

251



PHOTOMOD 8.1 Vectorization (Windows x64)

@ Classifier [polygons_for filling (Vectors)] [=[=] = |
DEE“|B_IE§I)H)H)H ..E%‘““mmzéﬂEg|ﬂga@ﬁm|Mﬂ.|@
BSZY % | Codes [a |
=% Layers ~ Vision | Code | Name | Type | Color | Symbol | Size | Qty [ Awn | -
- EO”OTH B 40210 BA3WCHAA NI L 1 10 0
-~ B TEOAES B 40110 TOUKA OPIEH P [ ] 10 0
""" ® 1apo ® 40120 OMOPHAATO P I 10 0
""" g ngml ® 40230 HAMPABNEHY L [ 1.0 0
""" & 10PON & 40240 NINHAA O®OF L _ 1.0 0
| & 3anonh & 40100 MEPECEYEHIAI P
<[] . [ o 4030 YyuACTOK ___EE__—
- & 40330 UACTB YHACT C =
Favorites

Fig. 223. A polygon filling a null area with the attached Classifier code

12. Vector data editing using *.x-mdata file
12.1. Vector data conversion to *.x-mdata

The system provides possibility to edit big volumes of vector data using separate file
with the *.x-mdata extension. Data processing is performed step by step in each area
containing points. After the processing is used to build TIN and DEM.

To create vector data file with the *.x-mdata extension, perform the following actions:

1. Select Vectors > Convert objects to x-mdata. The Parameters of conversion
to x-mdata window opens.
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r i
. Parameters of conversion to x-mdata L-Eh,l

Source data folder
rt/aalen_Group/aalen_DMC copy for DSM/Data,| _

Split by pre-regions

Ok ] | Cancel

1% A

Fig. 224. Vector data conversion to x-mdata
2. Inthe Source data folder field select source folder, where to perform vector data
search.

3. [optional] To edit vector data in stereopairs overlap area, set the Split by pre-re-
gions checkbox and select file with pre-regions file in the project.

4. [optional] To change coordinates of grid’s origin, in the Regular splitting paramet-
ers section, in the Origin sub-section input necessary origin coordinates.

5. [optional] To change grid’s step in the Regular splitting parameters section, in
the Step sub-section input grid step value.

6. Click OK. The Save window opens.
7. To the Resource name field input a name of new file with *.x-mdata extension.

8. Click the Save button to complete creation of vector data file.

12.2. *.x-mdata editing

The system provides possibility to process vector data by selected grid sheets or by
stereopairs overlap areas, that contain points.

The Edit x-mdata toolbar is used to edit points.
The toolbar contains the following buttons:
+ [= — allows to open a layer containing data from file with *.x-mdata extension;

« & — allows to close a layer containing data from file with *.x-mdata extension;
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« 2% — allows to open for editing a layer with data from selected grid sheet;

« =F — allows to open for editing a layer with data from a grid sheet, where the marker
is located;

« 2 — allows to open for editing a layer with data from all linear objects, located on
images;

« EF — allows to save changes on selected grid sheet;

« »* _ allows to close selected grid sheet;

To edit vector data file with the *.x-mdata extension, perform the following actions.
1. Select Vectors > x-mdata editor. The Edit x-mdata toolbar shows.

2. Click the = button of the Edit x-mdata toolbar to open a layer containing data from
file with *.x-mdata extension.

3. Selecta grid sheet for further editing of vector data using one of the following ways:

* by mouse click with pressed the Shift key select one of the grid sheets by mouse
and click the 2¥ button of the Edit x-mdata toolbar.

« place the marker to vicinity of a grid sheet and click the (=F button of the Edit x-
mdata toolbar.

4. [optional] To edit linear objects located on images click the & button of the Edit x-
mdata toolbar.

5. Click the ; + button of the Vectors toolbar to enable point objects input mode.

6. Edit consistently points on selected grid sheet.

é If point is input or moved out of the selected grid sheet area, it is automatically saved in
the location where it was input.

7. Click the @ to save changes on a layer with data of selected grid sheet.
8. Click the 4™ to close a layer with data of selected grid sheet;
9. Continue to edit other grid sheets.

10. To end process file click the @ button or close the Edit x-mdata toolbar.
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13. Import of vector objects

13.1. Import from ASCII

The system provides possibility to import vector objects from the ASCII format. In the
ASCII format each vector object is marked as sequence of points with three-dimensional
coordinates.

Files of this format has the *.txt extension. The file contains a sequence of records
delimited by the * symbol. Each entry describes an object that is a point or polyline/poly-
gon. The record consists of object code and a series of lines with three-dimensional
coordinates of vertices separated by a comma. Example of ASCII-file contents:

Road

L 1234 67.4567 67.565 453
L 1245 6.7439 570.860 958
*

Point

L 1257 85.2198 76.459 56

*

In order to import vector objects from the ASCII format perform the following actions:

? If the layer with the classifier was created earlier, when you import the file from ASCII format
layer attributes are preserved.

1. Choose Vectors > Import > ASCIIl. The Import from ASCII format window opens.
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(@ Import from ASCI [ |

C:/Users/guk/Desktop/Mpumepel dalinoe ana PHOTOMOD 2. txt

Use DBEF file
Skip empty text attributes
Swap XY

| Canvert coordinate system

Input coordinate system

Cartesian Right (Local right Cartesian reference system) Select, @

Orientation: right, geo-referencing: local coordinate system

QOutput coordinate system

Cartesian Right (Local right Cartesian reference system) Select, @

Orientation: right, geo-referencing: local coordinate system

[ Ok l | Cancel |

Fig. 225. Import from ASCII

2. [optional] In order to define standard parameters set the Use DBF file , Swap X
Y and Convert coordinate system checkboxes on (see Section 10.5). If all
checkboxes are set on, then when importing first XY-coordinates of points are
swapped, then the system recalculates the coordinates.

é If the Swap XY checkbox is cleared, the vector objects will be imported in the right coordin-

ate system. Otherwise, in the left one.

3. [optional] To prevent creating text attributes without value during import, set the Do
not create empty text attributes checkbox on.

When the Do not create empty text attributes checkbox is on, in some cases a data loss

may OcCcur.

4. Click OK to complete the import operation.
13.2. Import from ASCII-A

The system provides possibility of vector objects import from ASCII-A format. ASCII-A
format contains information about coordinates of vector objects vertices, as well as in-
formation about object type, layer number, attributes name and value.

Files of this format has the *.txt extension. Unlike ASCII, in ASCII-A format object
description contains first lines that describe object type and attributes.

Example of ASCII-A file content:
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L 101113 4
OBJECT NAME=Railway
0BJECT COLOR=3
0BJECT SYMBOL=R
OBJECT SIZE=5.5
545566.505,473671.817,77.850
545715.103,473656.072,78.310
545782.001,473567.393,78.156
545860.428,473463.139,77.974
545847.506,473339.305,77.380
545795.032,473249.288,76.795
545517.126,473365.500,76.318
545269.605,473463.426,75.869
*
The first line of each section has the following structure:
Type, code, layer, N1, N2, where:
» Type - the symbol describing an object type:
o L — polyline;
o P — point;
o C - polygon.
* Code is an object code;
» Layer is a number of layer;
* N1 —the total number of lines where there is a description of the object in the file;

* N2 — the number of lines where there is a description of the object attributes in the
file;
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This is followed by lines with attributes description that have the following form:
Name=Value

Then there are lines with the object vertices coordinates. The sequence of records is
delimited by * symbol.

In order to import vector objects from the ASCII-A format perform the following actions:

1. Choose Vectors » Import > ASCII-A. The Import from ASCII-A format window
opens.

@ Import from ASCI-A e |

C:/Users fguk/Desktop/Mpumepe! dainos ana PHOTOMOD 0. bt

Skip empty text attributes
Swap XY
V| Convert coordinate system

Input coordinate system

Cartesian Right (Local right Cartesian reference system) Select, @

Crientation: right, geo-referencing: local coordinate system

Output coordinate system

Cartesian Right (Local right Cartesian reference system) Select, @’

Crientation: right, geo-referencing: local coordinate system

[ 0K H Cancel |

Fig. 226. Import from ASCII-A

2. [optional] In order to define additional parameters set the Swap X Y and Convert
coordinate system checkboxes on (see Section 10.5). If all checkboxes are set
on, then when importing first XY-coordinates of points are swapped, then the system
recalculates the coordinates.

@ If the Swap XY checkbox is cleared, the vector objects will be imported in the right coordin-

ate system. Otherwise, in the left one.

3. [optional] To prevent creating text attributes with an empty value during import, set
the Do not create empty text attributes checkbox on.

When the Do not create empty text attributes checkbox is on, in some cases a data loss
may OccCur.

4. Click OK to complete the import operation.
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13.3. Import from CSV

The system provides possibility to import vector objects (with their attributes) from the
CSV format. CSV format is exchange text format, which is supported by major applica-
tions in different industries. It is used as exchange format when special geospatial data
formats are not applicable for some reason. In particular, CSV format is often used the
exchange data about orthomosaic splitting into sheets.

CSV-files with *.csv and *. txt extensions are supported.
In order to import vector objects from the CSV format perform the following actions:

1. Choose Vectors > Import » CSV. The Import from CSV format window opens.

. Import from CSV format uﬂléj

Dhimport and export files\EQ_2.tet

/| Determine attribute type by value

All points into one line object

Line template

Mame,¥1,71,%2,¥2,72,%3 - [® @&
Start import from line 2 =
Preview maximum 10 = lines

Automatically validate template [

Available fields Field separators

Name Y3 V| Comma Tab

K pic]

Y1 ¥ Space Semicolon

Fal 4 Other

K2 il

2 Decimal separator Misc

ﬁ @ Point only UTF-8
Point or comma Parse ®' "

Preview file: D:\import and export files\EO_2 bt

Name Y1 71 X2 Y2 72 X3 &
2 IMG_0053.JPG | 548933201236/ 70.1376867944! 237 345586290, 60.0 -21.0 0.6
3 IMG_0054.JPG | 54,59408581055 701412878172, 262,645579624 41.0 -1.8 -26.7 3
4 IMG_0055.JPG | 5459588110961 701405248413, 264545579928 289.0 -0.8 -35.5
5 IMG_0056.JPG | 548946791233 70.1377478146: 263 .545585419,175.0 -4.6 -13.2
6 IMG_0057.JPG | 54.8930471182 701387887938, 272.745584545.139.0 -128 -91

7T ThAG ANSR 1D 54 RO?2AKINR TN 1ANRINTROD 202 RASSRTIAAIART N -182 AN
Drag a field name from the list of available fields on a grid column to assign column type.

Double-click on grid column te cancel assignment.

Skip empty text attributes
Convert coordinate system
Input coordinate system
WG5S 84 / UTM zone 37N (36deg East to 42deg East; northern hemisphere. Djibouti. Egypt. Eritrea. Ethio
Orientation: right, geo-referencing: global coordinate system
Output coerdinate system

WG5 84 / UTM zone 37N (36deg East to 42deq East; northern hemisphere. Djibouti. Egypt. Eritrea. Ethio

Orientation: right, geo-referencing: global coordinate system

[ 0K ] | Cancel

Fig. 227. Import from CSV

2. [optional] To prevent creating text attributes with an empty value during import, set
the Do not create empty text attributes checkbox on.
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3.

When the Do not create empty text attributes checkbox is on, in some cases a data loss
may Occur.

[optional] After import the text type is assigned to all attributes. To assign the float
type for attributes with numeric value (see Section 7.2.1), set the Define attribute
type by value checkbox on.

[optional] To import flight path files set the All points into one line object.

The Line template field displays the list of fields, contained in each line of imported
CSV file:

* Name — object’s name;

* Xn, Yn, Zn, where n — integer number, coordinates of the first and subsequent
vertices of the object;

* * —missed field during import.

All objects are saved using the same template. Each line of a file contains the same
number of fields, that equals to number of fields in template. Lines which does not
correspond to the template, are skipped. To all vertexes two (for 2D objects import)
or three coordinates are specified.

In order to setup active template, perform one of the following actions:

+ drag a field name from the Available fields list to the Preview file table column.
After that the template in the Line template field is changes. To cancel a field
selection, double click the Preview file table column;

» change the template manually in the Line template field. Column type of the
Preview file table change automatically.

The flif button is used to return to default template: Name X Y Z.

The |%] button is used to compare the Line template field with data shown in the
Preview file table.

% The active template corresponds only to lines shown in the Preview file table.
The 4k button is used to replace specified field names by field values taken from
the first line of the Line template table.

ﬁ It is possible to specify any names for vectors import. For import of laser scanning data
the field names from the list of available names are specified.
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@ To import together with vector objects their attributes recorded in a *. csv file together with
object vertex coordinates, click the gk button, and if it is necessary to import only a part of
the attributes, change the line template manually in the Line template field.

To view attributes of vector objects after import, select a vector object and choose Window »
Object attributes.

ﬁ For correct import of vector objects with attributes, the first line of the *.csv file must be
filled in appropriately.
<

Mpumep chavna *.cSv, cogepxalwlero KoopAuMHaTbl TOYEYHbIX BEKTOPHbIX OOBLEKTOB
(nuketoB) n nx atpmbyThl. The example of *. csv file containing coordinates of point vector
objects and their attributes is the following:

X,Y,z,attribute name 1,attribute name 2
738181.714,260663.890,570.127,attribute value 1,attribute value 2
738186.630,260691.792,567.264,attribute value 1,attribute value 2
<,..>

738341.832,260696.672,572.350,attribute value 1,attribute value 2

6. [optional] Set the following additional parameters:

+ Automatically validate template — allows to use template, specified in the first
string of file; set the checkbox off to change template manually;

+ Start import from line — allows to choose file string from which is data import
starts;

* Preview maximum — allows to define number of strings displayed in the Preview
file table (10 by default).

7. Inthe Available fields section select necessary field name and drag it to the table
column. To cancel the field name double click the column header.

8. Inthe Field separators section set on one or multiple checkboxes to specify possible
fields delimiter symbol: comma, space, tab, semicolon or other. Default settings
are comma and space.

9. In the Decimal separator section setup the following parameters:
* Point only — to use point only as a decimal separator in coordinates;

* Point or comma — to use both point and comma as a decimal separator in co-
ordinates.

é If a comma is used as field separator, it is strongly not recommended for the Decimal
separator use point or comma, since objects will import incorrect.
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10. In the Misc section set the following checkboxes:

* UTF-8 - is used to recognize text in Unicode coding;
Unicode — symbols encoding format that allows to provide symbols of almost all written
languages.
» Parse °’ “ —is used to recognize records of projection centers or GCP.
When using this parameter it is highly recommended to check recognizing correctness

after import operation. To do this select any point in 2D-window and check coordinates
values in the Marker window.

11. The Preview file table contains data of imported file. Fields type according to the
template, located in the Line template field, are automatically assigned to the table
columns.

@ The * symbols marks columns with data which is not imported.

12. [optional] To change output objects coordinate system set the Convert coordinate
system checkbox on.

13. Click OK to import.

% Current template saves after import and adds to a drop-down list.

To check for errors the import results of the catalogue of projection centers or GCP
select a point in 2D-window; the Marker window will display point’s coordinates in
DMS format.

13.4. Import from DGN

The system provides possibility of vector objects import from DGN V7 format (other
possible names — ISFF DGN/Intergraph DGN). This is exchange format with *.dgn ex-
tension, that is used in the MicroStation 7.

% The DGN V8 format, that is used in the MicroStation 8 and later versions is not supported. In
this case to perform data exchange it is necessary in MicroStation to convert DGN file to V7
format.

In order to import vector objects from the DGN format perform the following actions:

1. Choose Vectors » Import » DGN. The Import from DGN format window opens.
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i !
@ Import from DGN v |
C:/Usersfguk/Desktop,MpuMepkl dainos ana PHOTOMOD, 2. bt
Multiply all coordinates (in MU) at 1.0 =

|:| Import text as points

[] use DBF file

[ skip empty text attributes

[] swapx Y

Convert coordinate system
Input coordinate system

Cartesian Right (Local right Cartesian reference system) @

Orientation: right, geo-referendng: local coordinate system

Output coordinate system
Cartesian Right (Local right Cartesian reference system) @

Orientation: right, geo-referendng: local coordinate system

Ok, H Cancel I

Fig. 228. Import from DGN

2. [optional] To multiply all coordinates of objects vertices during import specify the
coefficient in the Scale field.

3. Inthe Z for 2D objects section define one of the calculation ways of Z coordinates
of objects vertices:

+ Constant elevation — allows to assign the same value of Z coordinate to all ob-
jects;

+ DEM from resources — allows to select a resource with DEM containing Z values.
Click the _... | button to choose file in active profile resources.

» Use for unknown elevation — allows to fill the empty DEM cells with a predeter-
mined elevation values.
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7.

13.

The

[optional] To convert text objects from DGN file into point objects with label containing
source object text, set the Import text as points checkbox on (see Section 6.5).

[optional] To define additional parameters set the Use DBF file , Swap X Y and
Transform reference system checkboxes on (see Section 10.5). If all checkboxes
are set on, then when importing first XY-coordinates of points are swapped, then
the system recalculates the coordinates.

[optional] To prevent creating text attributes with an empty value during import, set
the Do not create empty text attributes checkbox on.

When the Do not create empty text attributes checkbox is on, in some cases a data loss
may occur.

Click OK to complete the import operation.

5. Import from DXF

system provides possibility of vector objects import from DXF format. This is ex-

change format with *.dxf extension, that is used in the AutoCAD programs.

7

L

The DXF format, that is used in the AutoCAD R15 and later versions is not supported. In this
case to perform data exchange it is necessary in AutoCAD program to convert DXF file to R14
format.

In case when 3D face objects are to be imported from the DXF format, for the user’s convenience
the system provides for immediate building the TIN layer on the base of imported 3D face objects
(Terrain » TIN > Import » DXF — see the “DTM Generation” User Manual).

A user is able to import 3D face objects as a vector layer (see this chapter) and further to build
a TIN on its base (see the “TIN creation” chapter in the “DTM Generation” User Manual).

The settings for both ways of data import from the DXF format are the same, because in any
case, during import, a vector layer will be created at first, which will either be used for automatic
TIN construction, or processed somehow by the user, depending on specific needs.

Note, that 3D face objects can be represented both by triangles and polygons. Their structure
will be completely maintained when importing 3D face objects as a vector layer. When building
a TIN (in every way) polygons will be split into triangles anyway.

In order to import vector objects from the DXF format perform the following actions:

1.

Choose Vectors » Import » DXF. The Import from DXF format window opens:
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(@ Import from DXF =)

C:fUsers/guk/Desktop,Mpumepkl daknoe ana PHOTOMOD 3978, dxf

™

Scale multiplicator 1.00 =

[7] Use blocks as points
Origin

X 0.00
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<
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¥ ]
L1132

0.00 0.00

[7] mport 20 objects

Elevation

3 Constant elevation 0.00
DEM from resources
Z from "Elevation™ code

Elevation from attribute
Attribute name |Elew

IUse for unknown elevations |0.00
Curves interpolation predsion: 0,100 =

[7] use DBF file

|:| Correct wrong text encoding
[7] select layers for impart

[7] skip empty text attributes

[ swap x ¥

Convert coordinate system
Input coordinate system

Cartesian Right (Local right Cartesian reference system) @

Crientation: right, geo-referencng: local coordinate system

Output coordinate system

Cartesian Right (Local right Cartesian reference system) @

Orientation: right, geo-referendng: local coordinate system

[ OK H Cancel ]

Fig. 229. Import from DXF

2. [optional] To multiply all coordinates of objects vertices during import specify the
coefficient in the Scale field;

3. [optional] To import origin of AutoCAD programobjects blocks as point objects, set
the Use blocks as points;

4. In the Point of origin section specify origin of coordinate system;
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10.

[optional] To convert 2D objects from DXF file into 3D objects, set the Import 2D
objects checkbox on. In the Z for 2D objects section define one of the calculation
ways of Z coordinates of objects vertices:

+ Constant elevation — allows to assign the same value of Z coordinate to all ob-
jects;

+ DEM from resources — allows to select a resource with DEM containing Z values.
Click the _... | button to choose file in active profile resources;

+ Z from “Elevation” code — allows to import Z coordinate from “Elevation” code.

The Elevation from attribute checkbox allows to import Z coordinate from attribute,
which name is specified in this field, its default value is Elev.

The Use for unknown elevation field allows to fill the empty elevations with a
predetermined value.

[optional] To define import accuracy of objects, containing curve lines, specify the
Curves interpolation precision parameter value.

é After that the number of curve vertices may change.

[optional] To prevent creating text attributes with an empty value during import, set
the Do not create empty text attributes checkbox on.

When the Do not create empty text attributes checkbox is on, in some cases a data loss
may occur.

[optional] To define additional parameters set the Use DBF file , Swap XY and
Transform reference system checkboxes on (see Section 10.5).

% If the last two checkboxes are set on, then when importing first XY-coordinates of points
are swapped, then the system recalculates the coordinates.

[optional] To correct wrong import of text objects set the Correct wrong text en-
coding checkbox on.

[optional] To import a particular number of layers set the Select layers for import
checkbox on and click the _... | button. The Layers table window is opened, where
the list of layers to be imported is displayed.
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. Layers table l—S__"hJ
& & &
Area
Bridge
Dam
Hydraography
Relief
Road
RootDir
Wall
[ QK ] | Cancel

Fig. 230. Table of layers to be imported
Select layers in the table using one of the following ways:
+ to import all layers, click the g button and click OK;

 to import not all layers, select them and click OK.

ﬁ to invert layers selecting allows the g= button, to unselect all layers — the & button.

11. Click OK to import.

13.6. Import from Generate

The system provides possibility of vector objects import from Generate format. Files
with points have the *.gnp or *.pnt extension, files with polylines — *.gnl or *. lin. This
format is used in the Arcinfo system.

In order to import vector objects from the Generate format perform the following actions:

1. Choose Vectors > Import » Generate. The Import from Generate format window
opens.
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r. Import from Generate li_z-r

C:/Users fguk/Desktop/Mpumepel dainos ana PHOTOMOD 0. bt
Use DEF file

Skip empty text attributes
Swap XY
| Convert coordinate system

Input coordinate system

Cartesian Right (Local right Cartesian reference system) Select, @

Orientation: right, geo-referencing: local coordinate system

Output coordinate system

Cartesian Right (Local right Cartesian reference system) Select, @

Crientation: right, geo-referencing: local coordinate system

[ 0K H Cancel |

Fig. 231. Import from Generate

2. [optional] To define additional parameters set the Use DBF file , Swap X Y and
Transform reference system checkboxes on (see Section 10.5). If all checkboxes
are set on, then when importing first XY-coordinates of points are swapped, then
the system recalculates the coordinates.

% If the Swap XY checkbox is cleared, the vector objects will be imported in the right coordin-
ate system. Otherwise, in the left one.

3. [optional] To prevent creating text attributes with an empty value during import, set
the Do not create empty text attributes checkbox on.

When the Do not create empty text attributes checkbox is on, in some cases a data loss
may occur.

4. Click OK to complete the import operation.

13.7. Import from ATLAS KLT

The system provides possibility to import vector objects from the ATLAS KLT format.
Files of this format has the *.klt extension.

In order to import vector objects from the ATLAS KLT format perform the following ac-
tions:

1. Choose Vectors > Import » ATLAS KLT. The Import from ATLAS KLT format
window opens.
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@ Import from ATLAS KLT (e |

C:/Users fguk/Desktop/Mpumeper dainos ana PHOTOMOD 09, Kt

-

Curves approximation predsion: 0.01 =

As code name use: Code -

Skip empty text attributes
Swap XY
V| Convert coordinate system

Input coordinate system

Cartesian Right (Local right Cartesian reference system) Select, @

Crientation: right, geo-referencing: local coordinate system

Output coordinate system

Cartesian Right (Local right Cartesian reference system) Select, @

Crientation: right, geo-referencing: local coordinate system

[ 0K H Cancel |

Fig. 232. Import from ATLAS KLT format

2. [optional] In order to change the number of vertices in a polyline approximating an
arc, input the Curves approximation precision parameters value.

% The higher the approximation precision, the more vertices in a polyline approximating the
arc/circle.

3. Select in the As a code name use, list, which parameter is recorded as a code
name when importing.

4. [optional] To prevent creating text attributes with an empty value during import, set
the Do not create empty text attributes checkbox on.

When the Do not create empty text attributes checkbox is on, in some cases a data loss
may occur.

5. [optional] In order to define standard parameters set the Swap X Y and Convert
coordinate system checkboxes on (see Section 10.5). If all checkboxes are set
on, then when importing first XY-coordinates of points are swapped, then the system
recalculates the coordinates.

% If the Swap XY checkbox is cleared, the vector objects will be imported in the right coordin-
ate system. Otherwise, in the left one.

6. Click OK to complete the import operation.
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13.8. Import from KML / KMZ

The system provides possibility to import vector objects from the KML and KMZ formats.
Files of this format have the *.kml (*.kmz) extension.

é Import vector objects from KML (KMZ) format does not perform in projects in the local coordinate
system.

In order to import vector objects from the KML (or KMZ) format perform the following
actions:

1. Choose Vectors > Import » KML, KMZ. The Import from KML / KMZ format window
opens.

(@ Import from KML / KMZ [ |

=rzfguk /Desktop Mpumepel dalinoe ana PHOTOMOD01_ Porto di Gicia Tauro.kmz

Skip empty text attributes
Swap XY
V| Convert coordinate system

Input coordinate system

WGES 84 [ UTM 32N (6%8.4.-12%6.4. CeBepHOE Nonywapue) Select, @

Orientation: right, geo-referencing: global coordinate system

Output coordinate system
WGS 34 [ UTM 32N (6%8.4.-12%6.4. CesepHoe nonywapme) Select, @

Orientation: right, geo-referencing: global coordinate system

[ OK ] | Cancel |

Fig. 233. Import from KML / KMZ format

2. [optional] To prevent creating text attributes with an empty value during import, set
the Do not create empty text attributes checkbox on.

When the Do not create empty text attributes checkbox is on, in some cases a data loss
may occur.

3. [optional] In order to define additional parameters set the Swap X Y and Convert
coordinate system checkboxes on (see Section 10.5). If all checkboxes are set
on, then when importing first XY-coordinates of points are swapped, then the system
recalculates the coordinates.

§ If the Swap XY checkbox is cleared, the vector objects will be imported in the right coordin-
ate system. Otherwise, in the left one.

270



PHOTOMOD 8.1 Vectorization (Windows x64)

4. Click OK to complete the import operation.
13.9. Import from LAS

The system provides possibility to import laser scanning point cloud from LAS format.
Files of this format has the *.las extension.

In order to import vector objects from the LAS format perform the following actions:

1. Choose Vectors > Import » LAS. The Import from LAS format window opens.

( . Import from LAS format Iﬁw

C: fUsersfguk/Desktop Mpumepk dainos ana PHOTOMODBlock_1_1_0.las

-

Min X 711582.649 = M MaxX 711707.049 Hom

Min¥ 3513059.254 |5 m MaxY 3517934.851 (= M

Min £ ©85.600 = M MaxZ 791,759 = M
Reflection
Total points: 4033454
Thinning
Grid step  1.000000 m

[ Skip empty text attributes

|:| Swap XY

Convert coordinate system
Input coordinate system

WES 84/ UTM 32N (6°6.0.-12%6.0. CEBEpHOE NONYWaPKHE)

Orientation: right, geo-referendng: global coordinate system

Qutput coordinate system

WGES 84/ UTM 32M (6%8.4.-12%. 4. CeBepHOE NONyLWapKe)

Orientation: right, geo-referencng: global coordinate system

[ Ok ][ Cancel ]

Fig. 234. Import from LAS format

é’ In the MinX, MinY, MinZ, MaxX, MaxY, MaxZ fields the system displays coordinates range
of points that are contained in imported LAS file.
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2. Inthe Reflection list set a filter for the LIDAR points which are supposed to be im-
ported in accordance with number of reflected pulses per one point (see the “LIDAR
Data processing” User Manual);

@ The total points number to be imported according to the user settings is displayed in the
appropriate field.

3. Input the Thinning: grid step value (in meters) to reduce the amount of data to be
imported during the import process.

@ Point are thinned in such a way that the distance between them is not less than a predeter-
mined grid step.
4. [optional] To prevent creating text attributes with an empty value during import, set
the Do not create empty text attributes checkbox on.
When the Do not create empty text attributes checkbox is on, in some cases a data loss

may occur.

5. [optional] In order to define additional parameters set the Swap X Y and Convert
coordinate system checkboxes on (see Section 10.5). If all checkboxes are set
on, then when importing first XY-coordinates of points are swapped, then the system
recalculates the coordinates.

é If the Swap XY checkbox is cleared, the vector objects will be imported in the right coordin-
ate system. Otherwise, in the left one.

6. Click OK to complete the import operation.

13.10. Import from LIG

The system provides possibility to import vector objects from the LIG format. Files of
this format has the *.1ig extension.

In order to import vector objects from the LIG format perform the following actions:

1. Choose Vectors > Import > LIG. The Import from LIG format window opens.

272


lidar.pdf
lidar.pdf

PHOTOMOD 8.1 Vectorization (Windows x64)

W o from L1G (e |

C:/Users/guk/Desktop/Mpumeper dainos ana PHOTOMOD /2. lig

Use DEF file
Skip empty text attributes
Swap XY
| Convert coordinate system
Input coordinate system

WGS 84 [ UTM 32M (5°8.4.-12°8.4. CEBEpHOE NONyLWap1e) Select, @

Orientation: right, geo-referencing: global coordinate system

Output coordinate system
WIES 84 [ UTM 320 (6%8.4.-12%.4. CeBepHOE Nonywapue) Select, @

Crientation: right, geo-referencing: global coordinate system

[ 0K H Cancel |

Fig. 235. Import from LIG format

2. [optional] To define additional parameters set the Use DBF file , Swap X Y and
Transform reference system checkboxes on (see Section 10.5). If all checkboxes
are set on, then when importing first XY-coordinates of points are swapped, then
the system recalculates the coordinates.

% If the Swap XY checkbox is cleared, the vector objects will be imported in the right coordin-

ate system. Otherwise, in the left one.

3. [optional] To prevent creating text attributes with an empty value during import, set
the Do not create empty text attributes checkbox on.

When the Do not create empty text attributes checkbox is on, in some cases a data loss
may occur.

4. Click OK to complete the import operation.

13.11. Import from MIF / MID

The system provides possibility to import vector objects from the MIF/MID format. This
is exchange format with *.mif extension, that is used in theMapinfosystem.

é When importing from MIF/MID format it is not allowed to use underscores in attributes names.
Replace all underscore characters in attribute names with spaces.

In order to import vector objects from the MIF/MID format perform the following actions:
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1. Choose Vectors > Import > MIF/MID. The Import from MIF/MID format window
opens.

@ Import from MIF/MID =)

C:/Users fguk/Desktop/Mpumepel dainos ana PHOTOMOD 0. bt
£ for 2D objects

@ Constant elevation 0.00 =

DEM from resources

Elevation from attribute

Use numeric sympols only

|F

Use for unknown elevations  0.00
| Skip objects
Elevation 0.00 =

Import text as points

Import points only
Skip empty text attributes
Swap XY

| Convert coordinate system

Input coordinate system

®

WGS 84 [ UTM 32M (5°8.4.-12°8.4. CEBEpHOE NONyLWap1e) Select,
Orientation: right, geo-referencing: global coordinate system
Output coordinate system

WIES 84 [ UTM 320 (6%8.4.-12%.4. CeBepHOE Nonywapue) Select, @

Crientation: right, geo-referencing: global coordinate system

Fig. 236. Import from MIF/MID format

2. Inthe Z for 2D objects section define one of the calculation ways of Z coordinates
of objects vertices:

» Constant elevation — allows to assign the same value of Z coordinate to all ob-
jects;

+ DEM from resources — allows to select a resource with DEM containing Z values.
To open necessary resource click the & button. To fill the empty DEM cells with
a predetermined elevation values, change the Use for unknown elevation
parameter value.

» Elevation from attribute — allows to import Z coordinate from attribute, which
name is specified in this field, its default value is Z. In order to remove all symbols
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from an attribute except for digits, point, comma and minus, set the Use numeric
symbols only checkbox;

3. [optional] In order to exclude objects with specified elevation, set the Skip objects
checkbox on and input necessary elevation value.

4. [optional] To convert text objects from MIF/MID file into point objects with label
containing source object text, set the Import text as points checkbox on (see
Section 6.5).

5. [optional] To split linear objects into separate points, set the Import points only
checkbox on.

6. [optional] To prevent creating text attributes with an empty value during import, set
the Do not create empty text attributes checkbox on.

When the Do not create empty text attributes checkbox is on, in some cases a data loss
may Occur.

7. [optional] In order to define standard parameters set the Swap X Y and Convert
coordinate system checkboxes on (see Section 10.5). If all checkboxes are set
on, then when importing first XY-coordinates of points are swapped, then the system
recalculates the coordinates.

% If the Swap XY checkbox is cleared, the vector objects will be imported in the right coordin-
ate system. Otherwise, in the left one.

8. Click OK to complete the import operation.

13.12. Import from Shape

The system provides possibility to import vector objects from the Shape format. This is
exchange format with *.shp extension, that is used in Arcinfo softwaresystem.

The Shape format consists of three files with the same names and following extensions:

* *.shp —main file, that contains information about objects; one Shapefile stores objects
of the only one type — points, polylines or polygons;

+ *.shx — additional index file, that contains information about objects position in the
main file; it is used to speed up access to the content of the Shapefile;

+ *.dbf — additional file containing the table of DBF database (see Section 13.14).

In order to import vector objects from the Shape format perform the following actions:
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1. Choose Vectors > Import > Shape. The Import from Shape window opens.

. Import from Shape
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Fig. 237. Import from SHP format

2. [optional] To use file with attribute information about objects, and to assign vector
objects to classifier, the Use DBF file checkbox is on by default (see Section 13.14).

* Choose the DBF file encoding — Win or UTF-8.

7

The UTF-8 encoding may be necessary for proper export of Cyrillic symbols.

3. [optional] To use file with information about location of objects, stored in the file
with *.shp extension, the Use SHX file checkbox is on by default.

4. [optional] To convert 2D objects from DXF file into 3D objects, set the Import 2D
objects checkbox on.
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8.

In the Z for 2D objects section define one of the calculation ways of Z coordinates
of objects vertices:

+ Constant elevation — allows to assign the same value of Z coordinate to all ob-
jects;

+ DEM from resources — allows to select a resource with DEM containing Z values.
To open necessary resource click the | button. To fill the empty DEM cells with
a predetermined elevation values, change the Use for unknown elevation
parameter value;

* Elevation from attribute — allows to import Z coordinate from attribute, which
name is specified in this field, its default value is Z. In order to remove all symbols
from an attribute except for digits, point, comma and minus, set the Use numeric
symbols only checkbox.

In the Base attributes section specify code names in the DBF file:
* Code — the CODE by default;

+ Code name — CODENAME by default;

* Layer name — LAYER by default;

[optional] To prevent creating text attributes with an empty value during import, set
the Do not create empty text attributes checkbox on.

When the Do not create empty text attributes checkbox is on, in some cases a data loss
may occur.

[optional] In order to define standard parameters set the Swap X Y and Convert
coordinate system checkboxes on (see Section 10.5). If all checkboxes are set
on, then when importing first XY-coordinates of points are swapped, then the system
recalculates the coordinates.

é If the Swap XY checkbox is cleared, the vector objects will be imported in the right coordin-
ate system. Otherwise, in the left one.

Click OK to complete the import operation.

13.13. Import from Panorama

The system provides possibility of vector objects import from Panorama format. This is
exchange format with *.sit and *.map extensions, that is used in GIS Map system.

In order to import vector objects from Panorama format perform the following actions:
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1.

Select Vectors > Import > Panorama. The Import from Panorama format window
opens.

. Import from Pancrama/SXF li_E-J

C:/Users /guk/Desktop/Mpumepel dainos ana PHOTOMOD 3. sxf

Import resource file

Impaort 2D objects

Elevation

4|k

@ Constant elevation 0.00
DEM from resources

Use for unknown elevations 0.00 =

Path to REC file )

Skip empty text attributes
Swap XY
V| Convert coordinate system

Input coordinate system

®

WG5S 34 [ UTM 32N (6%8.4.-12%8.4. CEBEPHOE NONYLEPWE)

Orientation: right, geo-referencing: global coordinate system

Qutput coordinate system

WGS 84 [ UTM 32M (5°%8.4.-12%8.4. CeBepHoe Nonylwapie) Select, @

Orientation: right, geo-referencing: global coordinate system

[ QK H Cancel |

Fig. 238. Import from Panorama format

In order to convert the lNMaHopama classifier into inner classifier of the system, the
Import classifier checkbox is on by default (see Section 6.4).

[optional] To convert 2D objects from DXF file into 3D objects, set the Import 2D
objects checkbox on. In the Z for 2D objects section define one of the calculation
ways of Z coordinates of objects vertices:

» Constant elevation — allows to assign the same value of Z coordinate to all ob-
jects;

+ DEM from resources — allows to select a resource with DEM containing Z values.
To open necessary resource click the | button. To fill the empty DEM cells with
a predetermined elevation values, change the Use for unknown elevation
parameter value. The default value is 0.0.

[optional] To prevent creating text attributes with an empty value during import, set
the Do not create empty text attributes checkbox on.
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When the Do not create empty text attributes checkbox is on, in some cases a data loss
may Occur.

5. [optional] In order to define standard parameters set the Swap X Y and Convert
coordinate system checkboxes on (see Section 10.5). If all checkboxes are set
on, then when importing first XY-coordinates of points are swapped, then the system
recalculates the coordinates.

§ If the Swap XY checkbox is cleared, the vector objects will be imported in the right coordin-
ate system. Otherwise, in the left one.

6. Click OK to complete the import operation.

The system provides possibility to import just point objects and linear object vertices
without attribute from Panorama format.

Perform the following actions to do this:

1. Choose Vectors > Import > Panorama (points only). The Import from Panorama
format window opens.

. Import from Panorama l&J

D:\import and export files\111 sit

Skip empty text attributes
Swap XY
Convert coordinate system
Input coordinate system
WG584 / UTM zone 37N (36deg East to 42deg East; northern hemis
Orientation: right, geo-referencing: global coordinate system
Output coerdinate system

WG5 84 / UTM zone 37N (36deg East to 42deg East; northern hemis

Orientation: right, geo-referencing: global coordinate system

[ OK ] ‘ Cancel ‘

Fig. 239. Import points from Panorama format

2. [optional] To prevent creating text attributes with an empty value during import, set
the Do not create empty text attributes checkbox on.

When the Do not create empty text attributes checkbox is on, in some cases a data loss
may occur.

3. [optional] In order to define additional parameters set the Swap X Y and Convert
coordinate system checkboxes on (see Section 10.5). If all checkboxes are set
on, then when importing first XY-coordinates of points are swapped, then the system
recalculates the coordinates.
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@ If the Swap XY checkbox is cleared, the vector objects will be imported in the right coordin-
ate system. Otherwise, in the left one.

4. Click OK to complete the import operation.

13.14. Using DBF file

The system allows to use DBF file if it is near to imported file. This is a file with the *.dbf
extension contains dBASE database table and is used as a file with attribute information
about objects, as well as for assigning vector objects to classifier.

Set the Use DBF checkbox on in the import settings window to use DBF file.

The database fields contain attribute information. In the first four fields DBF file stores
the following information:

* NAME — a unique object name;

* CODE - a code in classifier, to which the object is assigned;

+ CODENAME - a code name in classifier, to which the object is assigned,;

* LAYER - the layer name in the classifier, in which there is the object’s code.

Starting with the fifth field in the file are stored both basic and additional attributes of
vector objects.

When importing objects with the classifier from external exchange formats the objects
are attached to the current codes of classifier. To do this the system uses the information
stored in the main importing file or in DBF file. Objects are assigned to classifier during
import in the following way:

1. From the main importing file or from DBF file the system reads code name, code,
object type (point, polyline, polygon) and layer name.

2. The system checks a presence of code in loaded classifier. If the code is present
in the classifier, the object is assigned to it automatically. If there is no such code
in the classifier, the system creates a new layer and imported objects are assigned
to it.

13.15. Batch import

The system allows to perform import of multiple files with vector objects of any format.

To perform import of triangulation points catalogue perform the following actions:
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1. Choose Vectors > Import > necessary_fomat. The system opens the window used
to select files to be imported.

2. To choose files for import, click on them while the Shift key pressed.

3. Click the Open button. The import parameters window opens (more details on the
import options see in the relevant paragraphs of this section).

4. Setup import parameters and click OK. The Loading window opens.

. Loading

=

ersections contains data. 3 files selected to load

Clear layer and load all files into it

Lead all inte one new layer

Create separate layer for each file

Load all layers into Intersections layer without unloading existing data |

Batch import

Close

Fig. 240. Ways of multiple file loading

5. Select one of the following ways of imported layers loading:

7

Clear layer and load all files into it — vector data of active layer is replaced by

data from loading layers;

Load all into one new layer — vector data is loaded to a single new vector layer;

Create separate layer for each file — vector data of each file are loaded to

separate layers;

Load all layers into Vectors without unloading existing data — during loading
vector data is added to objects of active vector layer.

Batch import — vector data is imported to system’s internal format and are saved
to the selected folder in active profile resources. At that the data are not loaded
in the project and new layers are not created.

display.

13.16. Import from GDAL formats

If there are no loaded layers in the project, the Clear layer and load all files into it and
Load all layers into Vectors without unloading existing data loading options does not

The system provides possibility to import vector objects from formats supported by
GDAL library. To perform such import choose Vectors » Import » GDAL formats.
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13.16.1. Import from GeoPDF

The system provides possibility to import vector objects from the GeoPDF format (if
such data is available in current GeoPDF file). Files of this format has the *.pdf exten-
sion.

@ The system allows to load GeoPDF file as a georeferenced raster file (see the “Georeferenced
external data” chapter of the “Aerial triangulation” User Manual).

In order to import vector objects from the GeoPDF format perform the following actions:
1. Create empty vector layer with classifier.

2. Choose Vectors » Import » GDAL formats.... The Import from GDAL formats
window opens.

’. Import from GDAL formats I&

ChUsers\guldDesktoph GeoPDF\FL_Tsala Apopka_348896_1895_62500_geo.pdf

[ Skip ermpty text attributes
[ Swap X ¥

[7] Convert coordinate system

Input coordinate system
Cartesian Right (Local right Cartesian reference system) Celect
Orientaticn: right, geo-referencing: local coordinate system

Output coordinate system

Cartesian Right (Local right Cartesian reference system) Celect

Orientation: right, geo-referencing: local coordinate system

Ok ] I Cancel

Fig. 241. Import from GeoPDF

3. [optional] In order to define standard parameters set the Swap X Y and Convert
coordinate system checkboxes on (see Section 10.5). If all checkboxes are set
on, then when importing first XY-coordinates of points are swapped, then the system
recalculates the coordinates.

é If the Swap XY checkbox is cleared, the vector objects will be imported in the right coordin-
ate system. Otherwise, in the left one.
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4. [optional] To prevent creating text attributes without value during import, set the Do
not create empty text attributes checkbox on.

When the Do not create empty text attributes checkbox is on, in some cases a data loss
may occur.

5. Click OK to complete the import operation.
14. Export of vector objects

14.1. Export to ASCII

The system provides possibility of export to ASCII format. In ASCII format, each vector
object is referred to as a sequence of vertices with three-dimensional coordinates. A
description of the file format see in the Section 13.1.

In order to export vector objects to ASCII format perform the following actions:

1. Select Vectors > Export > ASCII. The Export to ASCII window opens.

& Export to ASCI =

C:/Usersfguk/DesktopMpumepkr dainos ana PHOTOMOD 0, bt
Export selected only
Export attributes to DEF

Convert coordinate system

Input coordinate system

WGES 84 /UTM 32M (6%8.4.-12%. 4. CeBepHOE NoONYWapHe) Select @
Orientation: right, geo-referendng: global coordinate system
Output coordinate system
WGES 84 /UTM 32M (6°8.4.-12%. 4. CeBepHoE NoNyWapHe) Select @
Orientation: right, geo-referencdng: global coordinate syste

Swap XY

Fig. 242. Export to ASCII format

2. [optional] In order to export just selected points, set the Export selected only
checkbox.
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3. [optional] To create file with attribute information about objects, and to assign vector
objects to classifier, set the Export attributes to DBF file checkbox on.

4. [optional] In order to define standard parameters set the Swap X Y and Convert
coordinate system checkboxes on (see Section 10.5).

@ If the Swap XY checkbox is set off, the vector objects will be exported in the right coordinate

system. Otherwise, in the left one.

5. Click OK to complete the export operation.

14.2. Export to ASCII-A

The system provides possibility of vector objects export to ASCII-A format. ASCII-A
format contains information about coordinates of vector objects vertices, as well as in-
formation about object type, layer number, attributes name and value. A description of
the file format see in the Section 13.2.

In order to export vector objects to ASCII-A format perform the following actions:

1. Choose Vectors > Export» ASCII-A. The Export to ASCII-A format window opens.

€ Export to ASCI-4, ==

C:/Usersfguk/Desktop,MpuMepel daiinos ana PHOTOMOD 0, bt
Export selected only
Export empty attribute values
Convert coordinate system

Input coordinate system

WES 84 /UTM 32N (6%.4.-12%.4. CesepHoe NonywWwape) Select @
Orientation: right, geo-referendng: global coordinate syste
Qutput coordinate system
WGES 84 /UTM 32M (6%8.4.-12%. 4. CeBepHOE NONYWapHE, Select @
Orientation: right, geo-referendng: global coordinate syste
Swap XY
Ok ] | Cancel

Fig. 243. Export to ASCII-A format

2. [optional] In order to export just selected points, set the Export selected only
checkbox.
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3. [optional] In order to export data without attribute information, set the Export empty
attribute values checkbox.

4. [optional] In order to define standard parameters set the Swap X Y and Convert
coordinate system checkboxes on (see Section 10.5).

@ If the Swap XY checkbox is set off, the vector objects will be exported in the right coordinate

system. Otherwise, in the left one.

5. Click OK to complete the export operation.

14.3. Export to CSV

The system provides possibility of export to CSV format. CSV format is exchange text
format with csv extension, which is supported by major applications in different industries.
It is used as exchange format when special geospatial data formats are not applicable
for some reason. In particular, CSV format is often used the exchange data about or-
thomosaic splitting into sheets.

In order to export vector objects to CSV format perform the following actions:

1. Select Vectors » Export > CSV. The Export to CSV window opens.
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i '
. Export to C5V format ﬁ
C:fUsers fguk/Desktop,MpumMepkl dalinoe anA PHOTOMOD, backupftest_attributes. cav
[7] Export selected only
Export
@ Linear objects Save maximum of 4 +| points
() Point objects
1 All points
Line template
X1,Y1,Z1,%2,Y2,Z2,%3,Y3,23,X4,Y4,74 -
[ First line with field names
Available fields 5 Used fields
X - X1 *
v1 2 ¥l I
7 < |z
Y2 1 ‘ﬁ‘ Y2 |
il 3 Z2 3
b E] & 3
NE 3
P ]
x4 B x4 B
¥4 - 4 -
Decdmal separator Enclose in quotes Field separator
@ Paint ) Auto @ Comma () Tabulation
") Comma i@ Al text fields (0) space () Semicolon
) Al fields () Other
|:| Convert coordinate system
Input coordinate system
WGES 84 /UTM 32M (6°8.4.-12%6.4. CeBepHOE NONyLUEpHE) Select, '@\
Crientation: right, geo-referendng: global coordinate system
Output coordinate system
WGES 84 /LM 32M (6°%8.40.-12%8.4. CEBEPHOE NONYLWSPKME) Select, @
Crientation: right, geo-referendng: global coordinate system
[ Ok J [ Cancel ]

Fig. 244. Export to CSV format

2. [optional] In order to export selected points only, set the Export selected only
checkbox on.
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3. [optional] In order to export one type of objects, in the Export section choose objects
type:

» Linear objects — only polylines is exported. In the Save maximum of .. points
field is defined maximum number of vertices of polyline for export. The other
vertices are not export and polyline is cutting out;

* Point objects — only points is exported;
» All points — both points and vertices are exported.

4. The Line template field displays the list of fields of each line of CSV-file. Define
the following additional parameters of data in file:

@ The i button allows to clear the Line template field.

» First line with field names — allows to add Line template in the first line of file;

+ Maximum decimal places — allows to specify number of decimal places in points
coordinates.

% Line template could be specified manually or with Available/Used fields lists.

5. In the Available fields list are displayed names of fields could be used as line
template for export. In the Used fields is displayed list of fields that are used as
Line template. Prepare template with the following buttons:

+ (= — allows to add selected Available field to the Used fields list (add to the
template);

» == — allows to add all Available fields to a line template;

+ = — allows to remove selected field name from the Used fields list;
+ =z — allows to remove all fields names from this list;

« 4k — allows to move down field selected in the Used fields list;

« 4 — allows to move up field selected in the Used fields list.

6. Inthe Decimal separator section choose, point or comma to be used to separate
coordinates.

7. [optional] In order to limit required parts of exported list of coordinates by quotes,
in the Enclose in quotes section choose one of the following options:
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» Auto — fields limit by quotes automatically;
+ All text fields — only text fields are limited by quotes;

+ All fields — allows to limit by quotes each field, which is located in the exported
file.

8. In the Field separator section choose, what is used to separate fields: comma,
space, tab, semicolon or other.

é If a comma is used as field separator, it is strongly not recommended for the Decimal
separator use point or comma, since objects will export incorrect.

9. |[optional] To define standard parameters set the Transform reference system
checkbox on (see Section 10.5.2).

10. Click OK to complete the export operation.

14.4. Export to DGN

The system provides possibility of export to DGN V7 format (another names are ISFF
DGN/Intergraph DGN). This is exchange format with *.dgn extension, that is used in
MicroStation 7.

\ﬂj, The DGN V8 format, that is used in theMicroStation 8 and later versions is not supported. In
this case to perform data exchange it is necessary inMicroStation to convert DGN file to V7
format. Exported file in DGN V7 format could be opened in anyMicroStation version, however,

format features imposes restrictions on the completeness of exported data.

The file of this format contains code, code name, object type, and object attributes.
Coordinates in DGN format are presented as main units Position Units in the range
from 0 to 4*1079 . For floating-point numbers the additional units Sub Units (SU) and
Master Units (MU) are used.

& The ratio of measurement units:

15U

N Pos.units
1MU=MSU,

where N and M -- integer numbers, stored as constants in DGN file.
In order to export vector objects to DGN format perform the following actions:

1. Select Vectors » Export » DGN. The Export to DGN window opens.
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e

'. Export to DGM

Export selected only
Linear units
Identifications (2 symbols max.):

Master Units (MU) mu

Sub Units (5L su

Origin
Auto selection
X

-
-

0.00

Export attributes to DEF

As layer use |Layer hi

Export "Label” attribute
Convert coordinate system

Input coordinate system

Ciriartstimee rink
Urientatg

Output coordinate system

WiES @ TT
virkao o5 U

Ciriamtstor -
Urientato

0
]

Swap XY

C:Usersfguk/DesktopMpumepel dalinoe ana PHOTOMOD/2.dan

0.00

Units ratio:

MU/SU: 1000 5
SU/Dgn Pos. Units: 100 |5

Y z
%+ 0.00 =
Selec @
nyLape) Selec @

oordinate system
OK l | Cancel

-

Fig. 245. Export to DGN format

[optional] In order to export just selected points, set the Export selected only

[optional] To rename Sub Units (SU) and Master Units (MU), in the Linear units

section input notations containing two symbols. To change the ratio of units, change

In the Point of origin section specify origin coordinates. The Auto selection

checkbox allows to define coordinate system origin as as the center of parallelepiped

2.
checkbox.
3.
the MU/SU or SU/DGN Pos. parameters Units.
4.
circumscribing all available objects.
5.

[optional] To create file with attribute information about objects, and to assign vector

objects to classifier, set the Export attributes to DBF file checkbox on.
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9.

In order to specify what to assign vector objects after export, select the As layer
use: parameter in the list.

% By default the system assigns objects using layer name. After that the system creates file
with *. vl extension, which contains selected layers names.

? The system allows to use assignment by object code or by the code name.

[optional] In order to export special objects labels (see Section 6.5), set the Export
Label attribute checkbox.

[optional] To define standard parameters set the Swap X Y and Transform refer-
ence system checkboxes on (see Section 10.5).

é If the Swap XY checkbox is set off, the vector objects will be exported in the right coordinate
system. Otherwise, in the left one.

Click OK to complete the export operation.

14.5. Export to DXF

The

system provides possibility of export to DXF format. This is exchange format with

*.dxf extension, that is used in the AutoCAD program.

7

7

7

The DXF format, that is used in the AutoCAD R15 and later versions is not supported. In this
case to perform data exchange it is necessary in AutoCAD program to convert DXF file to R14
format. During vector objects export the system also preserves the selected line style used
when exported DXF file is opened in the AutoCAD program.

Vector objects are exported as 3D-polylines by default. For the convenience of AutoCad users,
the system also provides for the export of vector objects as 2D-polylines (see Save as 2D
checkbox below).

When exporting vector objects as 2D polylines, the system allows one to export Z to “Elevation”
attribute. If the appropriate checkbox is set, a value of the first polyline/polygon vertex elevation
is exported into the Elevation attribute. Thus, this function is for the export of vector object el-
evation values in case when all their vertices have the same elevation, e.g. contours.

In order to export vector objects to DXF format perform the following actions:

1.

2.

Load a vector layer with points.

Select Vectors » Export » DXF. The Export to DXF format window opens.
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' Export to DXF @
C:/Users fguk/Desktop/Mpumeper dainos ana PHOTOMOD/S. dxf
Export selected only
Save as 2D
Export Z to "Elevation” attribute
Export attributes to DEF
Export attribute "Label™

Use as file name: Layer -
Attribute -
Labels for polygons Labels

Create used layers only

Convert line objects to Polygon Mesh

Lonvert oDjects with atinbutes

Default base elevation: 0.00

Convert coordinate system

Input coordinate system

VRS @A P TR 2R (80 o A0 1 o P ! 1
1.\:35—_ LT 22N (678 4.-1.78.4. LEBEPHOE NonylwapWe) Select @

Fig. 246. Export to DXF format

3. Specify the following parameters of export:
» Export selected only — allows to export only selected object from active layer;

+ Export attributes to DBF — allows to create file with with attribute information
about objects, as well as for assigning vector objects to classifier;

Export attribute “Label” — allows to export special object labels (see Section 6.5);

» Use as layer — allows to choose what to assign vector objects after export;

% By default the system assigns objects using layer name. After that the system creates
file with *.1v1 extension, which contains selected layers names.

ﬁ The system allows to use assignment by object code or by the code name. When vector
objects are assigned by attribute value, select the Label name in the Attribute list.
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» Create used layers only — allows to export only classifier layers with vector ob-

jects;

» Labels for polygons — allows to export labels for polygons in a separate layer.
Click the Labels button to specify parameters of labels export.

The Labels for polygons window opens.

L

. Labels for polygons I,ﬁr

1.00 =

Font size:

Layer name Labels
Code

Code name
Attribute

abel

Ok ] | Cancel

A

Fig. 247. Parameters polygon labels

Define the following parameters:

o Font size of labels;

o Layer name — name of layer with labels;

o Code, Code name or Attribute — allows to specify layer name (see Sec-

tion 7.3.1).

4. [optional] To convert linear objects to polyhedral object (see example below) set
the Convert linear objects to Polygon Mesh checkbox on and specify, what objects

to convert:

» Convert objects with attributes — used to convert linear objects with attribute;

+ Convert all — used to convert all linear objects; to set the orthogonal projection
of a linear object on a horizontal plane, change the Default base elevation.

5. [Optional] To export vector objects without elevations, set the Save as 2D checkbox.

6. [optional] In order to define additional parameters set the Swap X Y and Convert

coordinate system checkboxes on (see Section 10.5).

7. Click OK to complete the export operation.
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There is an example of export vector objects to DXF format with converting them to a

polyhedral object.

1. Load a Roofs layer with vector objects (roofs) to export in DXF format with converting

on polyhedral object.

P
€ 1: 5:2 Block scheme

Ot B e |[@Hd) A A®WE X 52 -

Vectors

R VYRR

EEES

3

& >

& > [0 --Blockscheme

Qui

[
o 0 © C [ C e Enm &

d

|49?03945??238 m; 6444448608891 m; 129.018258 m | Cartesian Left

Fig. 248. Source vector layer

2. Inthe Export to DXF window set the set the Convert linear objects to Polygon

Mesh checkbox on and export objects to a DXF file.
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. Export to DXF @
C:/Usersfguk/Desktop,/MpuMepkl dainos ona PHOTOMOD S, dxf
Export selected only
[] save as 2D
Export Z to "Elevation™ attribute
[] Export attributes to DBF
Export attribute "Label”

Lze as file name: [Layer v]
Attribute [ - |
[ Labels for polygons [ Labels ]

Create used layers only
Convert line abjects to Polygon Mesh
(71 Convert objects with atiributes

@ Convert all

Ak

Default base elevation: Q.00

|:| Convert coordinate system

Input coordinate system

WES 84/ UTM 32M (6%8.4.-12%. 4. CeBEpHOE NONYLWapHE) Select {P
Orientation: right, geo-referendng: global coordinate system

Output coordinate system

WGES 84/ UTM 32M (6%8.4.-12%. 4. CeBEpHOE NONYLWEDKE) Select @

Orientation: right, geo-referendng: global coordinate system

|:| Swap XY

K ] [ Cancel

Fig. 249. Parameters of export to DXF format

3. Open exported file in the Autodesk program. Roofs are displayed as polyhedral
objects.
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Fig. 250. Roofs, displayed as polyhedral objects
The system also provides possibility of batch vector objects export to DXF format. Batch
export is used to export classifier layer to separate files.
Perform the following actions to do this:
1. Open a layer with classifier.

2. Select Vectors » Batch export by classifier » DXF. The Browse for folder window
opens.

3. Select folder to export files.

4. Click OK. The Export to DXF window opens.
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. Export to DXF @
C:\UserslgukiDesktoptMpuMepkl dainoe ona PHOTOMOD backup
[] Export selected only
[] save as 2D
Export Z to "Elevation™ attribute
[] Export attributes to DBF
[] Export attribute "Label™

Use as layer: [Layer - ]

Attribute [ - |

[ Labels for polygons [ Labels ]

[ Create used layers only
[] Convert line objects to Polygon Mesh
Convert abjects with attributes
Convert all
Default base elevation: 0.00
|:| Convert coordinate system
Input coordinate system
WES 84/ UTM 32N (6°%8.40.-12%.4. CEBEpHOE NONYLWapHe) Select @

Crientation: right, geo-referendng: global coordinate system

Output coordinate system
WES 84/ UTM 32N (6°%8.0.-12% .0, CEBEpHOE NONYLWEPKWE) Select @

Orientation: right, geo-referendng: global coordinate system

|:| Swap XY

K ] [ Cancel

Fig. 251. Batch export to DXF format

5. Choose in the As file name use list classifier parameter, by which vector data di-
vides to files and names assign to these files: Layer, Code Code name or Attribute
value.

6. Configure the rest parameters of export in the same way as for usual export to DXF
format.

7. Click OK. In chosen path are created files, each of them contains data of only se-
lected classifier layer (or parameter).
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14.6. Export to Generate format

The system provides possibility of export to Generate format. This format is used in
Arcinfo softwaresystem. Files with points have the *.gnp or *.pnt extension, files with
polylines — *.gnl or *. lin.

During export to Arc Generate integer index is assigned to each object. If the layer with
classifier is exported, the object code, which is an integer is used as this index. Other-
wise, the object is assigned an index equal to the maximum value of all already used
codes plus 1.

In order to export vector objects to Generate format perform the following actions:

1. Select Vectors > Export > Generate. The Export to Generate window opens.

. Export to Generate @

Jsersfguk/Desktop Mpumeper dainos ana PHOTOMOD backupftest_attributes.gnl
Export selected only
Export attributes to DEF

Convert coordinate system

Input coordinate system

WGES 84 /UTM 32M (6%8.4.-12%. 4. CeBepHOE NONYWapHE, Select @
Orientation: right, geo-referendng: global coordinate system
Output coordinate system
WGES 34 /UTM 32M (6°8.4.-12%. 4. CeBepHOE NoNYWapHE) Select, @
Orientation: right, geo-referencdng: global coordinate system
Swap XY
K, ] | Cancel

Fig. 252. Export to Generate format

2. [optional] In order to export just selected points, set the Export selected only
checkbox.

3. [optional] To create file with attribute information about objects, and to assign vector
objects to classifier, set the Export attributes to DBF file checkbox on.

4. [optional] In order to define standard parameters set the Swap X Y and Convert
coordinate system checkboxes on (see Section 10.5).
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@ If the Swap XY checkbox is set off, the vector objects will be exported in the right coordinate
system. Otherwise, in the left one.

5. Click OK to complete the export operation.
14.7. Export to ATLAS KLT format

The system provides possibility of vector objects export to ATLAS KLT format.
Files of this format has the *.klt extension.
In order to export vector objects to ATLAS KLT format perform the following actions:

1. Choose Vectors > Export > ATLAS KLT. The Export to ATLAS KLT format window
opens.

-

& Export to ATLASKLT =

Users fquk/DesktopMpumepel dalinos ana PHOTOMOD badkwp/test_attributes kit
Export selected only
Scale 1.00 =

Convert coordinate system

Input coordinate system

WES 84/ UTM 32N (6°8.0.-12%.0. CEBEPHOE NONYLIEPHE] Select @
Orientation: right, geo-referendng: global coordinate syste
Cutput coordinate system
G5 84 /UTM 32M (6%8.4.-12%.0. CeBepHOE NONYLLEpKHE Selec @
Orientation: right, geo-referendng: global coordinate syste
Swap XY
QK ] | Cancel

Fig. 253. Export to ATLAS KLT format

2. Define the following parameters of datum: [optional] In order to export just selected
points, set the Export selected only checkbox.

+ Export selected only — allows to export only selected object from active layer;

+ Scale — allows to change scale that adds in the head of file.
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@ Scale value adds in the head of ATLAS KLT file. By default scale is 10 000.

3. [optional] In order to define additional parameters set the Swap X Y and Convert
coordinate system checkboxes on (see Section 10.5).

% If the Swap XY checkbox is set off, the vector objects will be exported in the right coordinate

system. Otherwise, in the left one.

4. Click OK to complete the export operation.
14.8. Export to KML / KMZ

The system provides possibility of vector objects export to KML (KMZ) format. Files of
this format has the *.kml (*.kmz) extension.

ﬁ Vector objects in local coordinate system could not be exported in the KML (KMZ) format. To
perform export change the coordinate system to the global one (see Section 10.5.2).

In order to export vector objects to KML (KMZ) format perform the following actions:

1. Select Vectors » Export » KML, KMZ. The Export to KML / KMZ format window
opens.

i il

& Export to KML / KMZ =

nA PHOTOMOD backupftest_attributes. kml
Export selected only
Export attribute "Label”

As layer use | Layer - |

Attribute: | - |

Create used layers only

Swap XY

[ K, ] | Cancel |

Fig. 254. Export to KML / KMZ format

2. Specify the following parameters of export:

» Export selected only — allows to export only selected object from active layer;
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» Export attribute “Label” — allows to export special object labels (see Section 6.5);

» Use as layer — allows to choose what to assign vector objects after export;

% The system allows to use assigning by classifier layer, object code, name of this code
or attribute value. When vector objects are assigned by attribute value, choose Attribute
in the list.

» Create used layers only — allows to export only classifier layers with vector ob-
jects;

3. [optional] To define additional parameters set the Swap X Y checkbox on (see
Section 10.5).

@ If the Swap XY checkbox is set off, the vector objects will be exported in the right coordinate
system. Otherwise, in the left one.

4. Click OK to complete the export operation.

14.9. Export to LAS

The system provides possibility of vector objects export to LAS format (see the “LIDAR
Data processing” User Manual). Files of this format has the *. las extension.

In order to export vector objects to LAS format perform the following actions:
1. Select Vectors » Export > LAS;
2. Specify the output LAS file location in Windows file system;

3. Click OK to complete the export operation.
14.10. Export to LIG

The system provides possibility of vector objects export to LIG format. Files of this
format has the *.1ig extension.

In order to export vector objects to LIG format perform the following actions:

1. Select Vectors > Export > LIG. The Export to LIG window opens.
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-

’. Export to LIG @

{Users(guk/DesktopMpumepsl dalinos ana PHOTOMOD fbackup/test_attributes. lig
Export selected only

[ Export attributes to DEF

Convert coordinate system

Input coordinate system

G5 84 /UTM 32M (6%8.4.-12%.0. CeBepHOE NONYLIEpKe Select @
Orientation: right, geo-referendng: global coordinate syste
Qutput coordinate system
G5 84 /UTM 32M (5%8.4.-12%6.A. CesepHOe NONYLLEpKHe Select @
Orientation: right, geo-referendng: global coordinate syste
Swap XY
Ok ] | Cancel

Fig. 255. Export to LIG format

2. Specify the following parameters of export:
» Export selected only — allows to export only selected object from active layer;

+ Export attributes to DBF — allows to create file with with attribute information
about objects, as well as for assigning vector objects to classifier.

3. [optional] In order to define additional parameters set the Swap X Y and Convert
coordinate system checkboxes on (see Section 10.5).

4. Click OK to complete the export operation.
14.11. Export to MIF / MID

The system provides possibility of export to MIF/MID format. The MIF/MID format is the
exchange format with *.mif extension, that is used in theMapinfosystem.

When exporting to MIF/MID format it is not allowed to use space in attributes names. Replace
all spaces in attribute names with underscores.

In order to export vector objects to MIF/MID format perform the following actions:

1. Choose Vectors » Export > MIF/MID. The Export to MIF/MID window opens.
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[ @ Export to MIF/MID |

C:/Users /guk/Desktop/Mpumeper dainos ans PHOTOMOD ftin. mif
Export selected only
[ Export "Label” attribute
[ Export attributes to DEF
|:| Save datum parameters
[7] save 7 as attribute
MName: (Z
Split into separate files Base attributes
@ Mone Code CODE 54

4|

4|

(Z) By layers Code name  CODEMAME &4

[ By attribute values [7] Export code as integer value

sheet_name

[T Use multiconnection
[7] Group by attribute

Attribute name:

|:| Convert coordinate system
Input coordinate system

WGES 84 [ UTM zone 32N (odeg East to 12deg East; northern he | Select: @

Orientation: right, geo-referencing: global coordinate system

Output coordinate system

WIGES 84/ UTM zone 32N (odeg East to 12deg East; northern he | Select: @

Orientation: right, geo-referencing: global coordinate system

|:| Swap XY

[ OK, ] [ Cancel

Fig. 256. Export to MIF/MID format

2. [optional] In order to export just selected points, set the Export selected only
checkbox.

3. Specify the following parameters of export:

 [optional] the Export selected only checkbox allows to export only selected object
from active layer;

 [optional] the Export Label attribute checkbox allows to export special object
labels (see Section 6.5);

* [optional] the Export attributes to DBF checkbox allows to create file with with
attribute information about objects, as well as for assigning vector objects to
classifier;
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+ [optional] In order to export splitting into sheets as separate objects (for example,
to export separately polygons that correspond to images borders, and separately
“gaps”), set the Use multiconnection checkbox on.

To merge separate objects with the same attributes (for example, to group just
“‘gaps”) set the Group by attribute checkbox on and input attribute name into
the appropriate field.

* [optional] To preserve Z coordinate as attribute in classifier, set the Save Z as
attribute checkbox and specify attribute name in the Name field;

+ [optional] The Save datum parameters checkbox allows to save seven paramet-
ers of coordinate system to metadata.

4. Inthe Split into separate files section specify one of the ways of export to a sep-
arate file:

* None - all objects of opened layer are exported in one file;

* By layers — each layer of classifier is exported to separate file, file is named with
name of corresponding classifier layer;

+ By attribute values — used to export objects of opened layer by attribute value,
which name is specified in this field below.

5. [optional] In the Base attribute section choose classifier attributes for DBF-file:
Code and/or Code name. Define their names and line length of attribute in corres-
pondent fields.

§ Attribute line has default length — 64 symbols. If it is necessary to display inMapInfoattributes

with code with are not integer, set the Export code as integer value checkbox on.

6. [optional] In order to define additional parameters set the Swap X Y and Convert
coordinate system checkboxes on (see Section 10.5).

@ If the Swap XY checkbox is set off, the vector objects will be exported in the right coordinate

system. Otherwise, in the left one.

7. Click OK to complete the export operation. Two files with the same names is created.
The first file has the *.mif extension and contains vector objects. The second file
has the *.mid extension and contains attributes of these vector objects.

14.12. Export to PLY

The system provides possibility of vector objects export to PLY format. Files of this
format has the *.ply extension.
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In order to export vector objects to PLY format perform the following actions:

1. Select Vectors » Export » PLY. The Export to PLY format window opens.

@ Export to PLY format (e |

Jsersfguk/DesktopMpumeps dainos ana PHOTOMOD backupftest_attributes.ply

Export linear objects
Convert coordinate system
Input coordinate system

WGES 84 [ UTM 32N (6%8.4.-12%8.4. CEBEpPHOE MONYLWEPWE) Select, @

Orientation: right, geo-referencing: global coordinate systen

Output coordinate system

WG5S 84 /UTM 32N (5°8.4.-12%.40. CeBepHOE Nonywapre) Select @
aeo-refere

Fig. 257. Export to PLY format

2. [optional] In order to export just linear objects, set the Export selected only
checkbox.

3. [optional] In order to define standard parameters set the Swap X Y and Convert
coordinate system checkboxes on (see Section 10.5).

% If the Swap XY checkbox is set off, the vector objects will be exported in the right coordinate
system. Otherwise, in the left one.

4. Click OK to complete the export operation.
14.13. Export to Shape

The system provides possibility of export to Shape format. This is exchange format with
*.shp extension, that is used inArcinfosystem.

The Shape format consists of three files with the same names and following extensions:

+ *.shp —main file, that contains information about objects; one Shapefile stores objects
of the only one type — points, polylines or polygons;

+ *.shx — additional index file, that contains information about objects position in the
main file; it is used to speed up access to the content of the shape-file;
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« *.dbf — additional file containing the table of DBF database (see Section 13.14).

* *.prj — additional file containing parameters of project projection.

In order to export vector objects to Shape format perform the following actions:

1. Select Vectors » Export » Shape. The Export to Shape window opens.

r
. Export to Shape

Export selected only

Use DBF file
| Points Base attributes
suffix _points Object name  NAME
7| Paolylines Code CODE
Suffix _lines Export code as integer value
7| Palygans Code name  CODEMAME
Suffix _polygons Layer name  LAYER

Split into separate files
Mone

By layers

By attribute values sheet_name

Use multiconnection
| Group by images

Image name attribute

Convert coordinate system
Input coordinate system

=m0 = e e -
WG5S 34/ UTH

C: fUsersfguk/Desktop Mpumeper daiinos ans PHOTOMOD backupftest_attributes.shp

-
64 =
64 |5
64 =
64 |5
Select, @
Select, @
Ok l | Cancel

Fig. 258. Export to SHP format

2. Specify the following parameters of export:

+ Export selected only — allows to export only selected object from active layer;

+ Export attributes to DBF — allows to create file with with attribute information
about objects, as well as for assigning vector objects to classifier.

o Select DBF file encoding, Win or UTF-8.

7

UTF-8 encoding may be necessary for correct export of Cyrillic characters.
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8.

Select object types for export: Points, Polylines, Polygpns and specify names of
objects types.

In the Split into separate files section specify one of the ways of export to a sep-
arate file:

* No — used to export all objects of one layer to a single file.

* By layers — used to export each layer to separate file; each file receives the
name of the corresponding layer;

» By attribute values — used to export objects of opened layer by attribute value,
which name is specified in this field.

[optional] To specify code names in classifier of the DBF file, in the Base attributes
section the Object name, Code, Code name, and Layer name checkboxes are
set on by default.

@ Attribute line has default length — 64 symbols. If it is necessary to display in Arcinfo soft-
wareattributes with code with are not integer, set the Export code as integer value
checkbox on.

[optional] In order to export splitting into sheets as separate objects (for example,
to export separately polygons that correspond to images borders, and separately
“‘gaps”), set the Use multiconnection checkbox on. To merge separate objects
with the same attributes (for example, to group just “gaps”) set the Group by images
checkbox on and input attribute name into the Image name attribute: field.

[optional] In order to define additional parameters set the Swap X Y and Convert
coordinate system checkboxes on (see Section 10.5).

5 If the Swap X Y checkbox is set off, the vector objects will be exported in the right coordinate
system. Otherwise, in the left one.

Click OK to complete the export operation.

14.14. Export to Panorama / SXF

The system provides possibility of vector objects export to the Panorama or *.sxf
(*.1txf) format. The Panorama format is exchange format with *.sit and *.map exten-
sions, that is used in GIS Map system.

SXF (Storage and eXchange Format) is the open format for terrain digital information.
This format was developed in 1992 by the Topographic Service of the Armed Forces
of the Russian Federation and in 1993 was approved as the main exchange format for
terrain digital information for the Russian Armed Forces and for some federal services
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of the Russian Federation. There are the binary and text (*.txf) forms of data storage
in the SXF format.

In order to export vector objects to Panorama / SXF format perform the following actions:

1. Select Vectors > Export > Panoramal/SXF. Specify the export file name and click
the Save button. The Export to Panorama/SXF window opens:

€& Export to Panorama/SXF @

Users/guk/DesktopMpumeper dainos ans PHOTOMOD backup/test_attributes.sit

Export selected only

Export to SIT

Export to SXF

Export to TXF

Delete hyphens in sheet names
Add prefix "0.”

|Jse region name as sheet name

Convert coordinate system

Input coordinate system

WG5S 84 /UTM 32N (6%8.4.-12%6.4. CEBEpHOE NoNyLWapHe) Select @
Crientation: right, geo-referencing: global coordinate syste
Output coordinate system

VGS 84 J UTT a select,| @
Orientatior g:

Swap XY

[ oK ] | Cancel
L &

Fig. 259. Export to Panorama / SXF

2. [optional] In order to export just selected points, set the Export selected only
checkbox;

3. Set or clear the following checkboxes to select at least one export format:
* Export to SIT;
* Export to SXF;
* Export to TXF.

ﬁ At least one format must be chosen (for that reason, if only one checkbox is set, the
program will not allow you to clear it).

4. [optional] In order to delete hyphens in sheet names, set the appropriate checkbox;
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5. [optional] To use region name as sheet name, set the appropriate checkbox (re-
commended for further data processing in GIS Map);

g If the checkbox is cleared, a user-entered file name is used as a sheet name (see above).

If the checkbox is set, the District name entered by the user is used as a sheet name (see
below).

6. [optional] To define standard parameters set the Swap X Y and Transform refer-
ence system checkboxes on (see Section 10.5);

% If the Swap XY checkbox is set off, the vector objects will be exported in the right coordinate
system. Otherwise, in the left one.

7. Click OK. The Creation of Panorama map window opens:

. it
. Panorama map creation et e
Map scale |2I.‘.IUU - |
District name |
RSC file name
Continue Cancel

Fig. 260. Creation of Panorama map

8. Selectin the list the map scale to create a map of particular scale (in a range from
2 000 to 1 000 000);

9. In the District name field input necessary name;

10. In the Output file section click the _... | button to choose classifier file (with *.rsc
extention);

11. Click the Continue button to complete the export.

14.15. Batch export of layers

The system provides possibility of batch vector objects export to separate files with the
same extension.

To export multiple vector layers perform the following actions:

1. Open at least two vector layers.
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2. Select Vectors > Export » Batch export of layers. The Export opened vector
layers window opens.

. Export opened vector layers. [ﬁ

Qutput folder: u

Cutput files format: | ASCII -

[7] Export attributes to DEF

[ OK ] I Canicel

W 4

Fig. 261. The Export opened vector layers window

3. Click the _.. | button to choose destination folder for files export.
4. Choose one of the following formats from the list:

+ ASCII;

* ASCII-A;

« CSV;

* DGN;

« DXF;

* Generate;

» ATLAS KLT;

« KML;

s LIG;

« MIF/MID;

« PLY;

» Shape;

» Panorama.
5. Set the export parameters, according to the chosen format.

6. Click OKto export multiple vector objects to separate files with the same extension.
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14.16. Batch export of resources

The system provides possibility of batch vector objects export from resources to separate
files with the same extension.

To do this perform the following actions:

1. Select Vectors > Export > Batch export of resources. The Parameters window
opens.

( ’ Options @1

4 Data E] - Dst Big Tiles.2012-08-21 18-40-36.x-data

classifier Dst Big Tiles.2012-08-21 18-54-06 x-data
> dem

mosaic
cheets
descriptors
Locks
» ProjOptions
Temp
> Aalen_DMC konwa CeynH
» Aalen_DMC_copy_for_vect.. -

Na‘me Size i
Dst Big Tiles.2012-08-21.1... 406.50 KB
Dst Big Tiles.2012-08-21.1... 603.00 KB
Dst Big Tiles.2012-08-21.1... 1.25 MB
Dst Big Tiles.2012-08-22.1... 116 MB
Dst Big Tiles.2012-08-22.1... 1.28 MB
Dst Big Tiles.2012-08-221... 1.52 MB
Dst Big Tiles.2012-08-221... 119.50 KB

ML NI THo_ R4S Ao a0 4£4 CAon

4 mn I

M By

[ Mext ] [ Cancel

Fig. 262. The Parameters window

2. Choose a folder containing vector objects in resources tree.

é The T2 button allows to display all available resources in nested files. The [£] button allows
to refresh part of the window with resources.

é The ™ button allows to show a list with 10 recently selected resources.

3. Select file with vector objects in the list and click the = button to add a layer.

ﬁ The == and == buttons allow to add to the list or remove from it all added files with vector
objects, the [= button allows to remove selected file from the list.
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4. Repeat the 2 and 3 steps to add next files with vector objects.

5. Click the Next button. The Options window opens.

r’ Options @1
Cutput folder: |:|

Qutput files format: | ASCIL -

Expart attributes to DEF

| Back | [ OK l | Cancel |

Fig. 263. The Options window

6. Click the _.. | button to choose destination folder for files export.
7. Choose one of the following formats from the list:

« ASCII;

» ASCII-A;

+ CSV;

« DGN;

» DXF;

+ Generate;

» ATLAS KLT;

« KML;

e LIG;

« MIF/MID;

+ PLY;

» Shape;

+ Panorama.
8. Set the export parameters, according to the chosen format.

9. Click OKto export multiple vector objects to separate files with the same extension.
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15. Generators of splitting into sheets

15.1. Standard orthomap sheet frames generator

The program provides possibility to split survey area for notation sheets of chosen scale,
which consist of vector polygons.

Generators of splitting into sheets are used to:

+ to split orthomaps into sheets by images;

« for further use in the GeoMosaic program;

« for contours sheets export.

Perform the following to split survey area to notation sheets of chosen scale:

1. Choose Vectors > Create standard orthomap sheet frames. The Generate
standard sheets window opens.

. !
. Generate standard sheets Lﬁ

Transform sheets into another Coordinate system:

WGES 84/ UTM 32N (6%8.0.-12%.0. CEBEpHOE NONYILADWE ) Select, @

Crientation: right, geo-referencng: global coordinate system

Transform sheets into another Coordinate system:
WES 84/ UTM 32M (6%.4.-12%6.0. CeBEpHOE NoNYLLEDWE ) Select: @

Ciriartatinrme ikt nen-referencinne alohal coordinst setam
rientaoon: rignt, geo-rererendang. goba orainate sysoe

Limits in destination coordinate system

4|k

Morth 541112646

East 531508.69 -

Ak

West 580029.53

4|k

South 5403431,80

Parameters

Scale 1:2 000 -

Attribute with sheet name MName
Add "(5)" to sheet name

Fero-pad the 1:100 000; 1:5 000; 1:2 000 numbers
Quarters notation

@ a 6,81 L, 5,4 ab,c.d

Create outscribed rectangles for sheet

[ CK l | Cancel

Fig. 264. Standard orthomap sheet frames generator parameters
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2. Inthe Geographic coordinate system section choose the input coordinate system,
which is used to specify splitting into sheets by latitude and longitude.

3. In the Destination coordinate system section choose the coordinate system to
recalculate coordinate system of sheets during splitting into sheets (coordinate
system of the project, for example).

4. Inthe Limits in destination coordinate system section are specified coordinates
of area borders for splitting into sheets. To change area size input coordinates of
corners in the North, West, East, South fields.

@ The program provides possibility to split survey area for predefined by user notation sheets
of chosen scale.

5. Choose the scale of orthomap in the Scale section.
6. Inthe Parameters section define the following settings:

+ Attribute with sheet name — allows to define the name of attribute to write the
sheet names;

+ Add “(S)” to sheet name — allows to clarify map position, located in south
hemisphere;

» Zero-pad the 1:100 000 number — allows to add zeros before zone numbers to
notation for lists of 1:100 000 scale;

* Quarters notation — allows to choose type of quarters notation.

7. [optional] In case when 1:5 000 or 1:2 000 scale is chosen, set on the Create
outscribed rectangles for sheet checkbox.

8. Click OK. After that the system starts the splitting orthomaps into sheets with spe-
cified notation.

The figure below displays an example of splitting of the survey area on map sheets with
the following data: orthophotomap scale — 1:200 000; geographic coordinate system —
Latitude-Longitude Pulkovo 1942; target coordinate system — SK-42, Zone 6.
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r. 1: 1:12 Block scheme
Ot E (@O QA QAMAQ 2
Vectors @
Banlyésn skl a2 BsEE¥445 E0Y &0
3
= -~ Marker
& & [ =~ Vectors
@ | > [0 #-Block scheme
& > - Raster
B Gbjcct attributes
DDh@BS&| 2P
Name | Value
"Mame" | A-37-059-245-h
™ (3
3 g [© m [/ m [oee Enm 2
| 738056.320265 m; 258581 847828 m; 0.000000 m | WGES 84 S UTM zone 37N

Fig. 265. Example of splitting orthomaps into sheets with specified notation
15.2. Custom orthomap sheet frames generator

Program provides possibility creating sheets from several orthomaps, merged by cutlines
and created in local coordinate system.

Perform the following to split orthomaps by notation sheets in local coordinate system:

1. Choose Vectors > Create custom orthomap sheet frames. The Generate arbitrary
sheets window opens.
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( . Generate arbitrary sheets Iﬁﬁ
Attribute with sheet name  Name Sample
Primary sheet dimensions Scale 1 Scale 2 Scale 3 Scale 4 |
¥ 1000.00 = Y 1000.00 = 1 2

Lowerdeft corner of the origin sheet:

Iy

X 0.00 Sy o0 = 3 4

Origin sheet number

Y

X -2147483048 |5 Y -2147483648

4k

Sheet name template:
S(0x)-5(0y)-5(1)-5(2)-5(3)-5(4)

() Primary scale only

Cirigin Rows Columns Starting with
@ Scale 1 2 = 2 = 1 1 [] Separate numeration for rows and columns
) Scale 2 2 =1 (2 =1 1 1 [ separate numeration for rows and columns
() Scale 3 2 =1 2 = 1 1 [ separate numeration for rows and columns
) Scale 4 2 = 2 =1 1 [7] Separate numeration for rows and columns

FIENE] [ ok || cancel

Fig. 266. Custom orthomap sheet frames generator parameters
The bottom toolbar of window contains the following buttons:
» «7 — allows to reset parameters to default;
» L= — allows to load parameters from the file;
« &=l — allows to save parameters into a file.
2. Specify the following parameters of primary scale sheet:

ﬁ, In case of using the custom orthomap sheet frames generator it is possible to use up to 5
levels of splitting orthomaps into sheets: primary and 4 additional scales. Each next level
is created by splitting the previous level.

» Attribute with sheet name — allows to define the name of attribute to write the
sheet names;

* Primary sheet dimension — the primary scale sheet size;

* Lower-left corner of the origin sheet — allows to set coordinates of the origin
sheet;
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é Choose the reference point lower and left from work area.

é The coordinates of origins of the others sheets are calculated based on this information.

» Origin sheet number — allows to input a number of sheet that starts numeration;

+ Sheet name template — displays the template by which sheet names are created.
By default, $(0x)-$(0y)-$(1)-$(2)-$(3)-$(4), where

o $(0x) — number by X on primary scale;
o $(0y) — number by Y on primary scale;

o $(1), $(2), $(3), $(4) — number on the first and next levels in case if the
Separate numeration for rows and columns checkbox is set off;

o $(1x) — number by X in case if the Separate numeration for rows and
columns checkbox is set on;

o $(ly) — number by Y in case if the Separate numeration for rows and
columns checkbox is set on;

Notation adds as attribute of each sheet.

ﬁ If template does not correspond to selected number of splitting levels, attributes are
created incorrectly correct.

3. [optional] To use only one base list choose Primary scale only and click OK.
Otherwise move to the 7 step.
4. Specify the following parameters of primary scale sheet:

1. Choose number of additional levels of splitting: Scale 1, Scale 2, Scale 3,
Scale 4.

2. Select origin of sheets of additional level in the Origin list.
3. Define number of Rows and Columns for each level.

4. Define arbitrary symbol (letter or number) as a start sheet number in the
Starting with field.

é Notation with all types, except using Roman numerals, could be created.
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5. [optional] Sheets is numbered sequenced by row. To change numeration order
set the Separate numeration for rows and columns checkbox on.

@ All changes of parameters are shown in the Sample table.

5. In Coordinate systems tab specify the following parameters:

(" N
. Generate arbitrary sheets ﬁ
Parameters Coordinate systems

Geographic coordinate system

WGES 84/ UTM 32N (6%.0.-12°6. 4. CeBEpHOE NONYLIEDWE) Select, @

Crientation: right, geo-referencding: global coordinate system

Destination coordinate system

WGES 84/ UTM 32N (6%.0.-12°6. 4. CeBEpHOE NONYLWEPHE) Select, @

Crientation: right, geo-referencding: global coordinate system

Limits in destination coordinate system

4|F

Morth 5411126.46
West 580029.58 = East 581508.609 ~

South 5409431.80 d

lE/ lE | OK | | Cancel

Fig. 267. Custom orthomap sheet frames generator parameters

* In the Geographic coordinate system section choose the input coordinate
system, which is used to specify splitting into sheets by latitude and longitude.

* In the Destination coordinate system section choose the coordinate system
to recalculate coordinate system of sheets during splitting into sheets (coordinate
system of the project, for example).

 Inthe Limits in destination coordinate system section are specified coordinates
of area borders for splitting into sheets. To change area size input coordinates
of corners in the North, West, East, South fields.

6. Click OK. After that the system starts the splitting orthomaps into sheets with spe-
cified notation. New vector layer creates. Sheets are displayed in 2D-window.

15.3. Standard orthomap sheet frames importer

The program provides possibility to split survey area for predefined by user notation
sheets of chosen scale, which consist of vector polygons. The names of notation sheets
are specified in input CSV-file with *.csv or *. txt extension.
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@ The program provides possibility to split survey area for notation sheets of chosen scale, by

setting the coordinates of area borders for splitting into sheets.

An input CSV-file must meet the following requirements:

Names of notation sheets in input *.csv or *. txt files must be sequentially rowwise
arranged. Field delimiter symbols as comma, space, tab, semicolon or other are
not applicable;

An input CSV-file must contain names of notation sheets of only one scale;

Names of notation sheets in the input CSV-file must contain a unified Quarters
notation;

All names of notation sheets in the input CSV-file must have either only standard or
only numeric form;

The input CSV-file must contain the names of notation sheets located in one hemi-
sphere.

Perform the following to split survey area to predefined notation sheets of chosen scale:

1.

Choose Vectors > Import standard orthomap sheet frames. The Import standard
sheets window opens.
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. Import standard sheets

B

Geographic coordinate system

Orientation: left, georeferencing: global coordinate system

Destination coordinate system

Parameters

Geodetic WG584 (Jatitudeongitude in radians) () Select,

Select, I@

©

Scale 1:2000

Attribute with sheet name Name
Add "(5)" to sheet name

Zero-pad the 1:100 000; 1:5 000; 1:2 000 numbers
Quarters notation

@ a, 6,8, 1,2, 3,4 a b, cd

Create rectangle sheets boundaries

Import sheets

File with sheet names Nomendatures with errors

Digital nomendature
South hemisphere

[ oK ] | Cancel |

e

4

Fig. 268. Standard orthomap sheet frames import parameters

2. Inthe Geographic coordinate system section choose the input coordinate system,
which is used to specify splitting into sheets by latitude and longitude.

3. In the Destination coordinate system section choose the coordinate system to
recalculate coordinate system of sheets during splitting into sheets (coordinate
system of the project, for example).

4. In the Scale section choose the scale of notation sheets, which names will be im-

ported.

ﬁ An input CSV-file must contain the names of notation sheets of the same scale which
matches the selected one;

5. In the Parameters section define the following settings:

+ Attribute with sheet name — allows to define the name of attribute to write the
sheet names;
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6.

9.

+ Add “(S)” to sheet name — allows to clarify map position, located in south

hemisphere;

» Zero-pad the 1:100 000 number — allows to add zeros before zone numbers to
notation for lists of 1:100 000 scale;

* Quarters notation — allows to choose type of quarters notation.

c The names of notation sheets in the input CSV-file must contain a unified Quarters
notation which matches the selected one;

[optional] In case when 1:5 000 or 1:2 000 scale is chosen, set on the Create
outscribed rectangles for sheet checkbox;

In the Import sheets section click the _... | button, to select input CSV-file with
sheet names with *.csv or *, txt extension;

ﬁ Names of notation sheets in input *. csv or *. txt files are sequentially rowwise arranged.
Field delimiter symbols as comma, space, tab, semicolon or other are not applicable.

[optional] In case when notation sheets have solely numeric names, set on the

numeric names checkbox;

é All names of notation sheets in the input CSV-file must have either standard or numeric

form.

g In numeric form of notation sheets names, each letter denoting zones is replaced by double
figures. These figures correspond to the counting number of the zone (or the letter in the
Latin alphabet). For example, A— 01, B— 02, C — 03, D — 04, E — 05, and F — 06.
The numeric notation of a sheet of 1:1 000 000 K-38 map will be 11-38. Each sheet of
1:200 000 map is denoted by a double figure from 01 to 36, and 1:100 000 map is denoted
by three figures from 001 to 144. Letters in 1:500 000, 1:50 000, and 1:25 000 map sheet
notations are replaced by the figures 1, 2, 3, and 4, respectively.

Table 16. Numeric form of notation sheets names for 1:1 000 000 - 1:25 000 scales

Map scale Standard notations Numeric notations
1:1 000 000 K-38 11-38
1:500 000 K-38-b 11-38-2
1:200 000 K-38-XXXVI 11-38-36
1:100 000 K-38-99 11-38-099
1:50 000 K-38-99-B 11-38-099-3
1:25 000 K-38-99-B-I" 11-38-099-3-4

[optional] In case when notation sheets are located in southern hemisphere, set on
the South hemisphere checkbox;
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é An input CSV-file must contain the names of notation sheets located in one hemisphere.

10. Click OK. After that the system starts the splitting orthomaps into sheets with spe-
cified notation.

If errors are detected in the input CSV-file, the operation fails. An information mes-
sage showing the number of detected errors appears. The names of notation sheets
with errors are displayed in the Names with errors field.

16. Co-editing vector layers

The system provides an algorithm for collaborative editing of a vector layer by several
users at once. The program allows for coordination of operators’ actions by tracking
changes made to the vector layer in different units of PHOTOMOD. This allows us to
optimize the processing of large arrays of vector data, performed simultaneously on
several workstations, while avoiding the shortcomings that may arise when editing the
same resource by different users.

QA First of all, this functionality was developed to facilitate the work with the so-called cutlines, i.e.
topologically connected vector polygons, created in PHOTOMOD Geomosaic (see “Cutlines
creation” in the “Orthophotomaps creation” User Manual and the recommendations in Sec-
tion 16.1).

Vector layers available for co-editing have *. cx-data extension. The entire set of tools
and functionality of the system, designed to work with “standard” vector layers, is also
available for co-edited layers, unless otherwise noted.

é Co-editing is not supported for layers with a classifier.

Collaborative editing means simultaneous processing of different objects of the same
vector layer by several operators. Coordination of user actions is achieved by tracking
the state of each individual vector object and the algorithm for saving the changes made,
taking into account the actions of all operators:

» If a user has edited only “their” objects (not affected by other operators since the
layer was loaded in the current PHOTOMOD module), the vector layer is saved as
usual;

« If, during a session with a layer, the user has made changes to at least one object
that was simultaneously edited (saving data) in another PHOTOMOD module, then,
when trying to overwrite data, a dialog box is displayed notifying the user about the
conflict that has arisen.
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P
’. Question = £

[9]

Joint changes for one or more objects are found.
Save changes in your favor?

Yes | | Mo | | Cancel

Fig. 269. A dialog box

The user can:

o Save their changes — force save changes in all objects edited by them, including
co-edited objects, overwriting the changes made to these objects by other users
by clicking Yes;

o Overwrite only “their own” edited objects, without introducing “their own” changes
to objects that have already been processed by other operators, from the moment
the layer was loaded in the current PHOTOMOD unit, by clicking No;

o Cancel saving vector layer.

7

The system does not provide for highlighting conflict vector objects, as well as for displaying
their number. However, for co-edited vector layers, as well as for “common” vector objects,
it is possible to cancel editing.

In this case, if sequential cancellation of editing operations is carried out after saving the
data, then sequentially, in order of priority, all recent changes made to vector objects (in
current PHOTOMOD unit) are canceled - both by the current user and by other operators.
Operations with the action log are taken into account when checking for shared changes
of vector objects before saving the layer.

Despite the fact that the functionality of co-editing greatly facilitates group work with data,
in order to optimize the process of stereovectorization, users are strongly recommended
to split the work among themselves within the vector layer being processed, and also to
save the results of their efforts quite often, especially when processing topologically con-
nected objects (see below).

After the layer has been saved (regardless of the save mode selected by the user), the
information in the 2D window of the program is updated, displaying the last saved version
of the data, taking into account the changes made by all operators

To load the last saved version of the active vector layer without saving “your” changes,
choose Vectors > Revert. The 2D window of the program displays the last saved
changes in the active layer made by other users (if there are such changes).
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The algorithm for co-editing of vector objects takes into account not only changes made
directly to the objects themselves, but also operations with vector object attributes
(created in a layer without a classifier).

The system does not provide for co-editing various elements of the same object by
different users — the fact of shared changes will be recorded in any case, even if different
elements (or attributes) of the object in question were changed by operators.

To create a co-editable vector layer, first create a vector layer without a classifier.
Choose Vectors > Save as. In the window that opens, choose Co-editable vector
objects (*.cx-data) in the appropriate drop-down list. Set the name and path to save
a layer in the active profile resources and click Save.

16.1. Co-editing topologically connected vector objects

When several users work in groups on a co-edited vector layer, special attention should
be paid to topological operations, i.e. work with topologically connected objects, since
the changes made affect not only this particular object, but also its neighbors topologically
connected to it.

A special case of topologically connected objects are the so-called cutlines that are to-
pologically connected vector polygons created by PHOTOMOD Geomosaic. In case of
automatic cutline creation, the resulting vector layer is primarily available for collaborative
editing by several users and has *.cx-data extension (see “Cutlines creation” in the
“Orthophotomaps creation” User Manual).

Despite the fact that the functionality of vector object co-editing greatly facilitates
manual cutline co-editing in PHOTOMOD Geomosaic, users are strongly recommended
to split the work among themselves and pay special attention to the actions performed
at the “junctions” of their work areas, and also save the results of their work quite often.

When working with cutlines, it is recommended to use the “save your changes” function-
ality carefully. If, when working with topologically unconnected vector objects, this oper-
ation can simply lead to the loss of the results of the work of one or several operators,
then, with incoordinated deletion, addition or movement of the node vertices of cutlines,
it is very likely that extremely undesirable elements will appear in the layer with cutlines —
so-called “gaps” (see “Orthophotomaps creation” User Manual).

When copying PHOTOMOD GeoMosaic projects containing cutlines, it is important to
pay special attention to whether the vector data link to the project (see “General
parameters” in the “Orthophotomaps creation” User Manual).
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17. ArcSync. Synchronized vector edition

17.1. The main window of ArcSync

The ArcSync: Synchronize to Arcinfo map window is used to terrain objects vector-
ization at the same time in the PHOTOMOD system and in third-party software.

& ArcSync: Synchronize to Arcnfo map lﬁj lilﬁlﬂ_hj
c-BEX + -0 T8 [FR

File Type

DAVS_polygons.shp Polygons

Layers: 1

Fig. 270. The main window of ArcSync

List of synchronization files is a table. File path is displayed in the File column. In the
Type column is displayed type of object chosen in layer export (points, polylines or

polygons).

The ArcSync: Synchronize to Arcinfo map window toolbar contains the following
buttons:

* = — allows to open created ArcSync map;

. — allows to save vector layers as ArcSync map;

[ - allows to save vector layers as ArcSync map using unique name;
« & — allows to close ArcSync map or added layers;

* + —allows to add vector layer in the table;

+ — —allows to remove vector layer from the table;

— allows to synchronize maps manually;

« &F _ allows to import opened layer into 2D-window;

£k — allows to save opened layers in a Shape-file;

<& — allows to enable auto synchronization mode;

— allows to setup auto synchronization parameters.
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17.2. Workflow

To terrain objects vectorization at the same time in the PHOTOMOD system and in
third-party software is used the ArcSync module.

To Shape-files in Windows during simultaneously vector editing in PHOTOMOD and/or
another program, changes add to files gradually. It is not required to save files again
after editing.

It is recommended to create Shape-files in the third-party software or export vectors
from PHOTOMOD.

To terrain objects vectorization at the same time in the PHOTOMOD system and in
third-party software perform the following:

1. [optional] Export vector layer to Shape-file.
é During export polygons to a Shape format it is strongly recommended to set on all check-
boxes Export attributes to DBF and Polygons/Polylines/Points.

2. Choose Vectors > Import > Shape in the system and import a vector layer. Imported
layer displays in 2D-window.

ﬁ If DBF file was created during export, set the Use DBF-file checkbox on.

3. Choose Vectors » ArcSync » Map settings window or click the &2 button of the
ArcSync toolbar. The ArcSync: Synchronize to Arcinfo map window opens.

. ArcSync: Cukxporusauma ¢ kaproii Arclnfo = | B || N
c-BREX +- |0 Td|s B

Paiin Tun

Cnoes: 0

Fig. 271. The main window of ArcSync

4. Click the + button. The Add files window opens. Choose Shape file and click the
Open button. The file adds to the table.
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. ArcSync Synchronize to Arcnfo map [EJ E@ﬂ
c-BRX + -0 TH[H@
File Type
DAWS_polygons.shp Polygons
Layers: 1
L A
Fig. 272. Adding file in the table
5. Open second program and load the same vector file in it.
Deds 0 &~ M EEE
RE[Q@ i@ -0/ K@ B 0IRE
Editar - =
Table Of Contents 1 x o
% {} 8
= = Layers
= B WRILEZ TechSuppartiData’
=] vectors_polygons
S
—_— T
-:::C::GC:::,
fe— ‘——Za::p —=
S il i
4 1 | 2 Q|eu< m 3
Fig. 273. Vector layer in the third party program
6.

In the ArcSync: Synchronize to Arcinfo map window click the button. The
Settings window opens.
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r. Settings [ﬁw

Auto-sync

Minimum auto-sync interval | 2.0 =

[] Save layers changed in PHOTOMOD

Load layers which were changed outside

| ok || Cancel

Fig. 274. Synchronization parameters

7. Define the Minimum auto-sync interval in seconds.
8. Set on one or more checkboxes:

» Save layers changed in PHOTOMOD - changes made in PHOTOMOD are
shown in the third-party program;

* Load layers which were changed outside — changes made in the third-party
program are shown in PHOTOMOD 2D-window.

9. Click OK to save parameters.

10. Click the €% button. Auto-sync mode enables.

r. ArcSync: Synchronize to ArcInfo map I.Q:} ,| l =NECIN X )
>-BEX + -0 TR
File Type
D:WE_polygons.shp Polygons
Layers: 1

Fig. 275. Auto-sync mode is enabled

11. Change vector layer in the system.
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Fig. 276. Changes on vector layer in the system

12. In the other program click the Refresh button. As a result, changes display in this
program.

@ 1 32Block scheme =0 ECR
Ot @ | [@ED AWM R 2
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Fig. 277. Changes displaying in the third-party program
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13. To save changes in file, in the ArcSync: Synchronize to Arcinfo map window
click the & button.

14. To save changes in Shape-file of ArcSync format, in the ArcSync: Synchronize
to Arcinfo map window click the [g]| button and input filename.
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