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The system provides using of customized and non-customized hotkeys, that partially
duplicate menu items and toolbars buttons, and also allow to open the custom menus
(see the “Hotkeys and custom menus” chapter of the “General information” User
Manual). The most of hotkeys used in the system could be changed in the Customize
hotkeys window (Service › Customize hotkeys - see the detailed description in the
“Customize hotkeys” chapter of the “General information” User Manual).

1. Opening windows and toolbars
Shortcuts like Ctrl+Alt+<letter> are used to open the following windows, toolbars and
modules:

ActionKeyboard shortcut
to open the Block editor windowCtrl+Alt+B
to open the Marker windowCtrl+Alt+C
to open the Measurements windowCtrl+Alt+D
to open the Explorer windowCtrl+Alt+E
to open the Triangulation points window on the GCP list tabCtrl+Alt+G
to open the Manage project cameras windowCtrl+Alt+I
to open the Points measurement module with images containing marker
position

Ctrl+Alt+K

to open the Block layout windowCtrl+Alt+L
to open the Mosaic moduleCtrl+Alt+M
to open the Project management windowCtrl+Alt+O
to open the Settings windowCtrl+Alt+P
to open the Relative orientation report settings windowCtrl+Alt+R
to open the Triangulation points window on the All triangulation points
tab

Ctrl+Alt+T

to open the 2D-window (stereopair) windowCtrl+Alt+W

2. Navigation

2.1. Windows with a list of files/folders of Windows file system

ActionKeyboard shortcut
to open the Project management windowCtrl+Alt+O
to move to a folder that includes selected file, i.e. to rise one level up in the
Project management window

Left arrow

to display content of selected folder, i.e. to open the folder in the Project
management window

Right arrow

in the Project management window (Project › Open/manage ) allows to
pass from the projects list to input field used for input of key word for project

F3

search. Moreover, you can click the F3 button after keyword input for projects
search to perform sequential search for projects in the list
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2.2. The Explorer window and windows for resources load/save

ActionKeyboard shortcut
to open the Explorer windowCtrl+Alt+E
to move at one subfolders level upLeft arrow
to show content of selected folder, i.e. to open the folderRight arrow

For example, keys Left arrow and Right arrow also work in Raster Converter, Add images,
Add pushbroom images windows.

3. The main system window and layer manager
The following hotkeys are available in the main system window:

ActionKeyboard shortcut
to open user manualF1
to show/hide brightness/contrast/gamma correction pane located on the bottom
of the window

Shift+F8

to show/hide scroll barsCtrl+F8
to show/hide layer manager window, and also navigation windowCtrl+F11
to expand/collapse 2D-window, and also show/hide layer manager window,
and also navigation window

Ctrl+Shift+F11

to save active layerCtrl+S
to save active layer with a new nameCtrl+Shift+S
to close active layerCtrl+Q
to display information about active layerCtrl+I
to show/hide active layerH
to show/hide titles in active layerСtrl+H
to show/hide titles in all layersCtrl+Shift+H
“panning” for 0,9 of the window size, i.e. shift of the window content for 0,9 of
the window size

Shift+arrows

“panning” for 8 pixels, i.e. shift of the window content for 8 pixelsAlt+arrows
move selected objects in plane by 4 directionsCtrl+arrows
move selected objects in plane by 8 directionsCtrl+2 / Ctrl+4 / Ctrl+6 /

Ctrl+8 [numeric key-
board]

move selected objects along Z axisCtrl+PgUp / Ctrl+PgDn
/ Ctrl+mouse wheel

scroll list of points/coordinates/files in windows with scrollbarsMouse wheel
to temporarily hide toolbarsTab

• Ctrl+O – allows to open context (custom) menu, containing layer loading preferences
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ActionKeyboard shortcuts in
context menu

to open Load LAS windowL
to open layer, containing GridG
to open layer, containing DTM, represented as a triangular irregular network
(TIN)

T

to open layer, containing vector objectsV
to open layer, containing DTM, represented as a DEMD
to open layer, containing georeferenced rasters (from resources)R
to open 3D-windowW

• Ctrl+N – allows to open context (custom) menu, containing the options of data con-
struction or new layer preferences

ActionKeyboard shortcuts in
context menu

to create DTM as a DEM, based on triangular irregular network (TIN)D
to create DTM as triangular irregular network (TIN), based on points and
structural lines

T

to create a contours, based on triangular irregular network (TIN)C
to create vector layerV
to create vector layer with the ClassifierS
to create grid layerG

• Press and hold the Alt key during opening of new 2D-window for single image
(Window › New 2D-window (single image)) allows to open the image in 1:1 zoom,
otherwise, it will be opened in 2D-window in full.

Press and hold left mouse button during the operation Window › New 2D-window (single
image) instead of mouse clicks.

• Press and hold the Alt during choosing the Rasters › Load georeferenced images
(files/resources)menu item to load selected image to 2D-window immediately using
parameters of the last loading, otherwise prior to load selected image file a settings
window is opened (used to select coordinate system and background color).

Press and hold left mouse button during the operation Window › New 2D-window (single
image) instead of mouse clicks.

• Press and hold the Ctrl key while opening the Measurement window (the button
of the main toolbar), that allows to not change current active layer in Manager, other-
wise the Marker layer becomes active. In the same way, press and hold the Ctrl key
while closing theMeasurement window, that allows to not change theMarker active
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layer (if the window was opened without using theCtrl key), otherwise the layer which
was active before opening the window becomes active.

3.1. Scaling

ActionKeyboard shortcut
1:1 zoomAlt+1
customized zoomAlt+2–Alt+4
previous zoomAlt+0
“preset zoom” (used to switch between two customized zooms)Alt+5
show window content in a whole (zoom to fit)Alt+Enter
zoom management= [main keyboard]
zoom management- [main keyboard]
zoom management* [numeric keyboard]
zoom management/ [numeric keyboard]
zoom in of image part located inside of rectangle defined by mouse ( )Ctrl+Alt+mouse move

with pressed left button
zoom out of image part located inside of rectangle defined by mouse ( )Ctrl+Alt+Shift+ mouse

move with pressed left
button

zoom changeCtrl+Alt+mouse wheel
1 step zoom inCtrl+Alt+mouse click
1 step zoom outCtrl+Alt+Shift+mouse

click

Press Ctrl+Alt hotkeys (or click an appropriate button to enable the mode) and drag a rect-
angle by mouse to zoom in area of image. Press Ctrl+Alt+Shift hotkeys (or Shift key only, if
the mode is already enabled) and drag a rectangle by mouse to zoom out area of image.

3.2. Marker

ActionKeyboard shortcut
to open the Marker windowCtrl+Alt+C
to drag selected object in planeCtrl+mouse move with

pressed left button
enables panning modeAlt+mouse move with

pressed left button
to select by rectangle in group selection mode (the and buttons in Tools
additional toolbar)

Shift+mousemovewith
pressed left button

cancel selectionEsc
turn on/off “marker=mouse” modeF4
turn on/off fixed marker mode (roam-mode)F6
center window by markerF7
move marker to current vertex~
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ActionKeyboard shortcut
move marker along Z axisPgUp / PgDn
fast marker move along Z axisAlt+Shift+mouse move

with pressed left button
along vertical line

move marker in plane by 4 directionsArrows
move marker in plane by 8 directions2 / 4 / 6 / 8 [numeric key-

board]
to copy position of marker in 2D-window to clipboard (Edit › Copy marker to
clipboard)

Ctrl+Alt+Ins

to move marker to position in 2D-window copied to clipboard (Edit › Paste
marker from clipboard)

Alt+Shift+Ins

Objects selection by polygon in group selection mode by polygon (the button of the Tools
toolbox): Shift + mouse click – used to define first vertex of polygon, mouse click – to specify
every next vertex, double click – to define the last vertex of polygon (to finish a polygon drawing),
Esc – to cancel polygon drawing for objects selecting

3.2.1. Snapping and multi-snapping modes

For work in snapping mode (V, B, N, M) only the hotkeys are used.

ActionKeyboard shortcut
to execute 3D snapping to vertices (when themode was enabled with hotkey,
marker moves to the vertex nearest to the marker position)

V

to execute 2D snapping to vertices (when themode was enabled with hotkey,
marker moves to the vertex nearest to the marker position without changing
marker’s height value)

B

to execute 3D snapping to lines (when the mode was enabled with hotkey,
marker moves to the point on vector object segment, closest to the marker
position, with exact match with XYZ coordinates)

N

to execute 2D snapping to lines (when the mode was enabled with hotkey,
marker moves to the point on vector object segment, closest to the marker
position, without changing marker’s height value)

M

to turn on/off 2D multi-snapping mode – marker moves to vector object ele-
ments (vertices, medians etc.), XY-planemarker coordinates match to coordin-

2

ates of object elements, Z-height of marker is not changed ( button in
Vectors additional toolbar)
to turn on/off 3D multi-snapping mode – marker moves to vector object ele-
ments (vertices, medians etc.), XYZmarker coordinates match to coordinates
of object elements ( button in Vectors additional toolbar)

3

to turn on/off Snapping to points mode – marker snaps to vertices of vector
objects. Label End appears near that vertices ( button in Vectors additional
toolbar)

4

to turn on/off Snapping to medians mode – marker snaps to medians of
vector objects. In case of detecting object segment at the distance of lower

5

than Detect radius, its median is highlighted by small grey circle symbol.
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ActionKeyboard shortcut
Label Midpoint appears near that medians ( button in Vectors additional
toolbar)
to turn on/off Snapping to linesmode – marker snaps to segments of vector
objects. Label Nearest appears near segment point closest to the marker po-
sition ( button in Vectors additional toolbar)

6

to turn on/off Perpendicular snapping mode (allows to build orthogonal
polylines/polygons and to snap segments of drawing objects to segments of

7

existed objects in perpendicular manner) – button in Vectors additional
toolbar
to turn on/off Snapping to coords mode (allows to build polylines/polygons
orthogonal to the basic or additional coordinate system, as well as accurately

8

orient drawing objects regarding vertices of existed vector objects) – button
in Vectors additional toolbar

2D snapping is used while creation an object coinciding with existing one only in XY plane. If,
for example, it is necessary to add an extension to building with different height.

In snapping mode there is a possibility to draw a part of the created object over existing one.

4. Other system windows

4.1. Progress bar

• Ctrl+C / Ctrl+Ins, as well as the Copy context menu item, allow to copy event log to
clipboard.

• Ctrl+Shift+C / Ctrl+Shift+Ins allow to copy event log to clipboard in inner format.

Click an event log area to use hotkeys.

4.2. The “Block editor” window

ActionKeyboard shortcut
to open the Block editor windowCtrl+Alt+B
search for an image by name (part of name)Ctrl+F
choosing (highlighting) of all block imagesCtrl+A
add a new stripShift+Ins
delete chosen stripShift+Del
add images from files, located out of active profile resourcesIns
delete chosen imagesDel
move chosen images right/left/up/downCtrl+arrows
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4.3. The “Camera” window

• Ctrl+Ins/Ctrl+Del in tables of the Camera window ( , in the Manage project
cameraswindow) allow to add/delete the table row. Press the Shift key while clicking
the / buttons to multiply/divide distortion coefficients specified in the table by 10,
otherwise by 1000.

• Press and hold the Alt key during closing of the Camera window (the , buttons
in the Project managementwindow) that allows to not re-calculate interior orientation.

4.4. The “Classifier” window

• Ctrl+F on the Codes tab in the Classifier window (Window › Classifier) allows to
search for specified keyword in the Code table, F3 – to move to the next code, con-
taining the keyword specified.

4.5. The “Undo log” window

ActionKeyboard shortcut
to cancel the last operation of vector objects editing on a layer ( button in
main toolbar)

Ctrl+Z

to redo the last undone operation ( button in main toolbar)Ctrl+Shift+Z

5. Work in “Points measurement” module

ActionKeyboard shortcut
to add a tie point to marker position on selected image (duplicates the
button)

Ctrl+=

are used to search for and add a tie point on two (Space) or on all
(Ctrl+Space) opened images (duplicate the or buttons)

Space, Ctrl+Space

shows correlation coefficient of current image and left image in the marker
position (duplicates the button)

Q

to perform search for a point with marker position, but without proposition
about new point adding (or press and hold the Alt key while clicking the
or button)

F, Ctrl+F

to synchronize markers in all windows with images and center by marker the
image in active window

Shift+C

to zoom images in all opened windows at once (synchronously)Shift+* / Shift+/ [numeric
keyboard]

to adjust a step of move in Stereowindow ( )Ctrl+123456789
to add/delete/search for GCP on the GCP list tab ( ) of the Triangulation
points window (with automatic enabling of editing mode during points adding
or deleting)

Alt+Ins /Alt+Del /Ctrl+F

Alt during adding of GC point ( ) allows to add only one measurement on
selected image, otherwise – on all opened images

Alt+
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ActionKeyboard shortcut
click in theMap window (opened using the button in the Points measure-
ment window) allows to search for marker position only on opened images
of the Points measurement window;

mouse double click

click in theMap window (opened using the button in the Points measure-
mentwindow) allows to search and open only the images that contain marker
position

Shift+mouse double
click

to turn on/off the distance measuring mode in windows of opened imagesD
to change the horizontal size of the frame around the markerH+mouse wheel
to change the vertical size of the frame around the markerV+mouse wheel
to change the size of the frame around marker on both axesB+mouse wheel

To display the frame around the marker choose the Show frame for centering on area objects
item in the right-click menu (in the window of opened image).

In order to hide the frame choose the Show frame for centering on area objects item in the
right-click menu once more.

6. Work in stereomode
• F9 – turn on/off stereomode in 2D-window with stereopair;

• F11 – toggle a phase in stereo windowwhen stereomode is enabled, or toggle left/right
frame when stereomode is disabled;

• F2 – adjust depth – allows to change images parallax to superpose marker;

• F3 – restore depth – allows to set images parallax to stereopair default value;

• Shift+PgUp / Shift+PgDn / Shift+mouse wheel – used to change parallax of image
(not marker);

• Shift+F2 – set marker parallax to zero value (at current images parallax);

• Shift+F3, Home – set marker parallax to default value for stereopair;

• Shift+F7 – turn on/off mode of fixed parallax marker;

• Ctrl+Shift+mouse wheel – change images Y-parallax;

• Alt+Shift+mouse move with pressed middle button along horizontal line – fast
change of image parallax;

• Press and hold the Shift key while clicking OK in the Select stereopair window
(Window › Stereopairs › Select stereopair) after highlighting of one of two selected
images on theAll images tab, leads to opening of the highlighted image in 2D-window
as a right stereopair image, otherwise (by default) images position in a strip is con-
sidered during stereopair opening.
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Enabled checkbox in the list means choosing the object, blue highlight – object highlighting
in the list.

• Space – allows to place marker on a model surface automatically using correlator.

6.1. “Change stereopair” toolbar / “Stereopairs” menu

ActionKeyboard shortcut
to open next stereopair in stripCtrl+Alt+Right arrow
to open stereopair one strip downCtrl+Alt+Down arrow
to open previous stereopair in the stripCtrl+Alt+Left arrow
to open stereopair one strip upCtrl+Alt+Up arrow
to jump to the best stereopair automaticallyCtrl+J

7. Rasters

ActionKeyboard shortcut
to use one of three modes of displaying raster images in 2D-window: Cached
only

Ctrl+Shift+1

to use one of three modes of displaying raster images in 2D-window:Depend-
ing on zoom

Ctrl+Shift+2

to use one of three modes of displaying raster images in 2D-window: Source
only

Ctrl+Shift+3

8. Vectors

ActionKeyboard shortcut
to open layer, containing vector objectsCtrl+O,V
to create vector layerCtrl+N,V
to create vector layer with the classifierCtrl+N,S
to create a contours, based on triangular irregular network (TIN)Ctrl+N,C
to display selected vector object properties (Vectors › Polyline properties)I
to open Elevations interpolating window (see the “Vectorization” User
Manual)

Z

8.1. The “Vectors” toolbar

ActionKeyboard shortcut
to enable point objects input mode ( button in Vectors additional toolbar)P
to enable non-closed polylines input mode ( button in Vectors additional
toolbar)

L

to enable polygons input mode ( button in Vectors additional toolbar)G
to enable CAD-objects creating mode ( button in Vectors additional toolbar)C
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ActionKeyboard shortcut
to enable roofs creating mode ( button in Vectors additional toolbar)R
to enable orthogonal input mode of vector objects ( button in Vectors addi-
tional toolbar)

A

to enable orthogonal input mode of vector objects for additional coordinate
system ( button in Vectors additional toolbar)

S

to enable streamline input mode of vector objects ( button in Vectors addi-
tional toolbar)

Y

to turn on tracing mode ( button in Vectors additional toolbar)T
to enable curve check points editing ( button in Vectors additional toolbar)X
to select a vertex, located in marker area on a distance specified in the Swath
field (Service › Settings › Vectors) ( button in Vectors additional toolbar)

W

to move marker to the selected vertex automatically ( button in Vectors
additional toolbar)

E

to turn on/off 2D multi-snapping mode – marker moves to vector object ele-
ments (vertices, medians etc.), XY-planemarker coordinates match to coordin-

2

ates of object elements, Z-height of marker is not changed ( button in
Vectors additional toolbar)
to turn on/off 3D multi-snapping mode – marker moves to vector object ele-
ments (vertices, medians etc.), XYZmarker coordinates match to coordinates
of object elements ( button in Vectors additional toolbar)

3

to turn on/off Snapping to points mode – marker snaps to vertices of vector
objects. Label End appears near that vertices ( button in Vectors additional
toolbar)

4

to turn on/off Snapping to medians mode – marker snaps to medians of
vector objects. In case of detecting object segment at the distance of lower

5

than Detect radius, its median is highlighted by small grey circle symbol.
Label Midpoint appears near that medians ( button in Vectors additional
toolbar)
to turn on/off Snapping to linesmode – marker snaps to segments of vector
objects. Label Nearest appears near segment point closest to the marker po-
sition ( button in Vectors additional toolbar)

6

to turn on/off Perpendicular snapping mode (allows to build orthogonal
polylines/polygons and to snap segments of drawing objects to segments of

7

existed objects in perpendicular manner) – button in Vectors additional
toolbar
to turn on/off Snapping to coords mode (allows to build polylines/polygons
orthogonal to the basic or additional coordinate system, as well as accurately

8

orient drawing objects regarding vertices of existed vector objects) – button
in Vectors additional toolbar
to change default axes direction of additional coordinate system ( button in
Vectors additional toolbar)

D

8.2. The “Tools” toolbar

ActionKeyboard shortcut
turns the alignment mode on ( button in Tools additional toolbar)Ctrl+Alt+A
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ActionKeyboard shortcut
to scale vector objects during their transformation in the alignment mode (
button in Tools additional toolbar)

Ctrl+Alt+S

to copy position of marker in 2D-window to clipboard ( button in Tools ad-
ditional toolbar)

Ctrl+Alt+Ins

to move marker to position in 2D-window copied to clipboard ( button in
Tools additional toolbar)

Alt+Shift+Ins

to paste vector objects from clipboard to active vector layer into marker position
( button in Tools additional toolbar)

Ctrl+Shift+V

to select by rectangle in group selection mode (the and buttons in Tools
additional toolbar)

Shift+mousemovewith
pressed left button

Objects selection by polygon in group selection mode by polygon (the button of the Tools
toolbox): Shift + mouse click – used to define first vertex of polygon, mouse click – to specify
every next vertex, double click – to define the last vertex of polygon (to finish a polygon drawing),
Esc – to cancel polygon drawing for objects selecting

8.3. The “Topology” toolbar / The “Topology” menu

ActionKeyboard shortcut
to convert polyline to polygon ( button in Topology additional toolbar)Shift+C
to convert polygon to polyline ( button in Topology additional toolbar)Shift+B
to merge selected polylines into a single one by adding a segment between
two last vertices of merging polylines ( button in Topology additional toolbar)

Shift+P

to merge selected polygons that have overlap or common border ( button
in Topology additional toolbar)

Shift+G

to split a polyline into two ones in the closest to marker vertex ( button in
Topology additional toolbar)

Shift+X

to split several polygons and polylines using “cutting” polyline ( button in
Topology additional toolbar)

Shift+I

to remove a segment connecting two vertices of polyline/polygon ( button
in Topology additional toolbar)

Shift+D

to remove a vertex with adjoining segmentsCtrl+D
to select polyline/polygon vertex closest to marker positionShift+S
to connect creating line to existed one in a closest to marker vertex ( button
in Topology additional toolbar)

Shift+V

to connect creating line to existed one in arbitrary place of segment ( button
in Topology additional toolbar)

Shift+L

to continue construction of the previously created polylineShift+N
to draw a border of one polygon along a border of another one ( button in
Topology additional toolbar)

Shift+M

to create polyline along another polyline up to marker position ( button in
Topology additional toolbar)

Shift+A

to continue creating polyline along another polyline up to nearest join vertex
( button in Topology additional toolbar)

Shift+F
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ActionKeyboard shortcut
to continue creating polyline/polygon along other vector objects up to selected
vertex ( button in Topology additional toolbar)

Shift+Z

to substitute a polyline/polygon fragment ( button in Topology additional
toolbar)

Shift+R

(Vectors › Topology › Object fragment › Select start point of fragment,
see the “Adding/deleting object fragment” chapter of the “Vectorization” User
Manual)

Alt+S

to delete polyline/polygon fragment (Vectors › Topology › Object fragment ›
Delete line fragment)

Alt+D

8.4. The “Geometry” menu

ActionKeyboard shortcut
to move point/vertices to marker position (Vectors › Geometry › Move point
to marker)

J

to move all vertices to marker height (Vectors › Geometry › Move to marker
height)

K

to move marker to selected vertices (Vectors › Geometry › Move marker to
selected point)

~

(Vectors › Geometry › Orthogonalization forward, see the “Vertices editing”
chapter of the “Vectorization” User Manual)

Ctrl+F

(Vectors › Geometry › Orthogonalization backward, see the “Vertices
editing” chapter of the “Vectorization” User Manual)

Ctrl+B

8.5. The “Selection” menu

ActionKeyboard shortcut
to select an object, previous to selectedCtrl+<
to select an object, next to selectedCtrl+>
to select a polyline vertex located before the selected one; sequence of vertices
is displayed when you select a vector object (see the “Vector object properties”
chapter of the “Vectorization” User Manual)

<

to select a polyline vertex located after the selected one; sequence of vertices
is displayed when you select a vector object (see the “Vector object properties”
chapter of the “Vectorization” User Manual)

>

8.6. The “Clipboard” menu

ActionKeyboard shortcut
to copy selected vector objects to the clipboardCtrl+C
to paste vector objects from clipboard to active vector layerCtrl+V
to cut vector objects from active layer and copy them to clipboardCtrl+X
to paste vector objects from clipboard to active vector layer into marker positionCtrl+Shift+V
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8.7. Grid

ActionKeyboard shortcut
to create grid layerCtrl+N,G

8.8. Snapping mode

ActionKeyboard shortcut
duplicate Edit › Snapping › Select a segment for a snapping menu item.
Is used during snapping to the selected segment’s prolongation or parallel

Ctrl+Space

9. Terrain

9.1. Points

ActionKeyboard shortcut
to open layer, containing vector objects (points)Ctrl+O,V

9.2. TIN

ActionKeyboard shortcut
to open layer, containing DTM, represented as a triangular irregular network
(TIN)

Ctrl+O,T

to create DTM as triangular irregular network (TIN), based on points and
structural lines

Ctrl+N,T

to enable/disable editable TIN layer visibilityCtrl+T

9.3. DEM

ActionKeyboard shortcut
to open layer, containing DTM, represented as a DEMCtrl+O,D
to create DTM as a DEM, based on triangular irregular network (TIN)Ctrl+N,D

9.4. Contours

ActionKeyboard shortcut
to create a contours, based on triangular irregular network (TIN)Ctrl+N,C

10. Work in Geomosaic program
• Press and hold the Shift key while creating a preview (Mosaic › Preview and
Mosaic › Preview (current sheet) ) to perform re-calculating of brightness adjust-
ment (duplicate the Mosaic › Rebuild brightness adjustment button).
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